Subject: Re: [DNSOP] A new appoarch for identifying anycast name server instance

From: [email-masked]
Date: Sun, 25 Sep 2011 13:53:46 -0700

On Sun, Sep 25, 2011 at 12:19 PM, Paul Hoffman <[email-masked]>wrote:

> On Sep 25, 2011, at 11:26 AM, [email-masked] wrote:
>
> > We have a draft of our proposal with rationale at
> > http://www.isi.edu/~xunfan/research/draft-anycast-diagnostics.txt
>
> Instead of "ns-diagnostics", using "_ns-diagnostics" would be much better.
> The "_ at the beginning of a label is not a hostname" meme seems to be
> accepted by nearly everyone in the DNS world.

Sure, thanks for the advise. We can add "_" for "instance_id" and "node_id"
also, "_instance_id._ns-diagnostics.$ORIGIN",
"_node_id._ns-diagnostics.$ORIGIN"

>
> You do not define the difference between an "instance" and a "node", and
> RFC 4892 doesn't define "node". Either clearly differentiate them here, or
> maybe just get rid of "node".

Yes, the is not the first time we have this terminology problem. "node" is
defined in RFC 4786 while RFC 4892 use "instance".

We only have a slight explanation of the two in Section 1 the first goal,

"The mechanism should be able to identify both specific anycast
       instances (a specific computer running anycast), and also anycast
       nodes (defined in RFC 4786 [RFC4786] as the topology location
       where multiple instances may run)"

but we should definitely give a clear differentiation at the beginning.

Thanks!

>
> --Paul Hoffman
>
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 25 Sep 2011 14:06:23 -0700

> "_node_id._ns-diagnostics.$ORIGIN"

Sounds good.

> but we should definitely give a clear differentiation at the beginning.

Ah, I missed that. Maybe a two-paragraph terminology section would make it more obvious for the too-quick like me...

--Paul Hoffman

---

From: [email-masked]
Date: Mon, 26 Sep 2011 00:35:20 -0700

Quoting Paul Hoffman <[email-masked]>:

> Ah, I missed that. Maybe a two-paragraph terminology section would make it
> more obvious for the too-quick like me...

Sure, we will do that.