Subject: [DNSOP] FW: New Version Notification for draft-gersch-dnsop-revdns-cidr-02.txt

From: "Joe Gersch" <[email-masked]>
Date: Wed, 2 May 2012 10:22:18 -0600

DNSOP reviewers,

   We have submitted a new revision of draft-gersch-dnsop-revdns-cidr which defines a method for naming CIDR address blocks in the reverse DNS.

   This revision addresses the concerns and suggestions raised at the IETF Paris meeting and from the mailing list.  In particular (from the change log):

   Changes from version 01 to 02

      Concerns were raised at the IETF 83 meeting that the document
      appeared to specific to the routing application.  Several other
      applications were mentioned.  We clarified the introduction to
      show that the naming convention is application agnostic.

      Expanded the related work discussion to include RFC 1101.

      The "m" label is now added even when on an octet boundary.

      Moved all other discussion into the Additional Considerations
      section; removing the alternate naming and replacing it with a
      discussion of existing delegations, adding a section on separating
      prefix and PTR records, added a section on enumerating prefixes
      and finding longest matches.  All these changes reflect comments
      from the mailing list, IETF 83 discussions, and other comments.
      They do not change the naming scheme itself.

      To emphasize the approach is application agnostic, the appendix
      examples were changed from using routing security records to LOC
      records.  Any record type could be used, but LOC records were
      chosen as they were viewed as easy to understand.

Thank you for your comments and ideas,
  - Joe Gersch, Dan Massey and Eric Osterweil

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wed 5/2/2012 10:17 AM
To: Joe Gersch
Cc: [email-masked]; [email-masked]
Subject: New Version Notification for draft-gersch-dnsop-revdns-cidr-02.txt
 
A new version of I-D, draft-gersch-dnsop-revdns-cidr-02.txt has been successfully submitted by Joe Gersch and posted to the IETF repository.

Filename:	 draft-gersch-dnsop-revdns-cidr
Revision:	 02
Title:		 Reverse DNS Naming Convention for CIDR Address Blocks
Creation date:	 2012-05-01
WG ID:		 Individual Submission
Number of pages: 24

Abstract:
   The reverse DNS naming method is used to specify a complete IP
   address.  At present there is no standard way for the reverse DNS to
   handle address ranges.  As an example, there is no formal mechanism
   to define a reverse DNS name for the block of addresses specified by
   the IPv4 prefix 129.82.0.0/16.  Defining such a reverse DNS naming
   convention would be useful for a number of applications.  This draft
   proposes a naming convention for encoding CIDR address blocks into
   the reverse DNS namespace.

The IETF Secretariat

---

From: Ray Bellis <[email-masked]>
Date: Wed, 9 May 2012 15:31:41 +0000

Joe,

The draft says:

"The challenge is to preserve this alignment even when even when CIDR

 prefixes do not fall on octet boundaries.  For example,
 129.82.128.0/19 is a subprefix of 129.82.128.0/18.  The DNS name for
 129.82.128.0/19 should be logically below the DNS name for
 129.82.128.0/18.  This document introduces a naming convention for
 CIDR prefixes that preserves this alignment"

Whilst you've made some changes in -02 relating to the octet boundaries, as far as I can see this assertion is still not true.

The draft shows 129.82/16 mapping to m.82.129.in-addr.arpa, and 129.82.64/18 mapping to 1.0.m.82.129.in-addr.arpa, so that's OK.

However 129/8 would map to m.129.in-addr.arpa, but m.82.129.in-addr.arpa (129.82/16) is _not_ a subdomain of that, even though it is a sub-prefix of the /8.

It seems to be that your scheme works when considering prefixes which are split _within_ an octet, but does not work when considering splits _across_ an octet boundary.

Or have I misunderstood?

kind regards,

Ray