Subject: Re: [DNSOP] [dane] FYI: Verisign files patent application for way of transfering hosting on DNSSEC Domains

From: Tony Finch <[email-masked]>
Date: Mon, 8 Oct 2012 14:58:13 +0100

> On Fri, 5 Oct 2012, John Gilmore wrote:
>
> > [Sounds like somebody should tell the Patent Office that this
> > "invention" is obvious to anyone skilled in the field, before
> > those lovely monopolists at Verisign find themselves with yet
> > another government-granted monopoly.]
> >
> > http://domainnamewire.com/2012/10/05/verisign-files-patent-application-for-way-of-transfering-hosting-on-dnssec-domains/
> >
> >   Verisign files patent application for way of transfering
> >   hosting on DNSSEC Domains

Prior art:
http://tools.ietf.org/html/draft-koch-dnsop-dnssec-operator-change-01

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Forties, Cromarty: East, veering southeast, 4 or 5, occasionally 6 at first.
Rough, becoming slight or moderate. Showers, rain at first. Moderate or good,
occasionally poor at first.

---

From: Ted Lemon <[email-masked]>
Date: Mon, 8 Oct 2012 14:13:28 +0000

> http://tools.ietf.org/html/draft-koch-dnsop-dnssec-operator-change-01

Interesting timing: the Verisign patent was filed two weeks after this draft was published.

---

From: Ray Bellis <[email-masked]>
Date: Mon, 8 Oct 2012 14:35:32 +0000

On 8 Oct 2012, at 15:13, Ted Lemon <[email-masked]<mailto:[email-masked]>> wrote:

On Oct 8, 2012, at 9:58 AM, Tony Finch <[email-masked]<mailto:[email-masked]>> wrote:
Prior art:
http://tools.ietf.org/html/draft-koch-dnsop-dnssec-operator-change-01

Also from April 2011:

<http://conferences.npl.co.uk/satin/presentations/satin2011slides-Crocker.pdf>

I'm pretty sure that an earlier version of this was presented at the DNSSEC Deployment Workshop held in Reston in October 2008.

Ray

---

From: SM <[email-masked]>
Date: Mon, 08 Oct 2012 08:08:47 -0700

>http://tools.ietf.org/html/draft-koch-dnsop-dnssec-operator-change-01

Does this affect draft-ietf-dnsop-rfc4641bis (currently in the RFC 
Editor queue)?

Regards,
-sm

---

From: Tony Finch <[email-masked]>
Date: Mon, 8 Oct 2012 21:27:59 +0100

> <http://conferences.npl.co.uk/satin/presentations/satin2011slides-Crocker.pdf>

That procedure is incorrect: it is missing a wait step between updating the DS and DNSKEY RRsets and updating the NS RRsets. A validator might fetch data from the new operator and try (and fail) to validate it against an old cached keys.

Tony.

---

From: Tony Finch <[email-masked]>
Date: Mon, 8 Oct 2012 21:34:10 +0100

On 8 Oct 2012, at 16:08, SM <[email-masked]> wrote:
> 
> Does this affect draft-ietf-dnsop-rfc4641bis (currently in the RFC Editor queue)?

It's section on change-of-operator was added in revision -03 dated July 2010. Sadly it is buggy.

http://tools.ietf.org/html/draft-ietf-dnsop-rfc4641bis-03#section-4.3.5

Tony.

---

From: Antoin Verschuren <[email-masked]>
Date: Tue, 9 Oct 2012 17:13:30 +0200

> http://tools.ietf.org/html/draft-ietf-dnsop-rfc4641bis-03#section-4.3.5

I
discovered the issue after a DNSSEC workshop by NLNetLabs for SIDN
in 2008, and published about it's remedy internally and on
mailinglists and tried to get a chapter about it in 4641bis.

The first public presentation was made By Olafur in Amsterdam during
the OARC workshop:
https://www.dns-oarc.net/files/workshop-200905/gudmundsson.pdf to get
consencus.

So enough prior art.
Question is more if we need action and if so what.
I don't have any knowledge about the US patent system, or any patent
system as a matter of fact.

- -- 
Antoin Verschuren

Technical Policy Advisor SIDN
Meander 501, PO Box 5022, 6802 EA Arnhem, The Netherlands

P: +31 26 3525500  F: +31 26 3525505  M: +31 6 23368970
mailto:[email-masked]  xmpp:[email-masked]
http://www.sidn.nl/

---

From: Christopher Morrow <[email-masked]>
Date: Tue, 9 Oct 2012 11:27:24 -0400

> system as a matter of fact.

perhaps the questions to ask are:
 1) does it hurt the filing entity to file a claim? (verisign in this case)
 2) does it hurt people using the 'prior art' today? (ietf users of
the technology I suppose)
 3) what remediation is verisign expecting today (or ever)?
 4) what's the cost to fight the claim?

I think for 1 there's very little cost (none maybe), so the rest don't
really matter... file all the patent applications!! (there's a meme
about this...)