Subject: Re: [DNSOP] Models of DNS cache behavior?

From: "Livingood, Jason" <[email-masked]>
Date: Fri, 18 Jan 2013 16:03:01 +0000

If there is anyone out there interested in doing research into DNS
recursive resolvers and are seeking either (1) access to data (stripped of
PII of course) and/or (2) modest funding support, please let me know
off-list.

- Jason

On 2/20/12 2:27 PM, "Emiliano Casalicchio"
<[email-masked]> wrote:

>John,
>may be the model described in this paper can be useful for you.
>
>	Yakup Koç, Almerima Jamakovic, Bart Gijsen, "A Global Reference Model of
>the DNS"
>
>presented at DNS-EASY 2011.
>
>Here the proceedings:
>http://www.gcsec.org/sites/default/files/files/dnseasy2011_final.pdf
>
>Best
>Emiliano
>
>
>
>
>On 18 Feb 2012, at 02:57, John Levine wrote:
>
>> Are there any models of DNS cache behavior, either analytic or
>> simulations?  What I have in mind is something that would help me see
>> whether I should partition a cache among various kinds of traffic, or
>> perhaps limit max TTLs, or experiment with replacement strategies.
>> 
>> For that matter, what's the state of DNS modelling in general?
>> 
>> I found a paper by Jung et al from 2003 on cache models which starts
>> by asserting that caches are so big that entries only drop out due to
>> TTL expiry, did a lot of analysis and simulation, and concluded that
>> 15 minute TTLs got nearly the same cache benefit of 24 hr TTL.
>> 
>> A 2010 paper by Alexiou et al.  models the Kaminsky DNS poisoning
>> attack and the port randomizing fix, which is interesting but not what
>> I'm looking for.  (They conclude that the attack is real, and the fix
>> works OK.)
>> 
>> Anything else I should be looking at?
>> 
>> 
>> -- 
>> Regards,
>> John Levine, [email-masked], Primary Perpetrator of "The Internet for
>>Dummies",
>> Please consider the environment before reading this e-mail. http://jl.ly
>> _______________________________________________
>> DNSOP mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dnsop
>> 
>
>_______________________________________________
>DNSOP mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dnsop

---

From: "Livingood, Jason" <[email-masked]>
Date: Fri, 18 Jan 2013 16:07:16 +0000

Oh, and some interesting questions may include a study of:
- How are TTLs changing over time now that so much content is moving to
CDNs
- What are the recursive resolver effects due to more hyper-giants and CDNs
- Study of large scale auth failures in CDN/content providers and the
resulting effects on recursive resolvers (system shocks where QPS load may
go up 100% - 200% in a few minutes)

Jason

---

From: "Guangqing Deng" <[email-masked]>
Date: Mon, 21 Jan 2013 08:59:43 +0800

Such topic (namely modeling DNS cache behavior) sounds interesting and I’d like to have a try. By the way, is this topic cared about by this work group? 

Guangqing Deng

From: Livingood, Jason
Date: 2013-01-19 00:07
To: Emiliano Casalicchio; John Levine; [email-masked]
Subject: Re: [DNSOP] Models of DNS cache behavior?
Oh, and some interesting questions may include a study of:
- How are TTLs changing over time now that so much content is moving to
CDNs
- What are the recursive resolver effects due to more hyper-giants and CDNs
- Study of large scale auth failures in CDN/content providers and the
resulting effects on recursive resolvers (system shocks where QPS load may
go up 100% - 200% in a few minutes)

Jason