Subject: [DNSOP] Working Group Last Call for draft-ietf-dnsop-as112-dname-00

From: Tim Wicinski <[email-masked]>
Date: Sat, 7 Dec 2013 09:01:55 -0500

Greetings,

We're kicking off the Working Group Last call on using AS112 Redirection 
using DNAME. The authors believe that this document has addressed all 
the issues raised on the document.  The latest version of the draft is 
available at:

     http://www.ietf.org/id/draft-ietf-dnsop-as112-dname-00.txt
     http://tools.ietf.org/html/draft-ietf-dnsop-as112-dname-00

Because of this last call is surrounded by the upcoming holiday season, 
we're making this a four (4) week last call cycle.

Substantive comments and statements of support/opposition for advancing this document should be directed to the mailing list. Editorial
suggestions can be sent directly to the authors. The chairs will send in their comments as well during the last call period. This last call will
conclude on January 3rd, 2014.

thanks
tim

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 7 Dec 2013 08:33:59 -0800

Alas, this document is definitely not ready for publication as an RFC. It still is very unclear which parts are restatements of RFC 6304, which are changes, and which are speculative. Appendix B makes an attempt to make this clearer, but fails spectacularly by saying that Appendix B should be removed from the final document.

The lead paragraph of Appendix B says:

   The following changes are required to [RFC6304] to provide support
   for AS112 redirection.  It is proposed that a successor document to
   [RFC6304] be prepared for joint publication with this document in the
   interests of providing clear advice to prospective new AS112
   operators.  The following sub-sections are hence provided mainly only
   to describe the scope of the changes required for 6304bis, and are
   not intended for publication in this document.  References to this
   section in this document should ultimately be replaced with
   references to 6304bis.

...but there is no successor document seems to have been started. So, now we are left with RFC 6304, a bunch of changes (or not) to it in this document, and no roadmap.

I propose that this document be scrapped completely, and that the RFC 6304 successor simply be published with these changes. That new document should have what is Appendix B of this document as a sub-section of its introduction (because the changes are significant), and should retain Appendix A of this document (because it shows due diligence for the changes).

--Paul Hoffman

---

From: Joe Abley <[email-masked]>
Date: Sat, 7 Dec 2013 17:03:20 -0500

> Alas, this document is definitely not ready for publication as an RFC. It still is very unclear which parts are restatements of RFC 6304, which are changes, and which are speculative. Appendix B ma…

I agree that it's not quite ready for last call, as it stands right now. I was slightly surprised to see the wg last call start, given that (as mentioned in Vancouver, and in the text you quoted) there was an open question about a successor to 6304.

> I propose that this document be scrapped completely, and that the RFC 6304 successor simply be published with these changes. That new document should have what is Appendix B of this document as a s…

I could see that working. I could also see this document proceeding, documenting the change in approach, and a separate document being written to update 6304. It would be good to hear the wider working group's opinion on the preferred direction.

Joe

---

From: Warren Kumari <[email-masked]>
Date: Sun, 8 Dec 2013 13:15:32 -0500

> I agree that it's not quite ready for last call, as it stands right now. I was slightly surprised to see the wg last call start, given that (as mentioned in Vancouver, and in the text you quoted) t…

Yup, this is my fault — I *completely* spaced on the discussions in Vancouver (sadly much of the meeting is a blur).
I did take a quick look through the minutes before asking for WGLC, but they didn’t jog my memory sufficiently. Sorry!

> I could see that working. I could also see this document proceeding, documenting the change in approach, and a separate document being written to update 6304. It would be good to hear the wider wor…

Yes please. 

Abashedly,
W

> 
> 
> Joe
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

--
After you'd known Christine for any length of time, you found yourself fighting a desire to look into her ear to see if you could spot daylight coming the other way.

    -- (Terry Pratchett, Maskerade)

---

From: Tony Finch <[email-masked]>
Date: Mon, 9 Dec 2013 14:55:46 +0000

Tim Wicinski <[email-masked]> wrote:
>
> We're kicking off the Working Group Last call on using AS112 Redirection using
> DNAME. The authors believe that this document has addressed all the issues
> raised on the document.

See https://www.ietf.org/mail-archive/web/dnsop/current/msg10638.html

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Forties, Cromarty: East, veering southeast, 4 or 5, occasionally 6 at first.
Rough, becoming slight or moderate. Showers, rain at first. Moderate or good,
occasionally poor at first.