Subject: [DNSOP] AS112 document question

From: Joe Abley <[email-masked]>
Date: Thu, 22 May 2014 11:33:14 -0400

Hi all,

We have two documents proceeding (in wglc) together, both relating to AS112 service:

  draft-ietf-dnsop-rfc6304bis
  draft-ietf-dnsop-as112-dname

The 6304bis document updates the advice to people running AS112 nodes to incorporate the new scheme described in the as112-dname document, whilst also supporting the current scheme.

William has reminded me that there has been some work done amongst current AS112 operators to add an IPv6 prefix to the current scheme, and that some AS112 operators have deployed it. This makes those AS112 nodes capable of receiving queries over both IPv4 and IPv6, and means the AS112 service overall is IPv6-capable. The IPv6 number resources were obtained by DNS-OARC (I presume from ARIN, although I haven't checked).

The new scheme, described in as112-dname, already supports both IPv4 and IPv6.

We could add advice to AS112 node operators to configure those IPv6 addresses and prefixes to 6304bis.

The nameservers PRISONER.IANA.ORG, BLACKHOLE-1.IANA.ORG and BLACKHOLE-2.IANA.ORG would need AAAA records added in order for resolvers to use IPv6 transport when querying the AS112 servers. This could be added to the IANA Considerations section in 6304bis.

It's possible that the current scheme will be obsoleted by the DNAME approach in the future. This is by no means certain, of course, and we should expect both schemes to be live for some time.

Tim, Suz, colleagues -- what would you prefer? Should we add the IPv6 bits to 6304bis in order to codify IPv6 support for the current scheme, or should we leave the current scheme as-is?

The authors humbly await your instructions :-)

Joe

---

From: Chris Thompson <[email-masked]>
Date: 22 May 2014 17:19:49 +0100

On May 22 2014, Joe Abley wrote:

[...]
>William has reminded me that there has been some work done amongst current
>AS112 operators to add an IPv6 prefix to the current scheme, and that some
>AS112 operators have deployed it.

But does this get exercised at all, as long as blackhole-1.iana.org and
blackhole-2.iana.org have no AAAA records? Is the idea to introduce new
names, or to add AAAA records to the existing names once there are enough
AS112 nodes advertising the IPv6 prefix?

-- 
Chris Thompson               University of Cambridge Information Services,
Email: [email-masked]    Roger Needham Building, 7 JJ Thomson Avenue,
Phone: +44 1223 334715       Cambridge CB3 0RB, United Kingdom.

---

From: Joe Abley <[email-masked]>
Date: Thu, 22 May 2014 12:58:23 -0400

On 22 May 2014, at 12:19, Chris Thompson <[email-masked]> wrote:

> blackhole-2.iana.org have no AAAA records?

No.

> Is the idea to introduce new

For the current AS112 scheme (PRISONER, BLACKHOLE-1, BLACKHOLE-2) the proposal would be

(a) update the advice to AS112 operators so that they have a convenient and accurate reference for how to configure the v6 stuff, and

(b) make a request of the IANA to add the AAAAs to those three names

I would not suggest qualifying (b) above with considerations about availability or node count or anything else, since:

(1) the DNS protocol is demonstrably tolerant of unreachable nameserver addresses,

(2) this is just a sink for unwanted traffic and hence the service expectations are already properly low and

(3) I think it's an unnecessary decision point for IANA staff, who I imagine would be happier carrying out instructions than making subjective judgements that they might be called upon to justify later.

William and I can provide some candidate text for review, but this question was really whether there is support for doing so given that the document is already in wglc.

Joe

---

From: S Moonesamy <[email-masked]>
Date: Sat, 24 May 2014 03:11:49 -0700

Hi Joe,
At 08:33 22-05-2014, Joe Abley wrote:
>The 6304bis document updates the advice to people running AS112 
>nodes to incorporate the new scheme described in the as112-dname 
>document, whilst also supporting the current scheme.
>
>William has reminded me that there has been some work done amongst 
>current AS112 operators to add an IPv6 prefix to the current scheme, 
>and that some AS112 operators have deployed it. This makes those 
>AS112 nodes capable of receiving queries over both IPv4 and IPv6, 
>and means the AS112 service overall is IPv6-capable. The IPv6 number 
>resources were obtained by DNS-OARC (I presume from ARIN, although I 
>haven't checked).
>
>The nameservers PRISONER.IANA.ORG, BLACKHOLE-1.IANA.ORG and 
>BLACKHOLE-2.IANA.ORG would need AAAA records added in order for 
>resolvers to use IPv6 transport when querying the AS112 servers. 
>This could be added to the IANA Considerations section in 6304bis.
>
>It's possible that the current scheme will be obsoleted by the DNAME 
>approach in the future. This is by no means certain, of course, and 
>we should expect both schemes to be live for some time.
>
>Tim, Suz, colleagues -- what would you prefer? Should we add the 
>IPv6 bits to 6304bis in order to codify IPv6 support for the current 
>scheme, or should we leave the current scheme as-is?

I suggest adding the IPv6 bits in 6304bis.  Please see RFC 6890 for 
information about what to put in the (IANA) registries.

Regards,
S. Moonesamy