Subject: Re: [DNSOP] revisiting outstanding dicusses for 6304bis

From: Joel Jaeggli <[email-masked]>
Date: Tue, 24 Feb 2015 12:06:06 -0800

Working group, 

I would direct your attention to the current discuss, here:

https://datatracker.ietf.org/doc/draft-ietf-dnsop-rfc6304bis/ballot/

Should we consider recommendations with respect to treatment of logging or storage of queries or the extent to which such queries should be protected? 

Thanks
Joel

Sent from my iPhone

> On Feb 23, 2015, at 08:25, Kathleen Moriarty <[email-masked]> wrote:
> 
> 
> 
>> On Mon, Feb 23, 2015 at 10:21 AM, Paul Hoffman <[email-masked]> wrote:
>> On Feb 23, 2015, at 7:13 AM, Kathleen Moriarty <[email-masked]> wrote:
>> > Thanks for bringing this to my attention.  The updated text points out the risk, but it would have been nice seeing it phrased in a way to encourage mitigation of that risk (recommend not to log).  It'd easier to attack a system and gain access to logs than to observe session traffic.
>> 
>> AS112 operators do so for the public benefit. There are very good operational reasons why they *should* log, in order to help find bugs and to provide better service. You are asking that the very tiny chance of a privacy breach should trump that operational benefit.
> 
> As an FYI - I wouldn't put this in the privacy bucket, but rather security as it reveals information about a network that could be used in future attacks against the organization leaking their data. 
>> 
>> The mention of the privacy issue with logging is sufficient, and going further would have negative consequences to the operations of this service.
> 
> Mitigating the risks could be helpful and might mean protecting access to logs in cases where logs must be generated. 
> 
> Thanks,
> Kathleen
>> 
>> --Paul Hoffman
> 
> 
> 
> -- 
> 
> Best regards,
> Kathleen

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 24 Feb 2015 15:28:53 -0500

> Should we consider recommendations with respect to treatment of logging or storage of queries or the extent to which such queries should be protected? 

IMO, No.  The text as it stands says, "This could result in logs."
There are lots of operational reasons to log, and the fact that your
leaking queries could result in information about your system being
made public is a reason _not to leak_ in the first place.  That has
nothing to do with operating AS112, which is infrastructure to sink
traffic that never should have made it to the Net in the first place.

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: joel jaeggli <[email-masked]>
Date: Tue, 24 Feb 2015 13:26:08 -0800

> traffic that never should have made it to the Net in the first place.

Ok thanks, this echos my assumptions , but I don't consider myself an
arbiter to taste, at least absence of validation.

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 24 Feb 2015 15:46:49 -0500

On Tue, Feb 24, 2015 at 3:28 PM, Andrew Sullivan <[email-masked]>
wrote:

> > Should we consider recommendations with respect to treatment of logging
> or storage of queries or the extent to which such queries should be
> protected?
> >
>
> Fair point.  I asked for it as an educational point, which hopefully the
operators know to protect logs already.  I'm sure the folks leaking DNS
data don't have a clue their queries are going out, may be logged, and
wouldn't know they were supposed to fix this leakage (or how) it unless
someone told them.

I'll remove the discuss based on the updated text.  Thank you.
Kathleen

-- 

Best regards,
Kathleen