Subject: [DNSOP] I-D Action: draft-ietf-dnsop-qname-minimisation-02.txt

From: [email-masked]
Date: Wed, 04 Mar 2015 04:53:19 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Domain Name System Operations Working Group of the IETF.

        Title           : DNS query name minimisation to improve privacy
        Author          : Stephane Bortzmeyer
	Filename        : draft-ietf-dnsop-qname-minimisation-02.txt
	Pages           : 9
	Date            : 2015-03-04

Abstract:
   This document describes one of the techniques that could be used to
   improve DNS privacy (see [I-D.ietf-dprive-problem-statement]), a
   technique called "qname minimisation".

   REMOVE BEFORE PUBLICATION Discussions of the document should take
   place on the DNSOP working group mailing list [dnsop].

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dnsop-qname-minimisation/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-dnsop-qname-minimisation-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-dnsop-qname-minimisation-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Bob Harold <[email-masked]>
Date: Wed, 4 Mar 2015 08:10:11 -0500

I think the change in section 4 "Performance implications" is incorrect:

in -01:
the total number of upstream queries under qname
minimisation would be counter-intuitively less than the number of
queries under the traditional iteration

in -02:
the total number of upstream queries under qname
minimisation would be counter-intuitively inferior to the number of
queries under the traditional iteration

-- But "less than" is better, not 'inferior' ?
I think "less than" is the proper wording.

-- 
Bob Harold
hostmaster, UMnet, ITcom
Information and Technology Services (ITS)
[email-masked]
734-647-6524 desk

On Wed, Mar 4, 2015 at 7:53 AM, <[email-masked]> wrote:

> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 9 Mar 2015 15:12:35 +0100

On Wed, Mar 04, 2015 at 08:10:11AM -0500,
 Bob Harold <[email-masked]> wrote 

> I think the change in section 4 "Performance implications" is incorrect:

This was reported by a native english speaker and committed here
<https://github.com/bortzmeyer/my-IETF-work/commit/4d8c75529ccec0cea334d78a665f73ebde27d897#diff-64cb8059630496a308f9d7d0f81ff316L197>

If I understand you, "inferior" in english has only the meaning "not
as good as" and never "fewer than" (which may be a good thing, which
is the case here)?

---

From: Bob Harold <[email-masked]>
Date: Mon, 9 Mar 2015 10:21:48 -0400

On Mon, Mar 9, 2015 at 10:12 AM, Stephane Bortzmeyer <[email-masked]>
wrote:

> <
> https://github.com/bortzmeyer/my-IETF-work/commit/4d8c75529ccec0cea334d78a665f73ebde27d897#diff-64cb8059630496a308f9d7d0f81ff316L197
> >
>
> Yes, that is how I understand it.  Can someone else confirm or deny?

---

From: "Niall O'Reilly" <[email-masked]>
Date: Mon, 09 Mar 2015 15:00:41 +0000

On Mon, 09 Mar 2015 14:21:48 +0000,
Bob Harold wrote:
> 
> On Mon, Mar 9, 2015 at 10:12 AM, Stephane Bortzmeyer
> <[email-masked]> wrote:
> 
>     <https://github.com/bortzmeyer/my-IETF-work/commit/4d8c75529ccec0cea334d78a665f73ebde27d897#diff-64cb8059630496a308f9d7d0f81ff316L197
>    >
>     

  Gladly.  Confirmed for practical purposes in the majority of cases.

  Best regards,
  Niall O'Reilly

---

From: "Rose, Scott W." <[email-masked]>
Date: Mon, 9 Mar 2015 11:22:41 -0400

According to my dictionary (as in, at least US english).

The usual phrasing in the sentence would be "less than" or "fewer than".  

Scott

On Mar 9, 2015, at 10:21 AM, Bob Harold <[email-masked]> wrote:

> 
> On Mon, Mar 9, 2015 at 10:12 AM, Stephane Bortzmeyer <[email-masked]> wrote:

===================================
Scott Rose
NIST
[email-masked]
+1 301-975-8439
Google Voice: +1 571-249-3671
http://www.dnsops.gov/
https://www.had-pilot.com/
===================================

---

From: Evan Hunt <[email-masked]>
Date: Mon, 9 Mar 2015 17:41:49 +0000

> The usual phrasing in the sentence would be "less than" or "fewer than".  

Suggested alternate wording:

 Thus, in some cases, a resolver using qname minimisation 
 could send counter-ituitively fewer upstream queries than
 a traditional iterative resolver.

-- 
Evan Hunt -- [email-masked]
Internet Systems Consortium, Inc.