Subject: Re: [DNSOP] [TCP] Review of draft-ietf-dnsop-5966bis-00.txt

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 9 Mar 2015 17:32:17 +0100

I re-send here two questions that have apparently not been addressed
in -01

On Sun, Jan 04, 2015 at 06:42:26PM +0100,
 Stephane Bortzmeyer <[email-masked]> wrote 
 a message of 37 lines which said:

> Section 3, "some network devices deliberately refuse to handle DNS
> packets containing EDNS0 options" Isn't it true of DNS-over-TCP as
> well? SAC035 is pessimistic (see table 2). Do we have other data on
> TCP (lack of) support in middleboxes?

> In the same section, should we add a word about poisoning attacks?
> AFAIK, at least one resolver, CNS, switches to TCP when it receives
> too many answers with the wrong Query ID. Should we document that
> the use of TCP may make poisoning more difficult?

---

From: Ray Bellis <[email-masked]>
Date: Mon, 9 Mar 2015 16:58:14 +0000

> On 9 Mar 2015, at 16:32, Stephane Bortzmeyer <[email-masked]> wrote:
> 

Stephane, can you please elaborate - are you specifically talking about EDNS0 options when inside a TCP connection, or just plain support for any TCP at all?

In the latter case, that's already addressed by RFC 5625 and to an extent by RFC 5966 and shouldn't (IMHO) need further elaboration.

kind regards,

Ray

---

From: John Dickinson <[email-masked]>
Date: Tue, 10 Mar 2015 15:21:54 +0000

> I re-send here two questions that have apparently not been addressed

Hi Stephane,

Sorry, this was my oversight. I have added them to the issue tracker at https://github.com/DNSOP/draft-5966-bis. I will make sure they are addressed in the next issue and possibly in the slot at the dnsop meeting.

regards
John

> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop