Subject: Re: [DNSOP] Requesting review of draft-ietf-dnssd-mdns-dns-interop-01

From: Ralph Droms <[email-masked]>
Date: Fri, 7 Aug 2015 16:08:00 -0400

Second try...

> On Jul 21, 2015, at 4:06 AM 7/21/15, Ralph Droms (rdroms) <[email-masked]> wrote:
> 
> Hi - The dnssd chairs would like to get some reviews of draft-ietf-dnssd-mdns-dns-interop-01, "On Interoperation of Labels Between mDNS and DNS," from dnsop participants.  draft-ietf-dnssd-mdns-dns-interop-01 is currently in dnssd WG last call and last call comments will be discussed in the dnssd WG meeting this week. 
> 
> Please post your feedback to dnsop or send to Tim and myself.
> 
> - Ralph
> 
> 
>

---

From: Bob Harold <[email-masked]>
Date: Mon, 10 Aug 2015 13:29:25 -0400

On Fri, Aug 7, 2015 at 4:08 PM, Ralph Droms <[email-masked]> wrote:

> > Hi - The dnssd chairs would like to get some reviews of
> draft-ietf-dnssd-mdns-dns-interop-01, "On Interoperation of Labels Between
> mDNS and DNS," from dnsop participants.
> draft-ietf-dnssd-mdns-dns-interop-01 is currently in dnssd WG last call and
> last call comments will be discussed in the dnssd WG meeting this week.
> >
I think I understand it, and it seems good to me.

Minor NIT - I would like the "LDH" acronym expanded or possibly defined the
first time it is used.  I knew the rule but was unfamiliar with the
acronym, requiring a search to figure it out.

-- 
Bob Harold

---

From: 神明達哉 <[email-masked]>
Date: Tue, 11 Aug 2015 10:07:31 -0700

At Fri, 7 Aug 2015 16:08:00 -0400,
Ralph Droms <[email-masked]> wrote:

> > draft-ietf-dnssd-mdns-dns-interop-01, "On Interoperation of Labels
> > Between mDNS and DNS," from dnsop participants.
> > draft-ietf-dnssd-mdns-dns-interop-01 is currently in dnssd WG last
> > call and last call comments will be discussed in the dnssd WG
> > meeting this week.
> >

I've read the draft.  Although I'm not really familiar with IDNA
(readers are supposed to be familiar with it according to Section
1.1), I think it's generally well written and useful.  One feedback as
a non-familiar reader that might be useful is that it would be more
helpful if this document provides some specific examples that are and
are not compliant with the proposed profile.

And, I noticed one very minor editorial issue: in the first paragraph
of Section 3:

   Any interoperability between DNS (including prevailing operational
   conventions and other resolution technologies will require
   interoperability across the portions of a DNS-SD Service Instance
   Name that are implicated in regular DNS lookups.

The parenthesis is not closed.  I guess there should be a closing
parenthesis after "conventions".

--
JINMEI, Tatuya