Subject: [DNSOP] update to the WG: moving forward on RFC 6761 review

From: Suzanne Woolf <[email-masked]>
Date: Thu, 8 Oct 2015 22:56:38 -0400

Dear Colleagues,

The WG has been through significant controversy in 2014-2015 on the topic of RFC 6761. This note is an update on actions the chairs are taking to address the issues raised by the lengthy and contentious WG and IETF Last Call processes on recent drafts requesting updates to the Special Use names registry.

We've taken a short time-out from the subject in order to allow the dust to settle in the WG, and to allow the IETF last call and IESG review processes to proceed to a conclusion regarding draft-ietf-dnsop-onion-tld-01. As we expected when we discussed the subject in the Prague IETF meeting, that process resulted in the addition of .onion to the special use names registry, debate on the application of the RFC 6761 process, and some guidance from the IESG. 

In a blog post on the subject, Jari Arkko, IETF chair, wrote:

"However, subsequent to this action [approving draft-ietf-dnsop-onion-tld-01], the IESG believes RFC 6761 needs action, and substantial community input. It needs to be open for review and modification because the current process is unscalable. Several other names had also been submitted for consideration as special names, and the RFC may not give adequate guidance about how when names should be identified as special names. Special names should also be, as the name implies – special and rare. The DNSOP working group is chartered to address this RFC 6761 review."

As we announced in Prague we're moving forward with a small design team to review the issues raised by these many months of discussion and controversy, and per our AD's request, begin to shape a proposal based on the experience and discussion so far.  We realize this is not a path what will meet with universal approval, but it's seemed to us, in consultation with the IESG, to be the path most likely to help us make progress within the IETF on these issues.

For the rules about design teams in the IETF, see https://www.ietf.org/iesg/statement/design-team.html, and note particularly: 

"Anyone can write an alternative proposal and ask the working group to consider it. The decision on which document to work further on must be made by the consensus of the working group. If design teams work as intended, their output will be of a quality that speaks for itself."

Design team mission statement:

"Efforts by the IETF to administer the Special Use Names registry under the provisions of RFC 6761 have proven to be controversial, consume large amounts of time and attention, and lead to outcomes that are confusing, unsatisfying, or both to operators and implementers. As a first stage towards implementing the guidance of the IESG on this subject (http://www.ietf.org/blog/2015/09/onion/, and IESG comments during the discussion of the draft at http://datatracker.ietf.org/doc/draft-ietf-dnsop-onion-tld/ballot/), the DT is asked to produce a brief internet-draft for Yokohama, outlining the issues. It's expected to be structured as a problem statement to the extent practical, as we've come to the preliminary conclusion that one of the challenges in applying RFC 6761 is that it's unclear on what problem it's intended to solve and what criteria to consider.

We will NOT proceed further without WG consensus on what problem(s) we're trying to solve with the Special Use names registry, and there is NO presumption that the WG will carry forward the design team's work in any case. The first work item of the DT is an initial attempt to pull together the discussion to date, including multiple DNSOP WG sessions at four IETF meetings and several thousand email messages to DNSOP (on multiple drafts) and the IETF discuss list (particularly on the draft-ietf-dnsop-onion-tld last call)."

Current members (brave souls willing to begin work):
	Joe Abley, Dyn
	Alain Durand, ICANN
	Peter Koch, DENIC

We would like the Design Team to be slightly larger, so are looking for 1-2 additional volunteers. Please let the chairs know if you're willing to be part of this work.

best regards,
Suzanne & Tim

---

From: hellekin <[email-masked]>
Date: Thu, 15 Oct 2015 12:22:35 -0300

On 10/08/2015 11:56 PM, Suzanne Woolf wrote:
> 
> We would like the Design Team to be slightly larger, so are looking
> for 1-2 additional volunteers. Please let the chairs know if you're
> willing to be part of this work.
>

Hello,

I sent you my will to volunteer a few days ago but it might not have
passed your filters, so here it is again on the list.  I'm volunteering
to participate in the WG dedicated to revising RFC6761.

Regards,

==
hk

---

From: Ted Lemon <[email-masked]>
Date: Thu, 15 Oct 2015 14:00:35 -0400

> to participate in the WG dedicated to revising RFC6761.

They didn’t reply to me either yet.   Bear in mind that working group chairs work on a volunteer basis…

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 15 Oct 2015 14:20:36 -0400

Hi 

Suzanne and I are going to be at ICANN next week so we decided to sit down then. 

I've been using this time getting things lined up for Yokohama 

Tim

From my high tech gadget

> On Oct 15, 2015, at 14:00, Ted Lemon <[email-masked]> wrote:
> 
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop