Subject: [DNSOP] Draft -domain-names-01

From: Edward Lewis <[email-masked]>
Date: Fri, 30 Oct 2015 11:23:24 +0000

A while back I floated a draft across this mail list and got (what I
think) is sufficient (perhaps not the right word) feedback from the WG.  I
updated the document and resubmitted.  FWIW, this is the document link:
        https://tools.ietf.org/html/draft-lewis-domain-names-01

I'm not even asking for comment on the list (but you can if you want).
When I rev'd the document, I didn't mention it on this list (until now).

What I'm asking for is - when in Yokohama, if you have an interest in this
I'm willing to discuss.

The issue in the document is both internal to DNS and external to DNS, I'm
looking for broader input (such as applications area topics).

Ed

---

From: Bob Harold <[email-masked]>
Date: Fri, 30 Oct 2015 09:34:20 -0400

On Fri, Oct 30, 2015 at 7:23 AM, Edward Lewis <[email-masked]>
wrote:

> I have to disagree with one section:

Section 3.1 includes:

A DNS domain name "192.0.2.1." can be configured and used in the
protocol.  The usefulness of this is limited by the concerns
described later on in Interoperability Considerations.  An outcome of
that the convention of representing the Domain Name "192.0.2.1." as

"1.2.0.192.in-addr.arpa."

I agree that "192.0.2.1." is a domain name.  But it is a totally different
domain name than "1.2.0.192.in-addr.arpa.".

"1.2.0.192.in-addr.arpa." is the typical domain name representation of the
IP address "192.0.2.1", which is a 32 bit number, not a name.  There is no
'root' or trailing dot in an IP address.

-- 
Bob Harold

---

From: "Darcy Kevin (FCA)" <[email-masked]>
Date: Fri, 30 Oct 2015 20:48:30 +0000

I think there’s something elided from that sentence, since, irrespective of semantics, “An outcome of that the convention …” isn’t even grammatically-correct English.

                                                                                                - Kevin

From: DNSOP [mailto:[email-masked]] On Behalf Of Bob Harold
Sent: Friday, October 30, 2015 9:34 AM
To: Edward Lewis
Cc: dnsop
Subject: Re: [DNSOP] Draft -domain-names-01

On Fri, Oct 30, 2015 at 7:23 AM, Edward Lewis <[email-masked]<mailto:[email-masked]>> wrote:

Ed

Section 3.1 includes:

I agree that "192.0.2.1." is a domain name.  But it is a totally different domain name than "1.2.0.192.in-addr.arpa.".

"1.2.0.192.in-addr.arpa." is the typical domain name representation of the IP address "192.0.2.1", which is a 32 bit number, not a name.  There is no 'root' or trailing dot in an IP address.

--
Bob Harold

---

From: Edward Lewis <[email-masked]>
Date: Sat, 31 Oct 2015 07:40:27 +0000

Bob's point is correct (I certainly agree/that's what I meant to convey) and Kevin is right, something got lost between brain and keyboard.

Thanks.

Sent from aomething with no kybosrd.

On Oct 31, 2015, at 05:49, Darcy Kevin (FCA) <[email-masked]<mailto:[email-masked]>> wrote:

I think there's something elided from that sentence, since, irrespective of semantics, "An outcome of that the convention ..." isn't even grammatically-correct English.

                                                                                                - Kevin

Ed

Section 3.1 includes:

--
Bob Harold

_______________________________________________
DNSOP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dnsop