Subject: Re: [DNSOP] I-D Action: draft-ietf-dnsop-no-response-issue-01.txt

From: Bob Harold <[email-masked]>
Date: Fri, 11 Dec 2015 14:22:31 -0500

On Mon, Nov 30, 2015 at 11:07 PM, <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>  This draft is a work item of the Domain Name System Operations Working
> Group of the IETF.
>
>         Title           : A Common Operational Problem in DNS Servers -
> Failure To Respond.
>         Author          : M. Andrews
>         Filename        : draft-ietf-dnsop-no-response-issue-01.txt
>         Pages           : 16
>         Date            : 2015-11-30
>
> Abstract:
>    The DNS is a query / response protocol.  Failure to respond or to
>    respond correctly to queries causes both immediate operational
>    problems and long term problems with protocol development.
>
>    This document identifies a number of common classes of queries to
>    which some servers either fail to respond or else respond
>    incorrectly.  This document also suggests procedures for TLD and
>    other similar zone operators to apply to help reduce / eliminate the
>    problem.
>
>    The document does not look at the DNS data itself, just the structure
>    of the responses.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-dnsop-no-response-issue/
>
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-ietf-dnsop-no-response-issue-01
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-dnsop-no-response-issue-01
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
>
> Minor nits:

Section 4.  Firewalls and Load Balancers

"Requests with unknown EDNS versions is expected client behaviour
should not be trued as an attack The correct"

should be:

"Requests with unknown EDNS versions is expected client behaviour
and should not be construed as an attack.  The correct"

change "should" to "and should"
change "trued" to "construed"
change "attack" to "attack. "

-- 
Bob Harold

---

From: Mark Andrews <[email-masked]>
Date: Sat, 12 Dec 2015 06:38:19 +1100

> change "attack" to "attack. "

Added to next version.
 
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]