Subject: [DNSOP] A nudge on the new terms in draft-ietf-dnsop-terminology-bis

From: "Paul Hoffman" <[email-masked]>
Date: Wed, 08 Feb 2017 16:31:56 -0500

[[ Hopefully the WG can focus on multiple topics at once; this one has 
an effect on the upcoming interim WG meeting. ]]

[[ We got a few responses to our earlier message about the new terms in 
draft-ietf-dnsop-terminology-bis-04, but would certainly like to hear 
more. From our earlier message: ]]

The authors have tentatively made some substantial changes to the draft, 
to define "domain name", "global DNS", and "private DNS" in a manner 
that can be used by other work in the IETF, particularly around RFC 
6761. Our first cut of definitions are in the new draft, but we fully 
expect significant discussion in the WG before there is even rough 
consensus. We are not even sure that the WG will agree with the idea of 
adding "global DNS" and "private DNS" to the document. The authors are 
not even sure they agree with all of this.

At the same time, we think that it would be easier to track open issues 
in our GitHub repo at 
https://github.com/DNSOP/draft-ietf-dnsop-terminology-bis rather than in 
the document as comments. To be clear, the discussion of how issues are 
to be resolved should be mostly done on the mailing list, but using 
GitHub to track issues might give easier-to-follow history of the 
discussions. We also are open to using GitHub for pull requests for 
specific changes to the document.

As a final note, this version of the draft also has some changes not 
related to the above, and we encourage review of those changes, plus 
anything else in the draft, of course.

--Paul Hoffman

On 27 Jan 2017, at 10:08, [email-masked] wrote:

> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> This draft is a work item of the Domain Name System Operations of the 
> IETF.
>
>         Title           : DNS Terminology
>         Authors         : Paul Hoffman
>                           Andrew Sullivan
>                           Kazunori Fujiwara
> 	Filename        : draft-ietf-dnsop-terminology-bis-04.txt
> 	Pages           : 34
> 	Date            : 2017-01-27
>
> Abstract:
>    The DNS is defined in literally dozens of different RFCs.  The
>    terminology used by implementers and developers of DNS protocols, 
> and
>    by operators of DNS systems, has sometimes changed in the decades
>    since the DNS was first defined.  This document gives current
>    definitions for many of the terms used in the DNS in a single
>    document.
>
>    This document will be the successor to RFC 7719.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-dnsop-terminology-bis/
>
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-ietf-dnsop-terminology-bis-04
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-dnsop-terminology-bis-04

---

From: Ralph Droms <[email-masked]>
Date: Thu, 9 Feb 2017 08:53:35 -0500

Paul - I finished my review of the terminology doc; added 1 issue today.

- Ralph

> On Feb 8, 2017, at 4:31 PM, Paul Hoffman <[email-masked]> wrote:
> 
> [[ Hopefully the WG can focus on multiple topics at once; this one has an effect on the upcoming interim WG meeting. ]]
> 
> [[ We got a few responses to our earlier message about the new terms in draft-ietf-dnsop-terminology-bis-04, but would certainly like to hear more. From our earlier message: ]]
> 
> The authors have tentatively made some substantial changes to the draft, to define "domain name", "global DNS", and "private DNS" in a manner that can be used by other work in the IETF, particularly around RFC 6761. Our first cut of definitions are in the new draft, but we fully expect significant discussion in the WG before there is even rough consensus. We are not even sure that the WG will agree with the idea of adding "global DNS" and "private DNS" to the document. The authors are not even sure they agree with all of this.
> 
> At the same time, we think that it would be easier to track open issues in our GitHub repo at https://github.com/DNSOP/draft-ietf-dnsop-terminology-bis rather than in the document as comments. To be clear, the discussion of how issues are to be resolved should be mostly done on the mailing list, but using GitHub to track issues might give easier-to-follow history of the discussions. We also are open to using GitHub for pull requests for specific changes to the document.
> 
> As a final note, this version of the draft also has some changes not related to the above, and we encourage review of those changes, plus anything else in the draft, of course.
> 
> --Paul Hoffman
> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> This draft is a work item of the Domain Name System Operations of the IETF.
>> 
>>        Title           : DNS Terminology
>>        Authors         : Paul Hoffman
>>                          Andrew Sullivan
>>                          Kazunori Fujiwara
>>   terminology used by implementers and developers of DNS protocols, and
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

---

From: Edward Lewis <[email-masked]>
Date: Fri, 10 Feb 2017 13:12:28 +0000

>    The authors have tentatively made some substantial changes to the draft, 
     to define "domain name"

I have a fundamental problem with that, meaning that a document within DNSOP is defining domain names.  Work I did to write (the still in progress) draft on Domain Names has led me to believe that domain names are a concept beyond the DNS protocol.  On the other hand, the DNS protocol and operators of it, deserve to have a definition in place, so I'm not totally convinced this is a bad idea.

Diving into the definition contained in the draft though, it needs work.  Referring to:

https://tools.ietf.org/html/draft-ietf-dnsop-terminology-bis-04, for "Domain Name" and "Label" :

) Domain name:  An ordered list of zero or more labels.

) Label:  An ordered list of zero or more octets and which makes up a
       portion of a domain name.

This is a circular definition which makes it quite meaningless.  E.g., "A is a string of B's" and "B is a component of A."

I don't have a suggested fix.  In as much as this isn't worth the paper you are reading this on, I've been trying to find time to update my draft on Domain Names, including, for now, rules on what would make a good definition.  I only mention this to express my frustration over not having something better to offer.

The closest I have to a suggestion is to put any definition of Domain Name in a DNS terminology document strictly in the context of documentation on the DNS protocol, at least for now.

---

From: Viktor Dukhovni <[email-masked]>
Date: Mon, 13 Feb 2017 23:34:35 +0000

On Fri, Feb 10, 2017 at 01:12:28PM +0000, Edward Lewis wrote:

> I have a fundamental problem with that, meaning that a document within
> DNSOP is defining domain names.  Work I did to write (the still in progress)
> draft on Domain Names has led me to believe that domain names are a concept
> beyond the DNS protocol.  On the other hand, the DNS protocol and operators
> of it, deserve to have a definition in place, so I'm not totally convinced
> this is a bad idea.
> 
> This is a circular definition which makes it quite meaningless.  E.g., "A
> is a string of B's" and "B is a component of A."

The definition is not as circular as it may seem.  A domain is a
sequence of labels, and a labels is a sequence of octets.  My beef
would be with the "zero or more" part, as applied to labels, since
zero length labels (if construed as actual labels rather than just
termination sentinels) do not occur except to terminate a domain
name.  Otherwise, if the zero length terminator is a label, then
domains have at least one (terminal zero-length) label.

I would also be tempted to not designate relative names as "domain
names".  To me, those are just sequences of labels that make up an
initial part of a domain name.

Not sure whether such hair splitting is needed.  The important
take-away from the definitions is that the document defines domain
names abstractly, as nodes on a rooted acyclic directed graph with
siblings distinguished by distinct non-empty octet strings known
as labels.  The sequence of labels from a node up to the root is
its domain name.  Such domain names can then represented in various
semantically equivalent forms.

-- 
	Viktor.

---

From: Richard Gibson <[email-masked]>
Date: Mon, 13 Feb 2017 18:54:28 -0500

On Mon, Feb 13, 2017 at 6:34 PM, Viktor Dukhovni <[email-masked]>
wrote:

> My beef

https://github.com/DNSOP/draft-ietf-dnsop-terminology-bis/issues/6