Subject: [DNSOP] I-D Action: draft-ietf-dnsop-session-signal-04.txt

From: [email-masked]
Date: Wed, 13 Sep 2017 02:28:28 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Domain Name System Operations WG of the IETF.

        Title           : DNS Stateful Operations
        Authors         : Ray Bellis
                          Stuart Cheshire
                          John Dickinson
                          Sara Dickinson
                          Allison Mankin
                          Tom Pusateri
	Filename        : draft-ietf-dnsop-session-signal-04.txt
	Pages           : 32
	Date            : 2017-09-13

Abstract:
   This document defines a new DNS Stateful Operation OPCODE used to
   communicate operations within persistent stateful sessions, expressed
   using type-length-value (TLV) syntax, and defines an initial set of
   TLVs used to manage session timeouts and termination.  This mechanism
   is intended to reduce the overhead of existing "per-packet" signaling
   mechanisms with "per-message" semantics as well as defining new
   stateful operations not defined in EDNS(0).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dnsop-session-signal/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dnsop-session-signal-04
https://datatracker.ietf.org/doc/html/draft-ietf-dnsop-session-signal-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dnsop-session-signal-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Sara Dickinson <[email-masked]>
Date: Wed, 13 Sep 2017 10:31:12 +0100

Hi All, 

Based on the discussions at IETF 99 and on the list this update to the draft makes a number of changes:

* The Title of the draft has been changed to ‘DNS Stateful Operations’ (DSO) to reflect the fact that the TLV format is not limited to being used for signalling
* The draft now updates RFC1035
* The term 'DSO session’ is used throughout for clarity
* A paragraph has been added to the Introduction to discuss the use of a new format
* Several terms in the Terminology section have been updated and some new ones added
* Clarified the use of the words timer and timeout throughout the document
* A short discussion section has been added with specific use cases
* The specific mention of QUIC has been removed, the text now just describe the properties of the transport used for DSO. 
* The text has been updated to specify that messages must be processed in the order they were sent (not received)
* A modifier Encrypted Padding TLV has been added to support padding of encrypted queries
* The text describing the behaviour of middle-boxes has been updated
* The set of RCODES defined in the document has been extended
* Responses to DSO messages are now optional: An Acknowledgement bit has been added to the DSO data format which specifies if the DSO message requires an acknowledgement response
* A section has been added to specify exactly what a client should to with the timers/timeouts when receiving a Keepalive TLV
* The section on Connection sharing is now consistent with RFC7766

Regards

Sara. 

> On 13 Sep 2017, at 10:28, [email-masked] wrote:
> 
> 
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop