Subject: Re: [DNSOP] [Ext] New draft for helping browsers use the DoH server associated with a resolver

From: Paul Hoffman <[email-masked]>
Date: Sun, 2 Sep 2018 00:36:44 +0000

On Aug 31, 2018, at 7:36 AM, John Dickinson <[email-masked]> wrote:
> Just trying to read this draft in detail and I find section 3 a bit confusing. You use terms such as client and resolver but at times it is not clear if you are referring to the OS stub, a third party stub, caching resolver, application or browser. Maybe using terms from your terminology draft would help.

The client is always "the thing emitting DNS queries"; the draft doesn't assume what other role (OS, browser, webapp, ...) the client plays. This is always going to be a problem for us with DoH, and I agree that we can have careful wording around it.

--Paul Hoffman

---

From: Tony Finch <[email-masked]>
Date: Tue, 4 Sep 2018 17:05:57 +0100

Paul Hoffman <[email-masked]> wrote:

> https://tools.ietf.org/html/draft-hoffman-resolver-associated-doh-01

This draft specifies that the new zone is delegated to the AS112 servers,
but RFC 7534 says the "direct delegation" approach is only supported for
the original AS112 zones. As I understand it the plan for new blackhole
zones is to use DNAME redrection to empty.as112.arpa.

It might be worth generalizing this to a catch-all zone for publishing
information about a recursive server (including the recommended DoH
endpoint, and whatever else might arise). On the other hand we already
have the widely copied bind./CH zone...

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
contribute to the process of peace and disarmament, the elimination
of world poverty, and the collective safeguarding of democracy