Subject: [DNSOP] Adding more example configurations to draft-ietf-dnsop-7706bis

From: Paul Hoffman <[email-masked]>
Date: Wed, 12 Sep 2018 17:57:17 +0000

Greetings again. One of the things that people said they wanted in 7706bis is more example configurations for different systems. We currently have:
- BIND 9.9 with views
- Unbound 1.4 and NSD 4
- Microsoft Windows Server 2012
I'll test BIND 9.10 with views to see if it's the same setup, and also more recent Unbound/NSDs.

I have seen messages in the past few months about some vendors adding 7706, or 7706-like, support to recent versions of their resolvers. It would be grand if those of you who have shipping implementations of this could send the configuration steps to the list so we can add them to the appendix.

--Paul Hoffman

---

From: Vladimír Čunát <[email-masked]>
Date: Thu, 13 Sep 2018 15:31:27 +0200

Hello.

On 9/12/18 7:57 PM, Paul Hoffman wrote:
> One of the things that people said they wanted in 7706bis is more > example configurations for different systems.
In Knot-resolver we decided to support an alternative approach:
aggressive caching with a module that keeps the root zone fresh in
cache.  We find such a setup much simpler, as you don't need another
daemon to run and configure.
https://knot-resolver.readthedocs.io/en/stable/modules.html#cache-prefilling

I'm not sure if such approaches are worth of additional mention in
7706bis.  You have
> A different approach to solving the problems discussed in this > document is described in [RFC8198]. That RFC does not seem to
explicitly mention similar prefetching workflow to achieve the
additional bonus of "guaranteed" latency and avoiding TLD typo leakage,
but I suppose that might be considered simple enough to be left as an
exercise to the readers.

--Vladimir