Subject: Re: [DNSOP] Creating a registry for reserved labels.

From: Paul Hoffman <[email-masked]>
Date: Thu, 27 Sep 2018 15:42:33 +0000

On 27 Sep 2018, at 8:13, Warren Kumari wrote:

> During the discussions on KSK Sentinel and MTA-STS (
> https://datatracker.ietf.org/doc/draft-ietf-uta-mta-sts/20/) the IESG noted
> that we recently have twice "reserved" use of a left hand (non-underscore)
> label.
>
> It is strongly felt that a registry to record names like this would be
> useful.
>
> Some examples of these names include:
> root-key-sentinel-not-ta-<number>.
> mta-sts.
> xn--(anything).

xn--(anything) labels can appear anywhere.

> Ok, good point.... but, I still think that labels which get special
> handling should be recorded *somewhere*, simply to satisfy the principle of
> least astonishment...

Fully agree. However, the registry should probably be for "special handling", not just for left-most position.
>
> So, does would anyone be willing to volunteer to write a "Special Use
> Labels" document (similar to draft-ietf-dnsop-attrleaf) simply creating a
> registry for "these left hand labels are special / funny in some way" ?

Sure.

--Paul Hoffman

---

From: Geoff Huston <[email-masked]>
Date: Fri, 28 Sep 2018 18:03:17 +0000

fwiw I agree with Warren’s proposal and Paul’s observation that such a registry is
a good idea and it need not reflect only left-most labels.

However, I worry that this approach does not generalise and scale well and the registry
maintenance guidelines should reflect an appropriately rigorous and conservative attitude to
further additions.

But its a useful registry to have in any case imho

Geoff

> On 28 Sep 2018, at 1:42 am, Paul Hoffman <[email-masked]> wrote:
>

---

From: Warren Kumari <[email-masked]>
Date: Fri, 28 Sep 2018 11:27:26 -0700

> maintenance guidelines should reflect an appropriately rigorous and
Yup.

We are adding (at the IESG's request) this (thanks to Terry for the text):
------
"The special labels defined here came after extensive IETF evaluation
of alternative patterns and approaches in light of the desired
behaviour (sections 2.1, 2.2) within the resolver and the applied
testing methodology (section 4.3).  As one example, underscore
prefixed names were rejected because a number of browsers / operating
systems would not fetch them, as they were not viewed as valid
"hostnames". Attention was paid to the consideration of local
collisions and the reservation of Left Hand Side (LHS) labels of a
domain name, and the impact upon zone operators who might desire to
use a similarly constructed hostname for a purpose other than as
documented here.  Therefore, it is important to note that the
reservation of the labels in this manner is definitely not considered
"best practice".
-----
to the KSK document. The registry creation document should contain some
language explaining that this sort of thing is a poor design-pattern[0],
and should be avoided unless there is a really good reason.... but, if
people do things like this, having them documented is better than
astonishment.

W
[0]: Worst Current Practice?!

> > Fully agree. However, the registry should probably be for "special
> handling", not just for left-most position.
> >>
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 28 Sep 2018 20:20:29 +0000

On Sep 28, 2018, at 11:27 AM, Warren Kumari <[email-masked]> wrote:
> to the KSK document. The registry creation document should contain some language explaining that this sort of thing is a poor design-pattern[0], and should be avoided unless there is a really good reason....

I agree that new document that I volunteered to edit (are there any offers of co-editors?) should have similar language. I fully disagree that it is a "poor design pattern". It has been shown over and over to work well.

> but, if people do things like this, having them documented is better than astonishment.

Yes, that's the reason for the registry.

--Paul Hoffman

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 29 Sep 2018 17:42:09 +0000

> reservation of the labels in this manner is definitely not considered

In re-reading this for inclusion in the future registry document, I noticed something wrong. You don't mean "Left Hand Side (LHS)": that almost always used to mean the user name in an email address. I think you instead mean "left-most" with no abbreviation.

--Paul Hoffman

---

From: Joe Abley <[email-masked]>
Date: Sat, 29 Sep 2018 14:10:44 -0400

>
>> Attention was paid to the consideration of local
>> domain name,

If you say "left-most" (or, really, express anything related to
directionality) don't you need to care about the presentation of the
script that the domain name is encoded in, which might read right to
left?

It'd be nice if there was standard terminology for this.

With apologies for the déjà vu.

Joe

---

From: "John Levine" <[email-masked]>
Date: 30 Sep 2018 21:50:03 -0400

>It'd be nice if there was standard terminology for this.

farthest from the root vs closest to the root?

R's,
John