Subject: [DNSOP] TSIG - add presentation format for humans.

From: Mark Andrews <[email-masked]>
Date: Thu, 22 Nov 2018 08:30:55 +1100

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742              INTERNET: [email-masked]

---

From: Dick Franks <[email-masked]>
Date: Wed, 21 Nov 2018 22:51:49 +0000

Net::DNS has offered this information for many years in the form of
comments,
which avoids a disaster if inadvertently ingested by a parser.

$packet->print;

;; HEADER SECTION
;;    id = 51343
;;    qr = 0    aa = 0    tc = 0    rd = 0    opcode = QUERY
;;    ra = 0    z  = 0    ad = 0    cd = 0    rcode  = NOERROR
;;    qdcount = 1    ancount = 0    nscount = 0    arcount = 1
;;    do = 0

;; QUESTION SECTION (1 record)
;; query.example.    IN    A

;; ANSWER SECTION (0 records)

;; AUTHORITY SECTION (0 records)

;; ADDITIONAL SECTION (1 record)
; hmac-sha1.example.    TSIG
;    algorithm:    HMAC-SHA1
;    time signed:    1542837913    fudge:    300
;    signature:    364892b4af8d131a647157838c541d2606d30be4
;    original id:    51343
;            NOERROR

--Dick

---

From: Mark Andrews <[email-masked]>
Date: Thu, 22 Nov 2018 09:57:52 +1100

and BIND does

.			0	ANY	TSIG	hmac-md5.sig-alg.reg.int. 1542840965 300 16 T1lmN3NSeGQvxA0xXiAL6g== 57713 NOERROR 0 

with hex for the other data if present.

> On 22 Nov 2018, at 9:51 am, Dick Franks <[email-masked]> wrote:
> 
> Net::DNS has offered this information for many years in the form of comments,