Subject: [dnsoverhttp] RFC 4501 vs. draft-hoffman-dns-over-http

From: Ben Schwartz <[email-masked]>
Date: Mon, 3 Apr 2017 16:55:57 -0400

I noticed that draft-hoffman-dns-over-http doesn't mention RFC 4501.  Does
anyone (especially the authors) know why that is?

It occurs to me that using RFC 4501 (dns:...) URIs could have advantages
for caching, whereas using an https:// URI makes deployment easier on
existing servers.  I wonder if there are other considerations?

--Ben

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 3 Apr 2017 21:00:09 +0000

On Apr 3, 2017, at 1:55 PM, Ben Schwartz <[email-masked]> wrote:
> 
> I noticed that draft-hoffman-dns-over-http doesn't mention RFC 4501.  Does anyone (especially the authors) know why that is?
> 
> It occurs to me that using RFC 4501 (dns:...) URIs could have advantages for caching, whereas using an https:// URI makes deployment easier on existing servers.  I wonder if there are other considerations?

There has been no noticeable implementation of RFC 4501, as far as I know. Thus, defining DNS-over-HTTP directly seemed better.

--Paul Hoffman