Subject: [Dots] Comments about the requirements draft (RE: Best transport selection during an attack?)

From: <[email-masked]>
Date: Thu, 5 Nov 2015 13:54:35 +0000

Hi Andrew,

You can retrieve my first review of the requirements draft from this link<https://tf.orange.com/DownloadTransaction.aspx?UploadID=635823317912521410&pwd=1mzkBJ+8GKsZvpv83QMUow==&recipient=l5Gb0t2wjE2TNRbzuAO2gIOc1LhkqOAAdQyaqwHJ7HE=&ref=l5Gb0t2wjE2TNRbzuAO2gIOc1LhkqOAAdQyaqwHJ7HE=&>. I’m also attaching the pdf file in case you have troubles to open the doc file.

draft-ietf-dots-requirements-00-rev Med.doc
draft-ietf-dots-requirements-00-rev Med.pdf

(These file(s) are available until 10/11/2015 14:50:16)

Cheers,
Med

De : Mortensen, Andrew [mailto:[email-masked]]
Envoyé : jeudi 5 novembre 2015 09:14
À : BOUCADAIR Mohamed IMT/OLN
Cc : kaname nishizuka; Roland Dobbins; [email-masked]; [email-masked]
Objet : Re: [Dots] Best transport selection during an attack?

Yes, this is captured in OP-005 of the requirements draft. I encourage WG members to read it and send feedback. Thank you.

andrew

On Thursday, November 5, 2015, <[email-masked]<mailto:[email-masked]>> wrote:
Hi Kaname,

I agree with your comment about the status.

FYI, we had this requirement in -00 of https://tools.ietf.org/html/draft-reddy-dots-transport-00#section-4:

   o  Acknowledgement for the processing of a filtering request and the
      enforcement of associated countermeasures.

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]<javascript:;>] De la part de kaname nishizuka
> Envoyé : jeudi 5 novembre 2015 07:09
> À : Roland Dobbins; [email-masked]<javascript:;>
> Cc : [email-masked]<javascript:;>
> Objet : Re: [Dots] [tsvwg] Best transport selection during an attack?
>
>
>  >the only mission-critical DOTS messages are mitigation service requests
> from DOTS clients and mitigation service refusals from DOTS servers.
>
> I'm in favor of the pointing out of the latter point: mitigation service
> refusals from DOTS servers.
> In operator's point of view, returning of status is indispensable to know
> the mitigation is succeed or not.
> Without such information, it will take more time to decide the next
> action, so it will harm the victim longer.
>
> IMHO, in this meaning, "SOS" is a little bit confusing because it seems
> like the signaling is one directional.
>
> regards,
> kaname nishizuka
>
>
> On 2015/11/04 10:37, Roland Dobbins wrote:
> > On 4 Nov 2015, at 10:29, Aaron Falk wrote:
> >
> >> And, you might not be able to tell you have a problem getting UDP
> through until you are under attack,
> >> when some operator may implement filtering that inhibits connectivity.
> >
> > Regular heartbeats between clients and servers, clients and relays, and
> relays and servers can serve the function of ensuring end-to-end
> connectivity on an ongoing basis.
> >
> > Failure to receive service request acknowledgements can serve this
> purpose under duress.
> >
> > It's expected that DOTS clients will update DOTS servers (either
> directly or via DOTS relays) with either continued mitigation requests
> and/or situational updates with regards to mitigation efficacy throughout
> mitigation service windows.  Likewise, DOTS servers are expected to do the
> same with regards to DOTS clients (again, either directly or via DOTS
> relays).
> >
> > Note that other than a DOTS server receiving a DOTS mitigation service
> requests, none of these message types are necessary in order to mitigation
> service to be initiated.  They are important and useful, but not mission-
> critical; the only mission-critical DOTS messages are mitigation service
> requests from DOTS clients and mitigation service refusals from DOTS
> servers.
> >
> > -----------------------------------
> > Roland Dobbins <[email-masked]<javascript:;>>
> >
> > _______________________________________________
> > Dots mailing list
> > [email-masked]<javascript:;>
> > https://www.ietf.org/mailman/listinfo/dots
>
> _______________________________________________
> Dots mailing list
> [email-masked]<javascript:;>
> https://www.ietf.org/mailman/listinfo/dots

_______________________________________________
Dots mailing list
[email-masked]<javascript:;>
https://www.ietf.org/mailman/listinfo/dots

---

From: "Mortensen, Andrew" <[email-masked]>
Date: Thu, 5 Nov 2015 18:30:37 -0500

Thanks, Med. I'm in transit back from Yokohama, so I'll review and comment
as soon as I can.

andrew

On Thursday, November 5, 2015, <[email-masked]> wrote:

> Hi Andrew,
>
>
>
> You can retrieve my first review of the requirements draft from this link
> <https://tf.orange.com/DownloadTransaction.aspx?UploadID=635823317912521410&pwd=1mzkBJ+8GKsZvpv83QMUow==&recipient=l5Gb0t2wjE2TNRbzuAO2gIOc1LhkqOAAdQyaqwHJ7HE=&ref=l5Gb0t2wjE2TNRbzuAO2gIOc1LhkqOAAdQyaqwHJ7HE=&>.
> I’m also attaching the pdf file in case you have troubles to open the doc
> file.
>
>
>
> *De :* Mortensen, Andrew [mailto:[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>]
> *Envoyé :* jeudi 5 novembre 2015 09:14
> *À :* BOUCADAIR Mohamed IMT/OLN
> *Cc :* kaname nishizuka; Roland Dobbins; [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>; [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
> *Objet :* Re: [Dots] Best transport selection during an attack?
>
>
>
> Yes, this is captured in OP-005 of the requirements draft. I encourage WG
> members to read it and send feedback. Thank you.
>
>
>
> andrew
>
>
>
> On Thursday, November 5, 2015, <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>
> Hi Kaname,
>
> FYI, we had this requirement in -00 of
> https://tools.ietf.org/html/draft-reddy-dots-transport-00#section-4:
>
> > De : Dots [mailto:[email-masked]] De la part de kaname nishizuka
> > À : Roland Dobbins; [email-masked]
> > Cc : [email-masked]
> > > Roland Dobbins <[email-masked]>
> > >
> > > [email-masked]
> > [email-masked]
> [email-masked]

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 10 Nov 2015 14:35:20 -0600

On 11/05/2015 07:54 AM, [email-masked] wrote:
> I’m also attaching the pdf file in case you have troubles to open the 
> doc file.
>

This list strips off attachments.  Best to learn how to post to the 
github (I myself need more time working at that).

> *De :*Mortensen, Andrew [mailto:[email-masked]]
> *Cc :* kaname nishizuka; Roland Dobbins; [email-masked]; [email-masked]
> Yes, this is captured in OP-005 of the requirements draft. I encourage 
> WG members to read it and send feedback. Thank you.
>
> andrew
>
>
>
> <mailto:[email-masked]>> wrote:
>
> Hi Kaname,
>
> > De : Dots [mailto:[email-masked] <javascript:;>] De la part 
> de kaname nishizuka
> > À : Roland Dobbins; [email-masked] <javascript:;>
> > Cc : [email-masked] <javascript:;>
> > > Roland Dobbins <[email-masked] <javascript:;>>
> > >
> > > [email-masked] <javascript:;>
> > [email-masked] <javascript:;>
> [email-masked] <javascript:;>