Subject: [Dots] I-D Action: draft-ietf-dots-data-channel-13.txt

From: [email-masked]
Date: Tue, 30 Jan 2018 05:10:21 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DDoS Open Threat Signaling WG of the IETF.

        Title           : Distributed Denial-of-Service Open Threat Signaling (DOTS) Data Channel Specification
        Authors         : Tirumaleswar Reddy
                          Mohamed Boucadair
                          Kaname Nishizuka
                          Liang Xia
                          Prashanth Patil
                          Andrew Mortensen
                          Nik Teague
	Filename        : draft-ietf-dots-data-channel-13.txt
	Pages           : 40
	Date            : 2018-01-30

Abstract:
   The document specifies a Distributed Denial-of-Service Open Threat
   Signaling (DOTS) data channel used for bulk exchange of data that
   cannot easily or appropriately communicated through the DOTS signal
   channel under attack conditions.

   This is a companion document to the DOTS signal channel
   specification.

Editorial Note (To be removed by RFC Editor)

   Please update these statements with the RFC number to be assigned to
   this document:

   o  "This version of this YANG module is part of RFC XXXX;"

   o  "RFC XXXX: Distributed Denial-of-Service Open Threat Signaling
      (DOTS) Data Channel Specification";

   o  reference: RFC XXXX

   Please update this statement with the RFC number to be assigned to
   the following documents:

   o  "RFC YYYY: Distributed Denial-of-Service Open Threat Signaling
      (DOTS) Signal Channel Specification";
   o  "RFC ZZZZ: Network Access Control List (ACL) YANG Data Model";

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dots-data-channel/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dots-data-channel-13
https://datatracker.ietf.org/doc/html/draft-ietf-dots-data-channel-13

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-data-channel-13

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Tue, 30 Jan 2018 13:26:08 +0000

Hi all, 

As a preparation for the new interim meeting, I'm pleased to share this updated version of this data channel spec. 

This new version addresses all the requirements set by the WG. Some major changes were made to achieve that, e.g., 
* Given the constraints imposed by RESTCONF and the structure of the ACL YANG module, the draft does not augment anymore the ACL YANG module. The new design is more simple + still rely upon I-D.ietf-netmod-acl-model. Motivation for such design is further discussed in the document. 
* Indicate that filtering rules assume a default direction (destination is the DOTS client' domain)
* In order to avoid stale alias/filtering entries, lifetimes are now mandatory to be included. 
* Add some validation rules on the target-prefix
* Fix the request-uri in the examples
* Update the security considerations (rate-limit, resource quota, ..)

Please review and share your comments, questions, and suggestions. 

Cheers,
Med

> -----Message d'origine-----
> De : I-D-Announce [mailto:[email-masked]] De la part de
> [email-masked]
> Envoyé : mardi 30 janvier 2018 14:10
> À : [email-masked]
> Cc : [email-masked]
> Objet : I-D Action: draft-ietf-dots-data-channel-13.txt
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt