Subject: [Dots] I-D Action: draft-ietf-dots-signal-channel-17.txt

From: [email-masked]
Date: Tue, 23 Jan 2018 02:16:53 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DDoS Open Threat Signaling WG of the IETF.

        Title           : Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Specification
        Authors         : Tirumaleswar Reddy
                          Mohamed Boucadair
                          Prashanth Patil
                          Andrew Mortensen
                          Nik Teague
	Filename        : draft-ietf-dots-signal-channel-17.txt
	Pages           : 84
	Date            : 2018-01-23

Abstract:
   This document specifies the DOTS signal channel, a protocol for
   signaling the need for protection against Distributed Denial-of-
   Service (DDoS) attacks to a server capable of enabling network
   traffic mitigation on behalf of the requesting client.

   A companion document defines the DOTS data channel, a separate
   reliable communication layer for DOTS management and configuration
   purposes.

Editorial Note (To be removed by RFC Editor)

   Please update these statements with the RFC number to be assigned to
   this document:

   o  "This version of this YANG module is part of RFC XXXX;"

   o  "RFC XXXX: Distributed Denial-of-Service Open Threat Signaling
      (DOTS) Signal Channel";

   o  "| 3.00 | Alternate server | [RFCXXXX] |"

   o  reference: RFC XXXX

   Please update TBD statements with the port number to be assigned to
   DOTS Signal Channel Protocol.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dots-signal-channel/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dots-signal-channel-17
https://datatracker.ietf.org/doc/html/draft-ietf-dots-signal-channel-17

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-signal-channel-17

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Tue, 23 Jan 2018 10:34:37 +0000

Hi all, 

A new version of this document is available online. The changes are as follows:

* Clarify the use of cuid and cdid parameters. 
* Update the CBOR mapping table to include JSON and YANG types. Also, parameters was reordered to follow the YANG tree structure. *** This change has a consequence on implementations. ***
* Double check the use of uri-path and query parameters + call out when these parameters are mandatory + shorten the name of uri-*.
* Reorganize some parts of the text for better readability 
* Clarify that the signal channel YANG module is meant to govern the signal-channel messages; the YANG module to be used for server management purposes is clearly out of scope.
* and fix nits.

Many thanks to Jon who helped to enhance this specification. Jon validated many pieces of the specification using his implementation. Much appreciated! 

As an editor of the document, I do think that this version is (almost) stable and unless there are major concerns, the plan is to have a WGLC for the document. 

In the meantime, please review and share your comments. We will be more than happy to discuss and address them. 

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]] De la part de internet-
> [email-masked]
> Envoyé : mardi 23 janvier 2018 11:17
> À : [email-masked]
> Cc : [email-masked]
> Objet : [Dots] I-D Action: draft-ietf-dots-signal-channel-17.txt
> 
> 
>         Title           : Distributed Denial-of-Service Open Threat
> Signaling (DOTS) Signal Channel Specification
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots