Subject: [Dots] REMINDER -- WGLC on DOTS Requirements

From: Roman Danyliw <[email-masked]>
Date: Tue, 2 Jan 2018 12:53:28 +0000

Hello!

Happy New Year!  The WGLC for the DOTS requirements draft will be closing soon.  Please provide any final comments.

Thanks,
Roman

-----Original Message-----
From: Roman Danyliw 
Sent: Thursday, December 7, 2017 3:51 PM
To: [email-masked]
Subject: WGLC on DOTS Requirements

Hello!

Consistent with our discussion at the Singapore meeting and with the concurrence of the draft authors, we are starting a working group last call (WGLC) for the DOTS Requirements draft:

Distributed Denial of Service (DDoS) Open Threat Signaling Requirements
draft-ietf-dots-requirements-08
https://tools.ietf.org/html/draft-ietf-dots-requirements-08

Please send all comments to the DOTS mailing list.

This WGLC will end on January 2, 2018 (~3 weeks to account for end-of-the-calendar year vacations).

Thanks,
Roman

---

From: "Jon Shallow" <[email-masked]>
Date: Tue, 2 Jan 2018 13:43:25 -0000

Hi Roman,

Comment # 1

I still have clarity issues with the usage of the terms "client-side" and
"server-side" with reference to DOTS gateways  They are used both as a
prefix and/or suffix to 'DOTS gateways', yet have different meaning based on
positioning.  What does "client-side DOTS gateway server-side" actually
mean?

"client-side DOTS gateway server-side" means as I understand it "The 'DOTS
client' component of the DOTS gateway that is sitting in a client domain",
not "The 'DOTS server' component of the DOTS gateway that is sitting in a
client domain".

"client-domain DOTS gateway server-facing-side" is a lot clearer to me.

- See discussions on
https://mailarchive.ietf.org/arch/msg/dots/7-27y3X9-nw6-aRuGflzTaSoy3s
Whatever the decision on naming, it needs to be explicitly defined, not as a
passing reference under "DOTS gateway" definition.

Comment # 2

While Filter is defined, it does not appear to be used / required, unless
Black-List / White-List are using Filter only as a mechanism.  Should there
be a DATA-005 for this as a requirement (i.e. using the flexibility of
netconf-acl?

Regards

Jon

-----Original Message-----
From: Dots [mailto: [email-masked]] On Behalf Of Roman Danyliw
Sent: 02 January 2018 12:53
To: [email-masked]
Subject: [Dots] REMINDER -- WGLC on DOTS Requirements

Hello!

Happy New Year!  The WGLC for the DOTS requirements draft will be closing
soon.  Please provide any final comments.

Thanks,
Roman

-----Original Message-----
From: Roman Danyliw 
Sent: Thursday, December 7, 2017 3:51 PM
To: [email-masked]
Subject: WGLC on DOTS Requirements

Hello!

Consistent with our discussion at the Singapore meeting and with the
concurrence of the draft authors, we are starting a working group last call
(WGLC) for the DOTS Requirements draft:

This WGLC will end on January 2, 2018 (~3 weeks to account for
end-of-the-calendar year vacations).

Thanks,
Roman

_______________________________________________
Dots mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dots

---

From: "Mortensen, Andrew" <[email-masked]>
Date: Tue, 2 Jan 2018 19:01:04 +0000

On Jan 2, 2018, at 8:43 AM, Jon Shallow <[email-masked]<mailto:[email-masked]>> wrote:

Hi Roman,

Comment # 1

The only terminology affected in the requirements draft is the following:

      Client-side DOTS gateways are DOTS gateways that are in the DOTS
      client's domain, while  server-side DOTS gateways denote DOTS gateways
      that are in the DOTS server's domain.

I have changed client-side and server-side to client-domain and server-domain, respectively. Do we need to make the server/client-facing-side distinction in the requirements draft, or can we address that in the architecture draft?

Comment # 2

This doesn’t seem unreasonable to me as long as we make it clear that, like B/W lists, filters are may be rejected due to capacity limitations or policy restrictions.

andrew

-----Original Message-----
From: Dots [mailto: [email-masked]<mailto:[email-masked]>] On Behalf Of Roman Danyliw
Sent: 02 January 2018 12:53
To: [email-masked]<mailto:[email-masked]>
Subject: [Dots] REMINDER -- WGLC on DOTS Requirements

Hello!

Thanks,
Roman

-----Original Message-----
From: Roman Danyliw
Sent: Thursday, December 7, 2017 3:51 PM
To: [email-masked]<mailto:[email-masked]>
Subject: WGLC on DOTS Requirements

Hello!

Distributed Denial of Service (DDoS) Open Threat Signaling Requirements
draft-ietf-dots-requirements-08
https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Ddots-2Drequirements-2D08&d=DwICAg&c=Hlvprqonr5LuCN9TN65xNw&r=M-0_CqEVXa9OQvmJ2gMtXAzL6v6JsZHtsRkmaRz4urE&m=qZ3RihAhgHGboH-YfW1KvVhH8DEr9W1F0HlPCDW8kXo&s=M4xBnJuuRh2ctgQNeo1YoX1emfiNtTuSG0Uyc6jHkyc&e=

Thanks,
Roman

_______________________________________________
Dots mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_dots&d=DwICAg&c=Hlvprqonr5LuCN9TN65xNw&r=M-0_CqEVXa9OQvmJ2gMtXAzL6v6JsZHtsRkmaRz4urE&m=qZ3RihAhgHGboH-YfW1KvVhH8DEr9W1F0HlPCDW8kXo&s=VL17KPOtxwiZZO202WzQInvMXPOGEKPPnKfDXPHvnfw&e=

_______________________________________________
Dots mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_dots&d=DwICAg&c=Hlvprqonr5LuCN9TN65xNw&r=M-0_CqEVXa9OQvmJ2gMtXAzL6v6JsZHtsRkmaRz4urE&m=qZ3RihAhgHGboH-YfW1KvVhH8DEr9W1F0HlPCDW8kXo&s=VL17KPOtxwiZZO202WzQInvMXPOGEKPPnKfDXPHvnfw&e=

---

From: "Jon Shallow" <[email-masked]>
Date: Tue, 2 Jan 2018 19:58:15 -0000

Hi Andrew et al,

Thanks for this – see inline.

Regards

Jon

From: Dots [mailto: [email-masked]] On Behalf Of Mortensen, Andrew
Sent: 02 January 2018 19:01
To: Jon Shallow
Cc: Roman Danyliw; [email-masked]
Subject: Re: [Dots] REMINDER -- WGLC on DOTS Requirements

On Jan 2, 2018, at 8:43 AM, Jon Shallow <[email-masked]> wrote:

Hi Roman,

Comment # 1

[Jon] It really is in the signal-draft that the suffix server/client-side is used – but it is only in the requirements draft that terms are defined – hence why I raised it here.  The architecture draft will also need the prefix server/client-side updated in most, but not all of the places – e.g. 2. DOTS Architecture “At some point, the DOTS client may decide to terminate the server-side attack mitigation, which it indicates to the DOTS server over the signal channel.” should not be changed to server-domain.

Comment # 2

andrew

 

-----Original Message-----
From: Dots [mailto:  <mailto:[email-masked]> [email-masked]] On Behalf Of Roman Danyliw
Sent: 02 January 2018 12:53
To:  <mailto:[email-masked]> [email-masked]
Subject: [Dots] REMINDER -- WGLC on DOTS Requirements

Hello!

Thanks,
Roman

-----Original Message-----
From: Roman Danyliw 
Sent: Thursday, December 7, 2017 3:51 PM
To: [email-masked]
Subject: WGLC on DOTS Requirements

Hello!

Distributed Denial of Service (DDoS) Open Threat Signaling Requirements
draft-ietf-dots-requirements-08
 <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Ddots-2Drequirements-2D08&d=DwICAg&c=Hlvprqonr5LuCN9TN65xNw&r=M-0_CqEVXa9OQvmJ2gMtXAzL6v6JsZHtsRkmaRz4urE&m=qZ3RihAhgHGboH-YfW1KvVhH8DEr9W1F0HlPCDW8kXo&s=M4xBnJuuRh2ctgQNeo1YoX1emfiNtTuSG0Uyc6jHkyc&e=> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Ddots-2Drequirements-2D08&d=DwICAg&c=Hlvprqonr5LuCN9TN65xNw&r=M-0_CqEVXa9OQvmJ2gMtXAzL6v6JsZHtsRkmaRz4urE&m=qZ3RihAhgHGboH-YfW1KvVhH8DEr9W1F0HlPCDW8kXo&s=M4xBnJuuRh2ctgQNeo1YoX1emfiNtTuSG0Uyc6jHkyc&e=

Thanks,
Roman

_______________________________________________
Dots mailing list
 <mailto:[email-masked]> [email-masked]
 <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_dots&d=DwICAg&c=Hlvprqonr5LuCN9TN65xNw&r=M-0_CqEVXa9OQvmJ2gMtXAzL6v6JsZHtsRkmaRz4urE&m=qZ3RihAhgHGboH-YfW1KvVhH8DEr9W1F0HlPCDW8kXo&s=VL17KPOtxwiZZO202WzQInvMXPOGEKPPnKfDXPHvnfw&e=> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_dots&d=DwICAg&c=Hlvprqonr5LuCN9TN65xNw&r=M-0_CqEVXa9OQvmJ2gMtXAzL6v6JsZHtsRkmaRz4urE&m=qZ3RihAhgHGboH-YfW1KvVhH8DEr9W1F0HlPCDW8kXo&s=VL17KPOtxwiZZO202WzQInvMXPOGEKPPnKfDXPHvnfw&e=

_______________________________________________
Dots mailing list
 <mailto:[email-masked]> [email-masked]
 <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_dots&d=DwICAg&c=Hlvprqonr5LuCN9TN65xNw&r=M-0_CqEVXa9OQvmJ2gMtXAzL6v6JsZHtsRkmaRz4urE&m=qZ3RihAhgHGboH-YfW1KvVhH8DEr9W1F0HlPCDW8kXo&s=VL17KPOtxwiZZO202WzQInvMXPOGEKPPnKfDXPHvnfw&e=> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_dots&d=DwICAg&c=Hlvprqonr5LuCN9TN65xNw&r=M-0_CqEVXa9OQvmJ2gMtXAzL6v6JsZHtsRkmaRz4urE&m=qZ3RihAhgHGboH-YfW1KvVhH8DEr9W1F0HlPCDW8kXo&s=VL17KPOtxwiZZO202WzQInvMXPOGEKPPnKfDXPHvnfw&e=

---

From: Roman Danyliw <[email-masked]>
Date: Tue, 2 Jan 2018 21:57:59 +0000

Hello again!

Given that some are just returning from their holiday, this WGLC will be extended one more day — till Wednesday, January 3rd.

Thanks,
Roman

> On Jan 2, 2018, at 07:53, Roman Danyliw <[email-masked]> wrote:
> 
> Hello!
>

---

From: "Jon Shallow" <[email-masked]>
Date: Wed, 3 Jan 2018 10:26:45 -0000

Version draft-ietf-dots-requirements-10.txt looks good to me and is ready to
be moved forward.

Thanks to all those who have given input and to all those who have updated
the draft accordingly with carefully thought through updates.

Regards

Jon

-----Original Message-----
From: Dots [mailto: [email-masked]] On Behalf Of Roman Danyliw
Sent: 02 January 2018 21:58
To: [email-masked]
Subject: Re: [Dots] REMINDER -- WGLC on DOTS Requirements

Hello again!

Given that some are just returning from their holiday, this WGLC will be
extended one more day - till Wednesday, January 3rd.

Thanks,
Roman

---

From: kaname nishizuka <[email-masked]>
Date: Thu, 4 Jan 2018 11:33:38 +0900

Hello,

I'm satisfied with the changes of the terminology of the DOTS gateway.
All of the content is worth to move it forward.

thanks,
Kaname