Subject: [Dots] Fwd: New Version Notification for draft-ietf-dots-requirements-16.txt

From: "Mortensen, Andrew" <[email-masked]>
Date: Mon, 22 Oct 2018 20:15:31 +0000

This revision address the AD feedback received here:

<https://mailarchive.ietf.org/arch/msg/dots/NKy0SbeKU6iswFhKOfLYbMtLb_g>

The editors hope this removes remaining barriers to IETF last call.

andrew

Begin forwarded message:

From: <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-ietf-dots-requirements-16.txt
Date: October 22, 2018 at 4:12:27 PM EDT
To: Reddy K <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, Andrew Mortensen <[email-masked]<mailto:[email-masked]>>, Tirumaleswar Reddy <[email-masked]<mailto:[email-masked]>>, Robert Moskowitz <[email-masked]<mailto:[email-masked]>>

[EXTERNAL EMAIL]

A new version of I-D, draft-ietf-dots-requirements-16.txt
has been successfully submitted by Andrew Mortensen and posted to the
IETF repository.

Name: draft-ietf-dots-requirements
Revision: 16
Title: Distributed Denial of Service (DDoS) Open Threat Signaling Requirements
Document date: 2018-10-22
Group: dots
Pages: 21
URL:            https://www.ietf.org/id/draft-ietf-dots-requirements-16.txt

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Tue, 23 Oct 2018 09:19:38 +0000

Based on the updated DOTS requirements, following changes are required to DOTS protocol drafts:

[1] In the updated requirement GEN-001, version number to distinguish protocol revisions is removed.  Remove "Uri-Path: "v1.0"" from the DOTS signal channel specification. We have already introduced
comprehension-mandatory and comprehension-required parameters in DOTS signal channel protocol to accommodate future protocol extensions and backward compatibility.

[2]
CIDR notation is not used for IPv4 prefix in https://tools.ietf.org/html/rfc6991, updated SIG-008 requirement does not refer to CIDR notation; will remove the following line from the DOTS signal and data channel drafts :
"Prefixes are represented using Classless Inter-Domain Routing (CIDR) notation [RFC4632]."

Cheers,
-Tiru

From: Dots <[email-masked]> On Behalf Of Mortensen, Andrew
Sent: Tuesday, October 23, 2018 1:46 AM
To: dots <[email-masked]>
Subject: [Dots] Fwd: New Version Notification for draft-ietf-dots-requirements-16.txt

CAUTION: External email. Do not click links or open attachments unless you recognize the sender and know the content is safe.

________________________________
This revision address the AD feedback received here:

andrew

Begin forwarded message:

[EXTERNAL EMAIL]

---

From: <[email-masked]>
Date: Tue, 23 Oct 2018 12:28:00 +0000

Hi Tiru,

Also, the data-channel will be updated to make use of accept- and drop-list.

Please see inline.

Cheers,
Med

De : Dots [mailto:[email-masked]] De la part de Konda, Tirumaleswar Reddy
Envoyé : mardi 23 octobre 2018 11:20
À : Mortensen, Andrew; dots; Benjamin Kaduk
Objet : Re: [Dots] New Version Notification for draft-ietf-dots-requirements-16.txt

[Med] Yes.

[2]

[Med] We are using cidr notation (even if 4632 is not explicitly cited in 6991).

Cheers,
-Tiru

andrew

Begin forwarded message:

[EXTERNAL EMAIL]

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 23 Oct 2018 22:28:04 -0500

> [Med] We are using cidr notation (even if 4632 is not explicitly cited in 6991).

CIDR notation is still generally a good thing; my comment on
dots-requirements was just that we have no *protocol-level* requirement to
use it.  I wasn't trying to say that we should stop using it.

-Ben