Subject: [Dots] TR: New Version Notification for draft-reddy-dots-home-network-02.txt

From: <[email-masked]>
Date: Tue, 13 Nov 2018 14:37:29 +0000

Hi Roman, Franck, Wei, 

FYI, we released an updated version of the draft which integrates the comments you raised. The main changes are as follows: 

* Add a new privacy considerations section as suggested by Roman.
* Add a discussion on issues/fixes when an address sharing function is present between the DOTS client and server (Wei)
* Add some text to clarify that the DOTS server on the CPE is simple compared to the one on the provider side. Only a single DOTS session will be maintained (Franck).
* Further highlight that the solution is suitable for blocking attacks near the sources (I failed to get the name of the gentleman who raised this issue in the meeting).
* Add some text to clarify that DOTS servers do not blindly accept requests and that the solution does not aim to track or censor users (the comment was made by same gentleman as above).  

Please let us know if the new text addresses your concern. 

As usual, comments, suggestions, and questions are more than welcome.

Cheers,
Med

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]]
> Envoyé : mardi 13 novembre 2018 15:28
> À : Tirumaleswar Reddy; Joshi Harsha; Jon Shallow; Reddy K; BOUCADAIR Mohamed
> TGI/OLN
> Objet : New Version Notification for draft-reddy-dots-home-network-02.txt
> 
> 
> A new version of I-D, draft-reddy-dots-home-network-02.txt
> has been successfully submitted by Mohamed Boucadair and posted to the
> IETF repository.
> 
> Name:		draft-reddy-dots-home-network
> Revision:	02
> Title:		Denial-of-Service Open Threat Signaling (DOTS) Signal
> Channel Call Home
> Document date:	2018-11-12
> Group:		Individual Submission
> Pages:		17
> URL:            https://www.ietf.org/internet-drafts/draft-reddy-dots-home-
> network-02.txt
> Status:         https://datatracker.ietf.org/doc/draft-reddy-dots-home-
> network/
> Htmlized:       https://tools.ietf.org/html/draft-reddy-dots-home-network-02
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-reddy-dots-home-
> network
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-reddy-dots-home-
> network-02
> 
> Abstract:
>    This document presents DOTS signal channel Call Home service, which
>    enables a DOTS server to initiate a secure connection to a DOTS
>    client, and to receive the attack traffic information from the DOTS
>    client.  The DOTS server in turn uses the attack traffic information
>    to identify the compromised devices launching the outgoing DDOS
>    attack and takes appropriate mitigation action.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: Roman Danyliw <[email-masked]>
Date: Tue, 13 Nov 2018 16:38:52 +0000

Hi Med!

Thanks for adding the new Privacy Considerations section (section 6).  It addresses my concerns voiced at the IETF 103 meeting.

Roman

> -----Original Message-----
> From: Dots [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Tuesday, November 13, 2018 9:37 AM
> To: Roman Danyliw <[email-masked]>; Xialiang (Frank, Network Integration
> Technology Research Dept) <[email-masked]>; Panwei (William)
> ([email-masked]) <[email-masked]>
> Cc: [email-masked]
> Subject: [Dots] TR: New Version Notification for draft-reddy-dots-home-
> network-02.txt
> 
> Hi Roman, Franck, Wei,
> 
> FYI, we released an updated version of the draft which integrates the
> comments you raised. The main changes are as follows:
> 
> * Add a discussion on issues/fixes when an address sharing function is
> present between the DOTS client and server (Wei)
> * Add some text to clarify that the DOTS server on the CPE is simple
> compared to the one on the provider side. Only a single DOTS session will be
> maintained (Franck).
> * Further highlight that the solution is suitable for blocking attacks near the
> sources (I failed to get the name of the gentleman who raised this issue in
> the meeting).
> * Add some text to clarify that DOTS servers do not blindly accept requests
> and that the solution does not aim to track or censor users (the comment
> was made by same gentleman as above).
> 
> > De : [email-masked] [mailto:[email-masked]] Envoyé
> > : mardi 13 novembre 2018 15:28 À : Tirumaleswar Reddy; Joshi Harsha;
> > Jon Shallow; Reddy K; BOUCADAIR Mohamed TGI/OLN Objet : New
> Version
> > Notification for draft-reddy-dots-home-network-02.txt
> >
> >
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat
> 
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: Dan Wing <[email-masked]>
Date: Thu, 22 Nov 2018 08:20:04 +0100

Currently I am in Morocco. Still useful to review next week?

-d

> On Nov 13, 2018, at 3:37 PM, <[email-masked]> <[email-masked]> wrote:
> 
> Hi Roman, Franck, Wei, 
>

---

From: <[email-masked]>
Date: Thu, 22 Nov 2018 07:54:51 +0000

Hi Dan, 

Enjoy your stay in Morocco!

Looking forward to receiving your review. 

Cheers,
Med

> De : Dan Wing [mailto:[email-masked]]
> Envoyé : jeudi 22 novembre 2018 08:20
> À : BOUCADAIR Mohamed TGI/OLN
> Cc : Roman Danyliw; Xialiang (Frank, Network Integration Technology Research
> Dept); Panwei (William) ([email-masked]); [email-masked]
> Objet : Re: [Dots] TR: New Version Notification for draft-reddy-dots-home-
> network-02.txt
> 
> > * Further highlight that the solution is suitable for blocking attacks near
> the sources (I failed to get the name of the gentleman who raised this issue
> in the meeting).
> and that the solution does not aim to track or censor users (the comment was
> made by same gentleman as above).
> >
> submission