Subject: [Dots] ietf104-hacthon-issue

From: "MeiLing Chen" <[email-masked]>
Date: Fri, 17 May 2019 09:59:13 +0800

Hi kaname,
    I have two questions about this slide of PPT.
question1：what's the function of Deadman's Trigger?
question2：Gateway Function、Redirection、Happy Eyeballs，Whether these three functions are not available in the go-dots?

---

From: kaname nishizuka <[email-masked]>
Date: Fri, 17 May 2019 13:10:53 +0900

Hi MeiLing,

 > question1：what's the function of Deadman's Trigger?

So-called Deadman's Trigger is the function described in '3.3.3. Automated Mitigation on Loss of Signal' of draft-ietf-dots-architecture and implemented as 'trigger-mitigation' in the signal channel.

    trigger-mitigation:   If the parameter value is set to 'false', DDoS
       mitigation will not be triggered for the mitigation request unless
       the DOTS signal channel session is lost.

 > question2：Gateway Function、Redirection、Happy Eyeballs，Whether these three functions are not available in the go-dots?
Currently they are not supported by go-dots.

regards,
Kaname

On 2019/05/17 10:59, MeiLing Chen wrote:
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: "MeiLing Chen" <[email-masked]>
Date: Tue, 21 May 2019 10:39:12 +0800

Hi kaname,panwei
[Meiling] Mitigation request with sampleMitigationRequestDraft.json use "trigger-mitigation"=true,  panwei think the mitigation request with trigger-mitigation set to false is a pre-configured mitigation request, it is sent before a DDoS attack happens. When DOTS server receives such mitigation request, it just saves this request and won’t trigger mitigation immediately.
Whether the process is correct or not?

regards,
Kaname

---

From: kaname nishizuka <[email-masked]>
Date: Fri, 24 May 2019 18:04:55 +0900

Hi MeiLing,

The process you described is correct.

regards,
Kaname

On 2019/05/21 11:39, MeiLing Chen wrote:
>      *