Subject: [Dots] prefix with namespace identifier in draft-ietf-dots-signal-filter-control

From: <[email-masked]>
Date: Mon, 24 Feb 2020 08:17:10 +0000

Re-,

The prefix use in draft-ietf-dots-signal-filter-control-02#section-5.1 is correct given that acl-* attributes are not defined in the base YANG module as being part of a mitigation request.

We assumed that the same key value is used for both (e.g., acl-name and ietf-dots-signal-control:acl-name). Given that we revisited that design in the telemetry I-D, I'm afraid that we will need to assign key values for ietf-dots-signal-control:acl-list and ietf-dots-signal-control:acl-name.
Cheers,
Med

De : Jon Shallow [mailto:[email-masked]]
Envoyé : vendredi 21 février 2020 16:46
À : BOUCADAIR Mohamed TGI/OLN; Konda, Tirumaleswar Reddy; kaname nishizuka; [email-masked]
Objet : RE: [Dots] DOTS telemetry questions

Hi,

See inline Jon1>

Regards

Jon

Jon> We  have the same naming issues in draft-ietf-dots-signal-filter-control-00 where we do not have the ietf-dots-signal-control: prefix in the JSON examples (Fig 10)

[Med] Fig 10 is a "normal" mitigation request. Why should it need to include "ietf-dots-signal-control:" prefix?

Jon1> My bad - I was looking at draft-ietf-dots-signal-filter-control-00, not draft-ietf-dots-signal-filter-control-02.  However, https://tools.ietf.org/html/draft-ietf-dots-signal-filter-control-02#section-5.1 only defines "activation-type" without the prefix, and acl-list and acl-name have the incorrect prefix: added to, for example, Figure 1.

---

From: "Jon Shallow" <[email-masked]>
Date: Wed, 26 Feb 2020 12:21:04 -0000

Hi all,

Thinking out of the box, for Figure 8 we have

      "ietf-dots-signal-channel:mitigation-scope": {

        "scope": [

          {

            "target-prefix": [

               "2001:db8:6401::2/127"

             ],

             "target-protocol": [

               17

             ],

             "ietf-dots-signal-control:acl-list": [

               {

                 "ietf-dots-signal-control:acl-name": "my-accept-list",

                 "ietf-dots-signal-control:activation-type": "immediate"

               }

            "lifetime": 3600

          }

        ]

      }

    }

If this was to be replaced with

      "ietf-dots-signal-control:mitigation-scope": {

        "scope": [

          {

            "target-prefix": [

               "2001:db8:6401::2/127"

             ],

             "target-protocol": [

               17

             ],

             " acl-list": [

               {

                 " acl-name": "my-accept-list",

                 " activation-type": "immediate"

               }

            "lifetime": 3600

          }

        ]

      }

    }

As the module is ietf-dots-signal-control: which includes the augments -
Would that not be valid (and a lot simpler)?

So we only need a CBOR definition for
ietf-dots-signal-channel:mitigation-scope and separately for
ietf-dots-signal-control:mitigation-scope as well as the augmented new
entries.

Regards

Jon

From: Dots [mailto: [email-masked]] On Behalf Of
[email-masked]
Sent: 24 February 2020 08:17
To: Jon Shallow; Konda, Tirumaleswar Reddy; kaname nishizuka; [email-masked]
Subject: [Dots] prefix with namespace identifier in
draft-ietf-dots-signal-filter-control

Re-,

The prefix use in draft-ietf-dots-signal-filter-control-02#section-5.1 is
correct given that acl-* attributes are not defined in the base YANG module
as being part of a mitigation request. 

We assumed that the same key value is used for both (e.g., acl-name and
ietf-dots-signal-control:acl-name). Given that we revisited that design in
the telemetry I-D, I’m afraid that we will need to assign key values for
ietf-dots-signal-control:acl-list and ietf-dots-signal-control:acl-name.

Cheers,

Med

De : Jon Shallow [mailto:[email-masked]] 
Envoyé : vendredi 21 février 2020 16:46
À : BOUCADAIR Mohamed TGI/OLN; Konda, Tirumaleswar Reddy; kaname nishizuka;
[email-masked]
Objet : RE: [Dots] DOTS telemetry questions

Hi,

See inline Jon1>

Regards

Jon

Jon> We  have the same naming issues in
draft-ietf-dots-signal-filter-control-00 where we do not have the
ietf-dots-signal-control: prefix in the JSON examples (Fig 10)
[Med] Fig 10 is a “normal” mitigation request. Why should it need to include
“ietf-dots-signal-control:” prefix?

Jon1> My bad – I was looking at draft-ietf-dots-signal-filter-control-00,
not draft-ietf-dots-signal-filter-control-02.  However,
https://tools.ietf.org/html/draft-ietf-dots-signal-filter-control-02#section
-5.1 only defines “activation-type” without the prefix, and acl-list and
acl-name have the incorrect prefix: added to, for example, Figure 1.

---

From: <[email-masked]>
Date: Wed, 26 Feb 2020 12:54:18 +0000

Hi Jon,

We can't do that because "mitigation-scope" is not defined in ietf-dots-signal-control. FWIW, draft-ietf-core-yang-cbor says the following (which consistent with 7951)

==
   o  namespace qualified - the identifier of the YANG item is prefixed
      with the name of the module in which this item is defined,
      separated by the colon character (":").

   The name of a module determines the namespace of all YANG items
   defined in that module.  If an item is defined in a submodule, then
   the namespace qualified name uses the name of the main module to
   which the submodule belongs.

==

Cheers,
Med

De : Jon Shallow [mailto:[email-masked]]
Envoyé : mercredi 26 février 2020 13:21
À : BOUCADAIR Mohamed TGI/OLN; Konda, Tirumaleswar Reddy; kaname nishizuka; [email-masked]
Objet : RE: [Dots] prefix with namespace identifier in draft-ietf-dots-signal-filter-control

Hi all,

As the module is ietf-dots-signal-control: which includes the augments - Would that not be valid (and a lot simpler)?

So we only need a CBOR definition for ietf-dots-signal-channel:mitigation-scope and separately for ietf-dots-signal-control:mitigation-scope as well as the augmented new entries.

Regards

Jon

From: Dots [mailto: [email-masked]] On Behalf Of [email-masked]
Sent: 24 February 2020 08:17
To: Jon Shallow; Konda, Tirumaleswar Reddy; kaname nishizuka; [email-masked]
Subject: [Dots] prefix with namespace identifier in draft-ietf-dots-signal-filter-control

Re-,

Cheers,
Med

Hi,

See inline Jon1>

Regards

Jon

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Wed, 26 Feb 2020 13:51:37 +0000

Let's assign key values for ietf-dots-signal-control:acl-list and ietf-dots-signal-control:acl-name.

Cheers,
-Tiru

From: [email-masked] <[email-masked]>
Sent: Wednesday, February 26, 2020 6:24 PM
To: Jon Shallow <[email-masked]>; Konda, Tirumaleswar Reddy <[email-masked]>; kaname nishizuka <[email-masked]>; [email-masked]
Subject: RE: [Dots] prefix with namespace identifier in draft-ietf-dots-signal-filter-control

CAUTION: External email. Do not click links or open attachments unless you recognize the sender and know the content is safe.

________________________________
Hi Jon,

==

==

Cheers,
Med

De : Jon Shallow [mailto:[email-masked]]
Envoyé : mercredi 26 février 2020 13:21
À : BOUCADAIR Mohamed TGI/OLN; Konda, Tirumaleswar Reddy; kaname nishizuka; [email-masked]<mailto:[email-masked]>
Objet : RE: [Dots] prefix with namespace identifier in draft-ietf-dots-signal-filter-control

Hi all,

Regards

Jon

From: Dots [mailto: [email-masked]<mailto:[email-masked]>] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: 24 February 2020 08:17
To: Jon Shallow; Konda, Tirumaleswar Reddy; kaname nishizuka; [email-masked]<mailto:[email-masked]>
Subject: [Dots] prefix with namespace identifier in draft-ietf-dots-signal-filter-control

Re-,

Cheers,
Med

De : Jon Shallow [mailto:[email-masked]]
Envoyé : vendredi 21 février 2020 16:46
À : BOUCADAIR Mohamed TGI/OLN; Konda, Tirumaleswar Reddy; kaname nishizuka; [email-masked]<mailto:[email-masked]>
Objet : RE: [Dots] DOTS telemetry questions

Hi,

See inline Jon1>

Regards

Jon