Subject: [Dots] multiple values in the filter RE: DOTS telemetry Issues picked up in Interop Testing

From: <[email-masked]>
Date: Tue, 21 Apr 2020 14:20:03 +0000

Re-,

If we want to allow for multiple values to be included, all what we need is to agree on the separator to be used for ranges and for distinct elements. We can get rid of [].

Cheers,
Med

De : Jon Shallow [mailto:[email-masked]]
Envoyé : mardi 21 avril 2020 12:56
À : BOUCADAIR Mohamed TGI/OLN; [email-masked]
Objet : RE: [Dots] DOTS telemetry Issues picked up in Interop Testing

De : Jon Shallow [mailto:[email-masked]]
Envoyé : mardi 21 avril 2020 10:59
À : BOUCADAIR Mohamed TGI/OLN; [email-masked]
Objet : RE: [Dots] DOTS telemetry Issues picked up in Interop Testing

Hi all,

A further thought on the use of Uri-Queries to clarify the AND/OR usage.

If you only allow one query per query type and put the match list in an array, then this will be an OR of the array list (the same as we do for the target* definitions right now.  E.G. :-

Uri-Query: target_prefix=[1.2.3.4/32,4.3.2.1/32]
Gives either 1.2.3.4 or 4.3.2.1 as a valid match.

And
Uri-Query: target-prefix=[1.2.3.4/32,4.3.2.1/32]
Uri-Query: lower-port=[80,443]
Gives (either 1.2.3.4 or 4.3.2.1) and (either port 80 or 443)

[] should not include spaces and comma used as a separator.

[Med] The issue I have with this is that we will need to handle cases where both lower-port and upper-port are present. Not sure what would be the benefit of allowing multiple key values, compact uris? If that's a concern, we may consider shortened names in the query (e.g., s/target-prefix/tp, s/lower-port/lp, ..).

Jon> fair point about lower and upper ports.  Uri-Query: target-port[80-85,443] works for me and covers both ranges and individual ports.

Jon> As this would be options on a GET request that has no body data, I don't think that I am too worried about using shortened names at this point.

---

From: "Jon Shallow" <[email-masked]>
Date: Tue, 21 Apr 2020 15:25:16 +0100

For me, - (minus) is for a range and , (comma) for distinct elements.
Spaces not allowed.

Regards

Jon

From: Dots [mailto: [email-masked]] On Behalf Of
[email-masked]
Sent: 21 April 2020 15:20
To: Jon Shallow; [email-masked]
Subject: [Dots] multiple values in the filter RE: DOTS telemetry Issues
picked up in Interop Testing

Re-, 

If we want to allow for multiple values to be included, all what we need is
to agree on the separator to be used for ranges and for distinct elements.
We can get rid of [].

Cheers,

Med

 

Hi all,

If you only allow one query per query type and put the match list in an
array, then this will be an OR of the array list (the same as we do for the
target* definitions right now.  E.G. :-

And 

[Med] The issue I have with this is that we will need to handle cases where
both lower-port and upper-port are present. Not sure what would be the
benefit of allowing multiple key values, compact uris? If that’s a concern,
we may consider shortened names in the query (e.g., s/target-prefix/tp,
s/lower-port/lp, ..).

Jon> fair point about lower and upper ports.  Uri-Query:
target-port[80-85,443] works for me and covers both ranges and individual
ports.

Jon> As this would be options on a GET request that has no body data, I
don’t think that I am too worried about using shortened names at this point.

---

From: <[email-masked]>
Date: Wed, 22 Apr 2020 09:26:13 +0000

Re-,

Below a change proposal to cover the following:

·         Multiple non-contiguous values

·         Contiguous blocks

·         wildcard

OLD:

   The DOTS client can filter out the asynchronous notifications from
   the DOTS server by indicating one or more Uri-Query options in its
   GET request.  A Uri-Query option can include the following
   parameters: target-prefix, lower-port, upper-port, target-protocol,
   target-fqdn, target-uri, alias-name.

NEW:
   The DOTS client can filter out the asynchronous notifications from
   the DOTS server by indicating one or more Uri-Query options in its
   GET request.  An Uri-Query option can include the following
   parameters: target-prefix, target-port, target-protocol, target-fqdn,
   target-uri, alias-name, 'mid', and 'c' (content) (Section 4.4).  If
   more than one Uri-Query option is included in a request, these
   options are interpreted in the same way as when multiple target
   clauses are included in a message body.  If multiple values of a
   query parameter are included in an Uri-Query option, these values
   MUST be separated by a "," character without any spaces.  Range
   values (i.e., contiguous inclusive block) can be included for target-
   port, target-protocol, and 'mid' parameters by indicating two bound
   values separated by a "-" character.  Wildcard names (i.e., a name
   with the leftmost label is the "*" character) can be included in
   target-fqdn or target-uri parameters.  For example, "*.example.com"
   can be included as a value of the target-fqdn parameter in an Uri-
   Query option.

Better?

Cheers,
Med

De : Jon Shallow [mailto:[email-masked]]
Envoyé : mardi 21 avril 2020 16:25
À : BOUCADAIR Mohamed TGI/OLN; [email-masked]
Objet : RE: [Dots] multiple values in the filter RE: DOTS telemetry Issues picked up in Interop Testing

For me, - (minus) is for a range and , (comma) for distinct elements.  Spaces not allowed.

Regards

Jon

From: Dots [mailto: [email-masked]] On Behalf Of [email-masked]
Sent: 21 April 2020 15:20
To: Jon Shallow; [email-masked]
Subject: [Dots] multiple values in the filter RE: DOTS telemetry Issues picked up in Interop Testing

Re-,

Cheers,
Med

Hi all,

And

---

From: "Jon Shallow" <[email-masked]>
Date: Wed, 22 Apr 2020 10:32:46 +0100

Hi Med,

Thanks – this works for me.

Regards

Jon

From: Dots [mailto: [email-masked]] On Behalf Of
[email-masked]
Sent: 22 April 2020 10:26
To: Jon Shallow; [email-masked]
Subject: Re: [Dots] multiple values in the filter RE: DOTS telemetry Issues
picked up in Interop Testing

Re-,

·         Contiguous blocks

·         wildcard

OLD:

NEW:

   values separated by a "-" character..  Wildcard names (i.e., a name

   Query option.

Better?

Cheers,

Med

Objet : RE: [Dots] multiple values in the filter RE: DOTS telemetry Issues

Regards

Jon

Re-, 

Cheers,

Med

 

Hi all,

And 

Jon> fair point about lower and upper ports..  Uri-Query:
target-port[80-85,443] works for me and covers both ranges and individual
ports.