Subject: [Dots] I-D Action: draft-ietf-dots-telemetry-07.txt

From: [email-masked]
Date: Wed, 15 Apr 2020 12:25:33 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DDoS Open Threat Signaling WG of the IETF.

        Title           : Distributed Denial-of-Service Open Threat Signaling (DOTS) Telemetry
        Authors         : Mohamed Boucadair
                          Tirumaleswar Reddy
                          Ehud Doron
                          Meiling Chen
	Filename        : draft-ietf-dots-telemetry-07.txt
	Pages           : 95
	Date            : 2020-04-15

Abstract:
   This document aims to enrich DOTS signal channel protocol with
   various telemetry attributes allowing optimal DDoS attack mitigation.
   It specifies the normal traffic baseline and attack traffic telemetry
   attributes a DOTS client can convey to its DOTS server in the
   mitigation request, the mitigation status telemetry attributes a DOTS
   server can communicate to a DOTS client, and the mitigation efficacy
   telemetry attributes a DOTS client can communicate to a DOTS server.
   The telemetry attributes can assist the mitigator to choose the DDoS
   mitigation techniques and perform optimal DDoS attack mitigation.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dots-telemetry/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dots-telemetry-07
https://datatracker.ietf.org/doc/html/draft-ietf-dots-telemetry-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-telemetry-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Thu, 16 Apr 2020 05:39:45 +0000

Hi all, 

This is a minor revision with the following changes: 

* add a NEW text and pointer to Block3/Block4 options but without any normative language. 
* add a clarification that attack level is implementation-specific (to address a comment from Meiling)
* clarify that telemetry setup is not deleted when a DOTS session is lost. Its validity depends on the association with a dots client domain, not a transport session. 
* unit-status is mandatory when configuring units.
* add a clarification about overlapping targets to cover resolving IP addresses of fqdns/uri/aliases. 
* clarify that telemetry-notify-interval does not consider each "fragmented" notification as a single notification (if blocks are used to send a notification).
* clarify that data included in some attributes assumes that any uri-query filters are applied. 

Cheers,
Med

> -----Message d'origine-----
> De : I-D-Announce [mailto:[email-masked]] De la part de
> [email-masked]
> Envoyé : mercredi 15 avril 2020 21:26
> À : [email-masked]
> Cc : [email-masked]
> Objet : I-D Action: draft-ietf-dots-telemetry-07.txt
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt