Subject: [Dots] TR: New Version Notification for draft-boucadair-dots-rfc8782-bis-00.txt

From: <[email-masked]>
Date: Mon, 27 Jul 2020 06:01:23 +0000

Hi all, 

As per the advice from the AD and the wG chairs, we prepared an candidate bis with the following changes: 
* update the module to use sx:structure (RFC8791)
* add a section that lists the main errors returned by the server
* update the iana allocation policy for the key values to align with the outcome of the telemetry discussion

The core specification is not updated. 

Cheers,
Med

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] 
Envoyé : lundi 27 juillet 2020 07:54
À : BOUCADAIR Mohamed TGI/OLN <[email-masked]>; Jon Shallow <[email-masked]>; Tirumaleswar Reddy.K <[email-masked]>
Objet : New Version Notification for draft-boucadair-dots-rfc8782-bis-00.txt

A new version of I-D, draft-boucadair-dots-rfc8782-bis-00.txt
has been successfully submitted by Mohamed Boucadair and posted to the IETF repository.

Name:		draft-boucadair-dots-rfc8782-bis
Revision:	00
Title:		Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Specification
Document date:	2020-07-26
Group:		Individual Submission
Pages:		119
URL:            https://www.ietf.org/internet-drafts/draft-boucadair-dots-rfc8782-bis-00.txt
Status:         https://datatracker.ietf.org/doc/draft-boucadair-dots-rfc8782-bis/
Htmlized:       https://tools.ietf.org/html/draft-boucadair-dots-rfc8782-bis-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-boucadair-dots-rfc8782-bis

Abstract:
   This document specifies the Distributed Denial-of-Service Open Threat
   Signaling (DOTS) signal channel, a protocol for signaling the need
   for protection against Distributed Denial-of-Service (DDoS) attacks
   to a server capable of enabling network traffic mitigation on behalf
   of the requesting client.

   A companion document defines the DOTS data channel, a separate
   reliable communication layer for DOTS management and configuration
   purposes.

   This document obsoletes RFC 8782.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Wed, 29 Jul 2020 13:14:29 +0000

Hi all, 

I forgot to mention the reasons why we need to urgently advance this specification (adoption followed hopefully by a WGLC):

* During the review of the telemetry spec by the yangdoctors, they raised a concern about how we use YANG to model the structure of the signal channel message. In order to solve that issue, we agreed to use the new feature specified in RFC8791. 

* Nevertheless, updating the telemetry spec is not sufficient because the modification has to be done against the module in RFC8782. 

* To that aim, we considered many options to make the modification: errata, updating the yang module only, include the updated module in the telemetry, or edit a bis document. 

* After consulting with the Chairs and the AD, the advice is to edit a minor update bis document: draft-boucadair-dots-rfc8782-bis 

* This update has to be progressed quickly because of the dependency of other DOTS Specs: 
  - filter control which is in the RFC Editor Queue.
  - Call Home which is waiting for the AD review
  - The telemetry specification which we target to put in the WGLC hopefully soon.

The changes are very focused as summarized in draft-boucadair-dots-rfc8782-bis.

Cheers,
Med

> De : Dots [mailto:[email-masked]] De la part de
> [email-masked]
> Envoyé : lundi 27 juillet 2020 08:01
> À : [email-masked]
> Objet : [Dots] TR: New Version Notification for draft-boucadair-dots-
> rfc8782-bis-00.txt
> 
> Hi all,
> 
> As per the advice from the AD and the wG chairs, we prepared an
> candidate bis with the following changes:
> Envoyé : lundi 27 juillet 2020 07:54 À : BOUCADAIR Mohamed TGI/OLN
> <[email-masked]>; Jon Shallow <supjps-
> [email-masked]>; Tirumaleswar Reddy.K <[email-masked]> Objet :
> New Version Notification for draft-boucadair-dots-rfc8782-bis-00.txt
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> The IETF Secretariat
> 
> 
> 
> ______________________________________________________________________
> ___________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les
> messages electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or
> privileged information that may be protected by law;
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots