Subject: [Dots] I-D Action: draft-ietf-dots-telemetry-10.txt

From: [email-masked]
Date: Fri, 10 Jul 2020 00:55:28 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DDoS Open Threat Signaling WG of the IETF.

        Title           : Distributed Denial-of-Service Open Threat Signaling (DOTS) Telemetry
        Authors         : Mohamed Boucadair
                          Tirumaleswar Reddy
                          Ehud Doron
                          Meiling Chen
                          Jon Shallow
	Filename        : draft-ietf-dots-telemetry-10.txt
	Pages           : 109
	Date            : 2020-07-10

Abstract:
   This document aims to enrich DOTS signal channel protocol with
   various telemetry attributes allowing optimal Distributed Denial-of-
   Service attack mitigation.  It specifies the normal traffic baseline
   and attack traffic telemetry attributes a DOTS client can convey to
   its DOTS server in the mitigation request, the mitigation status
   telemetry attributes a DOTS server can communicate to a DOTS client,
   and the mitigation efficacy telemetry attributes a DOTS client can
   communicate to a DOTS server.  The telemetry attributes can assist
   the mitigator to choose the DDoS mitigation techniques and perform
   optimal DDoS attack mitigation.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dots-telemetry/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dots-telemetry-10
https://datatracker.ietf.org/doc/html/draft-ietf-dots-telemetry-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-telemetry-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Fri, 10 Jul 2020 08:07:00 +0000

Hi all, 

This version integrates the inputs received in the interim and the three issues raised in the interop and then discussed on the list. Note that the document updates 8782 as we are changing some of the IANA assignment policies: 128-255 range for comprehension-optional attribute. 

Also, this version addresses the yangdoctors review. That is mainly use "sx:structure" rather than containers. The internal structure of the telemetry message is not modified. The new design requires a ** normative dependency ** on the 8782-yang-update draft. That issue is currently worked out with the chairs/Ben. 

We also added a NEW section called 'Error Handling" which is basically summarizing what we do already have in the specs. This section is meant to provide more visibility on error handling. 

Some other edits are made to enhance the readability of the document and fix nits. 

This version is ready for the WGLC.

Cheers,
Med

> -----Message d'origine-----
> De : I-D-Announce [mailto:[email-masked]] De la
> part de [email-masked]
> Envoyé : vendredi 10 juillet 2020 09:55
> À : [email-masked]
> Cc : [email-masked]
> Objet : I-D Action: draft-ietf-dots-telemetry-10.txt
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.