Subject: [Dots] I-D Action: draft-ietf-dots-telemetry-13.txt

From: [email-masked]
Date: Thu, 08 Oct 2020 06:53:47 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DDoS Open Threat Signaling WG of the IETF.

        Title           : Distributed Denial-of-Service Open Threat Signaling (DOTS) Telemetry
        Authors         : Mohamed Boucadair
                          Tirumaleswar Reddy
                          Ehud Doron
                          Meiling Chen
                          Jon Shallow
	Filename        : draft-ietf-dots-telemetry-13.txt
	Pages           : 107
	Date            : 2020-10-08

Abstract:
   This document aims to enrich DOTS signal channel protocol with
   various telemetry attributes allowing optimal Distributed Denial-of-
   Service attack mitigation.  It specifies the normal traffic baseline
   and attack traffic telemetry attributes a DOTS client can convey to
   its DOTS server in the mitigation request, the mitigation status
   telemetry attributes a DOTS server can communicate to a DOTS client,
   and the mitigation efficacy telemetry attributes a DOTS client can
   communicate to a DOTS server.  The telemetry attributes can assist
   the mitigator to choose the DDoS mitigation techniques and perform
   optimal DDoS attack mitigation.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dots-telemetry/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dots-telemetry-13
https://datatracker.ietf.org/doc/html/draft-ietf-dots-telemetry-13

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-telemetry-13

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Thu, 8 Oct 2020 14:00:03 +0000

Hi all, 

We made a minor edit to use the new Block3/4 names as defined by the core WG: Quick-Block1/2. 

We also fixed a very minor error in the YANG module. 

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]] De la part de internet-
> [email-masked]
> Envoyé : jeudi 8 octobre 2020 15:54
> À : [email-masked]
> Cc : [email-masked]
> Objet : [Dots] I-D Action: draft-ietf-dots-telemetry-13.txt
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Meiling Chen" <[email-masked]>
Date: Fri, 9 Oct 2020 17:39:53 +0800

Hi med,
Is Quick-Block specific to Telemetry transfer or general to Signal put method?

Best Regards,
Meiling

From: [email-masked]
Date: 2020-10-08 22:00
To: [email-masked]
Subject: Re: [Dots] I-D Action: draft-ietf-dots-telemetry-13.txt
Hi all, 

 
Cheers,
Med

---

From: "Jon Shallow" <[email-masked]>
Date: Fri, 9 Oct 2020 11:25:00 +0100

Hi Meiling,

Interesting question.

In my implementation this Quick-Block(1|2) is all handled in libcoap which does not care whether this is a telemetry update or signal update.

I do not think that it should be restricted only to Telemetry.

Regards

Jon

From: Dots [mailto:[email-masked]] On Behalf Of Meiling Chen
Sent: 09 October 2020 10:40
To: mohamed.boucadair; dots
Subject: Re: [Dots] I-D Action: draft-ietf-dots-telemetry-13.txt

Hi med,

Best Regards,

Meiling

Date: 2020-10-08 22:00

To: [email-masked]

Hi all, 

Cheers,

Med

> A New Internet-Draft is available from the on-line Internet-Drafts

> directories.

> This draft is a work item of the DDoS Open Threat Signaling WG of

> the IETF.

>         Title           : Distributed Denial-of-Service Open Threat

> Signaling (DOTS) Telemetry

>    various telemetry attributes allowing optimal Distributed Denial-

> of-

>    Service attack mitigation.  It specifies the normal traffic

> baseline

>    and attack traffic telemetry attributes a DOTS client can convey

> to

>    telemetry attributes a DOTS server can communicate to a DOTS

> client,

>    and the mitigation efficacy telemetry attributes a DOTS client

> can

>    communicate to a DOTS server.  The telemetry attributes can

> assist

>    the mitigator to choose the DDoS mitigation techniques and

> perform

Thank you.

Dots mailing list

[email-masked]

---

From: <[email-masked]>
Date: Fri, 9 Oct 2020 13:06:38 +0000

Hi all,

I agree with Jon.

We may consider adding some text to the 8782bis using the same wording of the telemetry I-D: no normative language.

Cheers,
Med

De : Jon Shallow [mailto:[email-masked]]
Envoyé : vendredi 9 octobre 2020 12:25
À : 'Meiling Chen' <[email-masked]>; BOUCADAIR Mohamed TGI/OLN <[email-masked]>; [email-masked]
Objet : RE: [Dots] I-D Action: draft-ietf-dots-telemetry-13.txt

Hi Meiling,

Interesting question.

Regards

Jon

Hi med,

Best Regards,
Meiling

From: [email-masked]<mailto:[email-masked]>
Date: 2020-10-08 22:00
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Dots] I-D Action: draft-ietf-dots-telemetry-13.txt
Hi all,

Cheers,
Med

> [email-masked]<mailto:[email-masked]>
> À : [email-masked]<mailto:[email-masked]>
> Cc : [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
Dots mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dots