Subject: [Dots] WGLC for draft-ietf-dots-telemetry-13

From: "Valery Smyslov" <[email-masked]>
Date: Tue, 27 Oct 2020 10:09:20 +0300

Hi,

this message starts a two-week working group last call for draft-ietf-dots-telemetry-13,
which will end on Wednesday, November 11. Please, review the draft carefully and
send your comments to the mailing list.

Regards,
Frank & Valery.

---

From: <[email-masked]>
Date: Fri, 30 Oct 2020 12:28:42 -0000

Hi there,

Issues found during Interop testing 30 Oct 2020.

1)
ietf-dots-telemetry:telemetry is not in the CBOR mapping and needs to be
added.

2)
Clarity needed.  We have

   A DOTS client uses a GET request to retrieve its vendor attack
   mapping details as maintained by the DOTS server (Figure 35).

   GET /restconf/data/ietf-dots-data-channel:dots-data\
       /dots-client=dz6pHjaADkaFTbjr0JGBpw\
       /ietf-dots-mapping:vendor-mapping?\
       content=all HTTP/1.1
   Host: example.com
   Accept: application/yang-data+json

    Figure 35: GET to Retrieve Installed Vendor Attack Mapping Details

If there has not been any POST/PUT vendor-mapping for dots-client=XX, what
is the response for the GET?
4.04 or generic mappings that the server knows about?
- my preference is for the HTTP 4.04 as there (currently) are no mapping
details maintained for the dots-client=

Regards

Jon

> -----Original Message-----
> From: Dots [mailto: [email-masked]] On Behalf Of Valery
> Smyslov
> Sent: 27 October 2020 07:09
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: [Dots] WGLC for draft-ietf-dots-telemetry-13
> 
> Hi,
> 
> this message starts a two-week working group last call for
draft-ietf-dots-
> telemetry-13,
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: <[email-masked]>
Date: Fri, 30 Oct 2020 12:55:57 +0000

Hi Jon,

Thank you for sharing these comments.

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]] De la part de supjps-
> [email-masked]
> Envoyé : vendredi 30 octobre 2020 13:29
> À : 'Valery Smyslov' <[email-masked]>; [email-masked]; dots-
> [email-masked]; [email-masked]
> Objet : Re: [Dots] WGLC for draft-ietf-dots-telemetry-13
> 
> Hi there,
> 
> ietf-dots-telemetry:telemetry is not in the CBOR mapping and needs
> to be added.
> 

[Med] Indeed. This used to be 32916 in the implementation mapping table.

Fixed in https://github.com/boucadair/draft-dots-telemetry/commit/f0ffd2bee65ccedf728f57b0769ee56eabb1e861. Thanks. 

> If there has not been any POST/PUT vendor-mapping for dots-
> client=XX, what is the response for the GET?

[Med] This one is covered by the base RESTCONF spec: 

   If a retrieval request for a data resource represents an instance
   that does not exist, then an error response containing a "404 Not
   Found" status-line MUST be returned by the server.

This is why we don't specify a similar error in 8783 when no alias or filtering is matching a GET. 

Please note that we don't discuss if the clients is not registered (and so on) as these cases are already covered in 8783. 

> - my preference is for the HTTP 4.04 as there (currently) are no
> mapping details maintained for the dots-client=
> 
> Regards
> 
> Jon
> 
> > which will end on Wednesday, November 11. Please, review the draft
> > carefully and send your comments to the mailing list.
> >
> > Regards,
> > Frank & Valery.
> >

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Fri, 30 Oct 2020 13:15:30 -0000

Hi Med,

Thanks for the comments/update - all good for me.

Regards

Jon

> From: Dots [mailto: [email-masked]] On Behalf Of
[email-masked]
> Sent: 30 October 2020 12:56
> To: [email-masked]; 'Valery Smyslov'; [email-masked]; dots-
> Subject: Re: [Dots] WGLC for draft-ietf-dots-telemetry-13
> 
> Hi Jon,
> 
> Fixed in https://github.com/boucadair/draft-dots-
> telemetry/commit/f0ffd2bee65ccedf728f57b0769ee56eabb1e861. Thanks.
> 
> > 2)
> > Clarity needed.  We have
> >
> This is why we don't specify a similar error in 8783 when no alias or
filtering
> is matching a GET.
> 
> Please note that we don't discuss if the clients is not registered (and so
on)
> as these cases are already covered in 8783.
> 
> ___________________________________________________________________
> ______________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
recu ce
> message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> If you have received this email in error, please notify the sender and
delete
> this message and its attachments.