Subject: Re: [Dots] Shepherd review of draft-ietf-dots-telemetry-use-cases

From: H Y <[email-masked]>
Date: Sat, 2 Apr 2022 10:12:24 +0900

Hi Valery,

Thank you for your careful review.

We fixed the nits and posted it as draft-ietf-dots-telemetry-use-cases-10.

>4. Section 3.1.1.
>   After that, the orchestrator
>   orders the forwarding nodes to redirect as much of the top talker's traffic...
> Shouldn't it be top-talkers' ?
>7. Section 3.1.5.
> s/The forwarding nodes  send traffic statistics ... to the orchestrator the using "vendor-id" and "attack-id" telemetry attributes/
> The forwarding nodes  send traffic statistics ... to the orchestrator by using "vendor-id" and "attack-id" telemetry attributes

We found the same nits in draft-ietf-dots-telemetry-use-cases-9, so we
fixed them all.

Thanks,
Yuhei

2022年3月31日(木) 22:54 Valery Smyslov <[email-masked]>:
>
> Hi,
>
> I reviewed the document and found some nits (mostly grammar and typos).
>
> 1. Abstract.
>
> The expansion of DOTS is "DDoS Open Threat Signaling". In the abstract it is expanded as "Denial-of-service Open Threat Signaling".
>
> 2. Figure 1, Figure 3, Figure 5, Figure 7, Figure 16, Figure 18.
>
> All contain the same typo:
>
> s/S is for DOTS client functionality/S is for DOTS server functionality
>
> 3. Section 3.1.1.
>
> IPFIX, BGP, SNMP aren't expanded on first use.
>
> 4. Section 3.1.1.
>
>    After that, the orchestrator
>    orders the forwarding nodes to redirect as much of the top talker's traffic...
>
> Shouldn't it be top-talkers' ?
>
> 5. Figure 7.
>
> s/BGP Flow spec/BGP Flowspec
>
> 6. Section 3.1.5.
>
> s/It may also necessary/It may also be necessary
>
> 7. Section 3.1.5.
>
> s/The forwarding nodes  send traffic statistics ... to the orchestrator the using "vendor-id" and "attack-id" telemetry attributes/
> The forwarding nodes  send traffic statistics ... to the orchestrator by using "vendor-id" and "attack-id" telemetry attributes
>
> 8. Section 3.2.
>
> s/Figure 15 provides ...  from the orchestrator to the network ./Figure 15 provides ...  from the orchestrator to the network.
>
> 9. Section 3.2.
>
> s/Then, the DDoS mitigation systems reports the status of DDoS countermeasures to the orchestrator sending "attack-detail" telemetry
> attributes./
> Then, the DDoS mitigation systems reports the status of DDoS countermeasures to the orchestrator by sending "attack-detail"
> telemetry attributes.
>
> 10. Section 3.2.
>
> s/After  that, the orchestrator integrates the reports ... and send it to a network administrator .../
> After  that, the orchestrator integrates the reports ... and sends them to a network administrator ...
>
> (two places)
>
> 11. Section 3.3.1.
>
>    On the other hand, DDoS detection based on the
>    DMSes is a more accurate method for detecting attack traffic better
>    than flow monitoring.
>
> I have trouble parsing this text. Probably:
>
>   On the other hand, DDoS detection based on the
>    DMSes is a more accurate method for detecting attack traffic
>    than flow monitoring.
>
> 12. Section 3.3.1.
>
> s/The aim of this use case is to increases flow collector's detection .../The aim of this use case is to increase flow collector's
> detection ...
>
> 13. Section 3.3.1.
>
> s/statisticsto/statistics to
>
> 14. Section 4.
>
> s/a DDoS attacks/DDoS attacks
>
> Regards,
> Valery.
>

-- 
----------------------------------
Yuuhei HAYASHI
08065300884
[email-masked]
[email-masked]
----------------------------------

---

From: "Valery Smyslov" <[email-masked]>
Date: Mon, 4 Apr 2022 10:26:16 +0300

Hi Yuhei,

thank you for updating the document. I've been waiting for the 
remaining author to provide IPR confirmation. Once I receive it,
I'll send the document to IESG.

Regards,
Valery.

---

From: "SuLi" <[email-masked]>
Date: Tue, 5 Apr 2022 16:31:16 +0800

Dear all:
	I don't have any IPR in this draft.

Best Regards!
Su Li(粟栗)

-----邮件原件-----
发件人: Valery Smyslov [mailto:[email-masked]] 
发送时间: 2022年4月4日 15:26
收件人: 'H Y'
抄送: [email-masked]; 'dots'; 'dots-chairs'
主题: RE: Shepherd review of draft-ietf-dots-telemetry-use-cases

Hi Yuhei,

Regards,
Valery.

---

From: "Valery Smyslov" <[email-masked]>
Date: Mon, 11 Apr 2022 14:20:12 +0300

Hi,

BCP78 and BCP79 requires that all authors and contributors confirm that they are 
not _aware_ of any IPR (or disclose them). So, it is not sufficient to confirm 
that you don't _have_ any IPR, you must confirm that you are not _aware_
of any IPR (for example, your employer may have one). Note, that you are not
required to search through all IPRs, you only required to confirm that you
are not aware of any.

So, please you re-confirm that you are not aware of any IPR related to the draft.

Regards,
Valery.

> > > The expansion of DOTS is "DDoS Open Threat Signaling". In the abstract it is expanded as "Denial-of-
> service
> > Open Threat Signaling".
> > >
> > > s/Figure 15 provides ...  from the orchestrator to the network ./Figure 15 provides ...  from the
> orchestrator
> > to the network.
> > >
> > > 9. Section 3.2.
> > >
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: "SuLi" <[email-masked]>
Date: Tue, 12 Apr 2022 09:09:11 +0800

Dear all,
	As one of the authors, I'm not aware of any IPR for this draft. 
	Thank you.

Best Regards!
Su Li(粟栗)

-----邮件原件-----
发件人: Valery Smyslov [mailto:[email-masked]] 
发送时间: 2022年4月11日 19:20
收件人: 'SuLi'
抄送: [email-masked]; 'dots'; 'dots-chairs'
主题: RE: [Dots] 答复: Shepherd review of draft-ietf-dots-telemetry-use-cases

Hi,

Regards,
Valery.