Subject: [Driu] Proposed agenda

From: Paul Hoffman <[email-masked]>
Date: Wed, 20 Jun 2018 16:06:01 +0000

Greetings. Even though the discussion here has been less vigorous than I expected, there is clearly some interest in the topics. I suspect when we get a bunch of people in the room, the mic lines might engender more interest in specific topics.

Also, I'm volunteering folks who might not be attending the meeting. If you are interested in preparing a presentation but are not going to be at the meeting, getting someone else to present is just fine.

We have 90 minutes. I propose the following, but am totally open to other suggestions. In particular, if someone has a draft or even a partially-formed idea about topics related to DNS resolver identification and use, please speak up now so we can give scheduled time instead of open mic time. Some areas I suspect people may have ideas are:
- DNS resolver choice in protocols other than DHCP
- DHCP configuration for protocols other than DNS that have multiple transports (maybe SMTP?)
- Fallbacks from secure to non-secure where there is no user interface for warnings

Intro to the topics: 15 mins (Paul Hoffman)
DHCPv6 Options for private DNS Discovery: 15 mins (Tom Pusateri and Willem Toorop)
Levels of security and privacy for different resolver transports: 15 mins (Sara Dickinson)
Open mic (remainder of time)

With the current agenda, we are just before the last DNSOP meeting, so we will hopefully have a good turnout of DNS folks. I hope we also get a good turnout of folks who think about configuration as well.

--Paul Hoffman

---

From: Tom Pusateri <[email-masked]>
Date: Wed, 20 Jun 2018 12:18:40 -0400

> On Jun 20, 2018, at 12:06 PM, Paul Hoffman <[email-masked]> wrote:
> 

I expect much of the discussion of DHCP to get bogged down in the threat analysis of providing secure DNS configuration over DHCP. I think this would be better served by creating a separate agenda item for discussion. As mentioned before, I have written a threat document here but continue to work on it.

https://github.com/pusateri/draft-tpwt-dhc-dns-discovery/blob/master/threat.md <https://github.com/pusateri/draft-tpwt-dhc-dns-discovery/blob/master/threat.md>

Tom

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 20 Jun 2018 16:22:33 +0000

On Jun 20, 2018, at 9:18 AM, Tom Pusateri <[email-masked]> wrote:
> https://github.com/pusateri/draft-tpwt-dhc-dns-discovery/blob/master/threat.md [github.com]

Does this sound better?
DHCPv6 Options for private DNS Discovery: 15 mins (Tom Pusateri and Willem Toorop)
Secure DNS Configuration over DHCP: 15 mins (Tom Pusateri and Willem Toorop)

--Paul Hoffman

---

From: Tom Pusateri <[email-masked]>
Date: Wed, 20 Jun 2018 12:24:43 -0400

> On Jun 20, 2018, at 12:22 PM, Paul Hoffman <[email-masked]> wrote:
> 

Can we reverse the order? I think Ted would argue that we should decide if it’s something we want to do before we show how we would do it.
‘
Tom