Subject: [dtn-users] DTNSIM, import.tcl not found

From: Maziar Mirzazad <[email-masked]>
Date: Tue, 23 Aug 2011 10:54:36 +0000

Dear all,
I am trying to run dtnsim in DTN2 refrence implementation.
When I run " ./dtnsim -c conf/two-node.conf ", I get the below error :

[0.000000 /dtnsim notice] random seed is 0
[0.000000 /dtnsim info] registered dtnsim commands
[0.000000 /dtnsim info] intialized dtnsim components
[0.000000 /dtnsim info] parsing configuration file conf/two-node.conf...
[0.000000 /command error] error: line 13: 'couldn't read file "/usr/dtn-2.7.0/../test-utils/import.tcl": no such file or directory':
couldn't read file "/usr/dtn-2.7.0/../test-utils/import.tcl": no such file or directory
    while executing
"source "$base_test_dir/../test-utils/import.tcl""
    (file "/usr/dtn-2.7.0/sim/sim-test-utils.tcl" line 5)
    invoked from within
"source $base_test_dir/sim/sim-test-utils.tcl"
    (file "conf/two-node.conf" line 13)
[0.000000 /dtnsim error] error in configuration file, exiting...

There is no import.tcl file!
Thanks in advance for any help.

Regards,

Maziar

---

From: "Alex McMahon" <[email-masked]>
Date: Tue, 23 Aug 2011 12:56:31 +0100 (IST)

Hi Maziar,

In your root dir do

hg clone http://dtn.hg.sourceforge.net/hgweb/dtn/test-utils/
cd DTN2/test; make

All the best

Alex

> [0.000000 /command error] error: line 13: 'couldn't read file
> "/usr/dtn-2.7.0/../test-utils/import.tcl": no such file or directory':
> _______________________________________________
> dtn-users mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-users
>

---

From: Maziar Mirzazad <[email-masked]>
Date: Tue, 23 Aug 2011 13:25:39 +0000

Hi Alex,
Thank you for your reply.
Now I faced a new problem : after I run the ./dtnsim, I get the following error :

ASSERTION FAILED (all_bundles_->contains(bundle)) at bundling/BundleDaemon.cc:2383 STACK TRACE: 0x818881f 0x8084475 0x8098563 0x8089fdd 0x805b892 0x80637d4 0x80639cd 0x8055aa0 0x8055e96 0x91ddec Aborted

Do you know what is the problem?
Best regards,

Maziar

-----Original Message-----
From: Alex McMahon [mailto:[email-masked]] 
Sent: Tuesday, August 23, 2011 1:57 PM
To: Maziar Mirzazad
Cc: [email-masked]
Subject: Re: [dtn-users] DTNSIM, import.tcl not found

Hi Maziar,

In your root dir do

All the best

Alex