Subject: [dtn-users] DTN2 Larger Network Problem

From: Maziar Mirzazad <[email-masked]>
Date: Wed, 3 Aug 2011 14:17:12 +0000

Dear All,
I was trying to implement DTN2 on my laptop. My problem in building larger networks is as follow :

My problem :
I have two virtual machines of red hat linux on my laptop. In both VMs, I installed DTN2.
As in each of them, I run the command "dtnping localhost" It works fine.
Also if I send e message using "dtnsend" command, I can receive the message by "dtnrecv" command.
Also I can ping one virtual machine from other VM using the regular ping command.

The problem is when I try to ping one VM from other VM using "dtnping" command, I don't get any replies.
Also I can't send any message using  "dtnsend" command from one VM to other VM.

You can find dtn.conf files of both VMs attached.

I would be very glad if you can help me.

Best Regards,
Maziar

---

From: Aidan Lynch <[email-masked]>
Date: Wed, 03 Aug 2011 16:01:31 +0100

Hi Maziar,

You should only need to set up a link in one direction for the routes to 
work. I've reattached the config files you sent with a few changes made 
to the routing section and a bunch of the comments striped out.

If you telnet into port 5050 and run 'link dump' and 'route dump' it 
will tell you what connections are available.

Hope this helps,
Aidan

On 03/08/11 15:17, Maziar Mirzazad wrote:
> *My problem : *
> *The problem is* when I try to ping one VM from other VM using 
> "dtnping" command, I don't get any replies.
>
> _______________________________________________
> dtn-users mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-users

---

From: Maziar Mirzazad <[email-masked]>
Date: Wed, 3 Aug 2011 16:16:20 +0000

Hi Aidan,
Thank you for your reply.

I tried as you said. But unfortunately it didn't work. I checked the routes using route dump. Link in one direction is available. But when I send a dtnping message, It expires and link status changes to UNAVAILABLE.

Regards,
Maziar

From: [email-masked] [mailto:[email-masked]] On Behalf Of Aidan Lynch
Sent: Wednesday, August 03, 2011 5:02 PM
To: [email-masked]
Subject: Re: [dtn-users] DTN2 Larger Network Problem

Hi Maziar,

You should only need to set up a link in one direction for the routes to work. I've reattached the config files you sent with a few changes made to the routing section and a bunch of the comments striped out.

If you telnet into port 5050 and run 'link dump' and 'route dump' it will tell you what connections are available.

Hope this helps,
Aidan

My problem :

Best Regards,
Maziar

dtn-users mailing list

[email-masked]<mailto:[email-masked]>

---

From: "Andresen, Jason R." <[email-masked]>
Date: Wed, 3 Aug 2011 12:20:59 -0400

You might want to make sure there isn't a firewall on the VM host that is blocking DTN.  Also double check the firewalls on your VMs to make sure they allow DTN traffic in.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Maziar Mirzazad
Sent: Wednesday, August 03, 2011 12:16 PM
To: Aidan Lynch; [email-masked]
Subject: Re: [dtn-users] DTN2 Larger Network Problem

Hi Aidan,

Regards,
Maziar

Hi Maziar,

Hope this helps,
Aidan

My problem :

Best Regards,
Maziar

dtn-users mailing list

---

From: Maziar Mirzazad <[email-masked]>
Date: Wed, 3 Aug 2011 16:31:19 +0000

Hi Aidan,

I totally forgot about firewall !
Thank you very much for your kind help :)
Best Regards.

Maziar Mirzazad

From: Andresen, Jason R. [mailto:[email-masked]]
Sent: Wednesday, August 03, 2011 6:21 PM
To: Maziar Mirzazad; Aidan Lynch; [email-masked]
Subject: RE: [dtn-users] DTN2 Larger Network Problem

Hi Aidan,

Regards,
Maziar

Hi Maziar,

Hope this helps,
Aidan

My problem :

Best Regards,
Maziar

dtn-users mailing list

---

From: Aidan Lynch <[email-masked]>
Date: Wed, 03 Aug 2011 17:36:48 +0100

Not my idea but glad it's working :)

Aidan

On 03/08/11 17:31, Maziar Mirzazad wrote:
> Thank you very much for your kind help J
>
> Best Regards.
>
> Maziar Mirzazad
>
> *From:*Andresen, Jason R. [mailto:[email-masked]]
> *Sent:* Wednesday, August 03, 2011 6:21 PM
> *To:* Maziar Mirzazad; Aidan Lynch; [email-masked]
> *Subject:* RE: [dtn-users] DTN2 Larger Network Problem
>
> You might want to make sure there isn't a firewall on the VM host that 
> is blocking DTN.  Also double check the firewalls on your VMs to make 
> sure they allow DTN traffic in.
>
> *From:[email-masked] [mailto:[email-masked]] 
> *On Behalf Of *Maziar Mirzazad
> *Sent:* Wednesday, August 03, 2011 12:16 PM
> *To:* Aidan Lynch; [email-masked]
> *Subject:* Re: [dtn-users] DTN2 Larger Network Problem
>
> Hi Aidan,
>
> I tried as you said. /But unfortunately it didn't work/. I checked the 
> routes using route dump. Link in one direction is available. But when 
> I send a dtnping message, It expires and link status changes to 
> UNAVAILABLE.
>
> Regards,
>
> Maziar
>
> *From:[email-masked] [mailto:[email-masked]] 
> *On Behalf Of *Aidan Lynch
> *Sent:* Wednesday, August 03, 2011 5:02 PM
> *To:* [email-masked]
> *Subject:* Re: [dtn-users] DTN2 Larger Network Problem
>
> Hi Maziar,
>
> You should only need to set up a link in one direction for the routes 
> to work. I've reattached the config files you sent with a few changes 
> made to the routing section and a bunch of the comments striped out.
>
> [email-masked]  <mailto:[email-masked]>