Subject: [dtn-users] DTN multiple gateway routing

From: Meisuchi Naisuty <[email-masked]>
Date: Sun, 1 Apr 2012 22:15:26 -0700

hi..
Is it DTN able to search for alternative way?
im trying configuration the dtn.conf with 2 links

this the conf:
route add dtn://r1.dtn/* link1
route add dtn://r1.dtn/* link2

there are 2 links..
when the link1 eth down
it cant ping to r1 by link2

any configuration that I missing?
thanks for response :D

---

From: Darren Long <[email-masked]>
Date: Mon, 02 Apr 2012 18:33:51 +0100

Hi,

I guess you are currently using the static router.  You may have more luck with the router type set to dtlsr  (the Delay Tolerant Link State Router - http://kfall.net/ucbpage/papers/dtlsr-nsdr07.pdf) on all nodes. 

The grc-dtnbone (http://www.dtnrg.org/wiki/DtnBone/grc-dtnbone) uses the dtlsr router, and if you look at the connectivity graph   (http://grc.nasa.dtnbone.net) you can see that connectivity between the 'mike' and 'india' nodes flaps around between links via the 'juliet', 'kilo' and 'lima' nodes.

Hope this helps.

Darren

---

From: Darren Long <[email-masked]>
Date: Tue, 03 Apr 2012 08:57:46 +0100

Hi Mesuchi,

Try:
	route set type dtlsr

instead of 
	route set type static

Then you don't need to explicitly declare routes, just links. 

When the links come up, 'adjacent' nodes exchange link state advisory bundles and the routing table is automatically populated.

Once you have some links up, type:
	bundle list
in the dtnd console and you should see some lsa bundles.  Typing:
	route dump
should show you routes derived from the LSA bundles you've received so far.

Darren 

On 3 Apr 2012, at 06:00, Meisuchi Naisuty wrote:

> but i found  no configuration at there.. may you give me the example
> of the DSLTR configuration?
> :D
> 
> On 4/2/12, Darren Long <[email-masked]> wrote:
>> Hi,
>> 
>> I guess you are currently using the static router.  You may have more luck
>> with the router type set to dtlsr  (the Delay Tolerant Link State Router -
>> http://kfall.net/ucbpage/papers/dtlsr-nsdr07.pdf) on all nodes.
>> 
>> The grc-dtnbone (http://www.dtnrg.org/wiki/DtnBone/grc-dtnbone) uses the
>> dtlsr router, and if you look at the connectivity graph
>> (http://grc.nasa.dtnbone.net) you can see that connectivity between the
>> 'mike' and 'india' nodes flaps around between links via the 'juliet', 'kilo'
>> and 'lima' nodes.
>> 
>> Hope this helps.
>> 
>> Darren
>>