Subject: [dtn-users] problem in runing DTN2

From: ahmed elouadrhiri <[email-masked]>
Date: Sat, 16 Jun 2012 17:38:54 +0000

Hi all;

when i try :

daemon/dtnd -c /home/fred/dtn/dtn.conf --init-db

the error :

daemon/dtnd: error while loading shared libraries: libdb-5.2.so:
cannot open shared object file: No such file or directory

help please, I searched the problem in the archive of the mailing
list, I found the problem and I have not found the answer.

Thank you for your Help.

Ahmed

Best Regards

---

From: Darren Long <[email-masked]>
Date: Sat, 16 Jun 2012 19:55:38 +0100

Hi Ahmed,

You could try:

    sudo ldconfig

That may help.

Darren

On 16/06/12 18:38, ahmed elouadrhiri wrote:
> daemon/dtnd: error while loading shared libraries: libdb-5.2.so <http://libdb-5.2.so>: cannot open shared object file: No such file or directory
> help please, I searched the problem in the archive of the mailing list, I found the problem and I have not found the answer.
> Thank you for your Help.
> Ahmed
> Best Regards
>
>
> _______________________________________________
> dtn-users mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-users

---

From: ahmed elouadrhiri <[email-masked]>
Date: Sat, 16 Jun 2012 19:10:12 +0000

thans a lot Darren;
but the problem remains

2012/6/16 Darren Long <[email-masked]>

> daemon/dtnd: error while loading shared libraries: libdb-5.2.so: cannot open shared object file: No such file or directory
>
> dtn-users mailing [email-masked]://www.irtf.org/mailman/listinfo/dtn-users
>
>
>

---

From: Alex McMahon <[email-masked]>
Date: Mon, 18 Jun 2012 12:00:26 +0100

Hi Ahmed, 

Can you confirm the development Berkeley Database Libraries for 5.2
present on your system ? 

Thanks

Alex