Subject: [dtn-users] Extended Class of Service (ECOS) Block

From: "Zoller, David A. (MSFC-EO60)[HOSC SERVICES CONTRACT]" <[email-masked]>
Date: Fri, 20 Jul 2012 07:53:55 -0500

A "heads up" In reference to the patches I uploaded yesterday:

·         dtn2_patch2_aggregate_custody_signals.patch

o   Implements the ground work for the Extended Class of Service block

§  This is a partial implementation that adds the ECOS block to outgoing custody signals and processes the most likely used features on incoming blocks but does not do anything with it.

One of our goals is to fit seamlessly into an ION implementation dominated (for now :)) architecture. ION sets the priority on Custody Signals and Aggregate Custody Signals to EXPEDITED while DTN2 uses NORMAL for Custody Signals. In our in-house version, I bumped the priority of the [A]CSs to EXPEDITED and added the ECOS block in order to conform with our environment. The bump to EXPEDITED was not included in the patch but the ECOS block which is only applicable to EXPEDITED bundles will be added if configured using --with-ecos.

Suggestion to the initiators of the ECOS block if they are out there:
It might be useful to default non-ECOS expedited bundles to a non-zero value (20?) to add the flexibility to specify a priority that is above or below them.

Regards,
DZ

David Zoller
COLSA Corporation
Marshall Space Flight Center

---

From: "Zoller, David A. (MSFC-EO60)[HOSC SERVICES CONTRACT]" <[email-masked]>
Date: Fri, 20 Jul 2012 10:00:45 -0500

My apologies to all,
My intention was not to imply that there are plans by MSFC to replace ION implementations with DTN2 or that there are any deficiencies in the ION implementation. I do not in any way speak for MSFC or have any influence on its policies. DTN2 is currently dearer to me as I have been working with it lately striving to bring its performance up to par with the ION implementation and I was just poking some poorly conceived fun. I apologize and I promise that it won't happen again.
Sincerely,
DZ

David Zoller
COLSA Corporation

From: [email-masked] [mailto:[email-masked]] On Behalf Of Zoller, David A. (MSFC-EO60)[HOSC SERVICES CONTRACT]
Sent: Friday, July 20, 2012 7:54 AM
To: [email-masked]
Subject: [dtn-users] Extended Class of Service (ECOS) Block

Regards,
DZ

David Zoller
COLSA Corporation