Subject: [dtn-users] 1 Hour Data Flow Test Results - DTN2.8.0 Changeset 3550 plus BundleList and Experimental TBRouter patches

From: "Zoller, David A. (MSFC-EO60)[HOSC SERVICES CONTRACT]" <[email-masked]>
Date: Thu, 19 Jul 2012 16:38:13 -0500

Greetings all one more time,
I am providing some performance test results focused mainly on ingest to go along with the patches I recently uploaded.
This run is using the DTN2 code with all of the patches including the ExperimentalTBRouter patch which improves the performance when there are a lot of bundles pending and a link opens.

I hope to see more improvements with the next set of patches that I am working on.
Best regards,
DZ

DTN2 - One Hour Data Flow with the Receiver (Node2) Brought Online After 30 Minutes

Test 1 - the latest code available on Sourceforge

*         DTN2 changeset 3550 plus patches up to and including the BundleList patch plus some statistics collection code.

*         OASYS changeset 2298 with all patches applied.

*         Data flow is 160 non-custody bundles per second for 60 minutes

*         576,000 UDP packets were transmitted (1316 byte payload)

*         576,000 packets were processed into bundles  (1316 byte payload)

*         0 packets were lost due to UDP socket buffer overflow

o   40MB socket buffer holds ~30k packets or ~187 seconds of data

Timeline Highlights
Seconds after Node1 started

85

Data flow started at 40 packets/sec

85-1912

Successfully received 292,603 bundles at 160 bundles/sec

1912

Node2 makes contact (link-0 created) - reroute_all_bundles entered - ingest halted for 8.7 seconds

1921

reroute_all_bundles finished

1926

bundle ingest rate was double catching up for the 8.7 second hit

1926 - 2356

Ingest at 160 bundle/sec while transmit to Node 2 averages 500 bundles/sec

2356 - 2376

Ingest pauses while 35,592 bundles transmitted and BundleTransmit events processed in 20 seconds (avg 1,780 bundles/sec)

2436

Node1 establishes connection to Node2 - reroute_all_bundles complete in 3.7 seconds

2436 - 2636

Ingest at 1 bundle/sec while transmit to Node 2 averages 420 bundles/sec

2646 - 2746

Ingest catches up averaging 345 bundles/sec while transmit averages 341 bundles/sec

2746 - 3687

fairly steady 160 bundles/sec both ingest and transmit

3685

Data flow terminates

3687

Processing complete in 1 hour 32 minutes

David Zoller
COLSA Corporation
HOSC / M103
*Office: (256) 544-1820
*EMail: [email-masked]<mailto:[email-masked]>

---

From: "Zoller, David A. (MSFC-EO60)[HOSC SERVICES CONTRACT]" <[email-masked]>
Date: Fri, 20 Jul 2012 06:55:09 -0500

3687

Sorry, Cut and Paste bit me there - that should be Processing complete in 1 hour after data flow start.

David Zoller
COLSA Corporation
HOSC / M103
*Office: (256) 544-1820

From: [email-masked] [mailto:[email-masked]] On Behalf Of Zoller, David A. (MSFC-EO60)[HOSC SERVICES CONTRACT]
Sent: Thursday, July 19, 2012 4:38 PM
To: [email-masked]
Subject: [dtn-users] 1 Hour Data Flow Test Results - DTN2.8.0 Changeset 3550 plus BundleList and Experimental TBRouter patches

Timeline Highlights

85

85-1912

1912

1921

1926

1926 - 2356

2356 - 2376

2436

2436 - 2636

2646 - 2746

2746 - 3687

3685

Data flow terminates

3687

David Zoller
COLSA Corporation
HOSC / M103
*Office: (256) 544-1820