Subject: [dtn-users] DTN2 support for IPv6?

From: [email-masked]
Date: Wed, 8 Aug 2012 13:10:13 -0400

Hi All,

I was curious if there's support in DTN2 for IPv6? A quick search didn't
reveal anything, but I was curious if any work's been done on this.

Thanks,
Angela

Angela Hennessy
Laboratory for Telecommunications Sciences

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Wed, 8 Aug 2012 12:40:30 -0500

My recollection is DTN-2 and ION do not support IPv6.

IBR and Postellation may.  I am pretty sure they do.

- Will

On Aug 8, 2012, at 1:10 PM, <[email-masked]<mailto:[email-masked]>> wrote:

Hi All,

Thanks,
Angela

Angela Hennessy
Laboratory for Telecommunications Sciences
_______________________________________________
dtn-users mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/dtn-users

******************************
William D. Ivancic
Phone 216-433-3494
Fax 216-433-8705
Networking Lab 216-433-2620
Mobile 440-503-4892
http://roland.grc.nasa.gov/~ivancic

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 8 Aug 2012 16:19:53 -0400

> IBR and Postellation may.  I am pretty sure they do.

postulation does support IPv6. Marc.

> 
> - Will
> 
> On Aug 8, 2012, at 1:10 PM, <[email-masked]> wrote:
> 
>> Hi All,
>> 
>> [email-masked]
> [email-masked]

---

From: Elwyn Davies <[email-masked]>
Date: Thu, 09 Aug 2012 00:56:37 +0100

> My recollection is DTN-2 and ION do not support IPv6.  
DTN2 definitely does not support IPv6 at present.
It would be necessary to update the IP discovery mechanisms and the UDP
and TCP convergence layers to provide IPv6 support within the protocol
plus modifying the API and control port configuration to allow
application and control support over IPv6.  It ought to be done but its
quite a bit of work.

Regards,
Rlwyn

---

From: Johannes Morgenroth <[email-masked]>
Date: Thu, 09 Aug 2012 08:56:57 +0200

> IBR and Postellation may.  I am pretty sure they do.

You are right. IBR-DTN supports IPv6. :-)

Johannes

-- 
Johannes Morgenroth     Institut fuer Betriebssysteme und Rechnerverbund
Tel.: +49-531-391-3249                           Muehlenpfordtstrasse 23
Fax.: +49-531-391-5936      TU Braunschweig         D-38106 Braunschweig