Subject: [dtn-users] Bundle status report fragment offset and payload length

From: Michele Rodolfi <[email-masked]>
Date: Fri, 14 Sep 2012 06:07:20 +0200

Hi all,
I'm trying to get infos from the bundle status reports, and I noticed
that in the fields "frag_offset" and " orig_length" in the structure
bundle_id referred by the status report I get values that do not make
sense.
I send bundles with a 50kB payload and receive all the status delivered reports.
In the frag_offset there is always the value 1348824164 and in the
orig_length the value is variable but anyway too big.
I can't understand why i get this behaviour
Here there is a csv log of what i get:
https://www.dropbox.com/s/jr0x1zc4gkhw2om/400908171_portatile-debian.dtn.csv

Also I'm wondering if there is a way to read the Administrative Record
Flags of an administrative record defined in the RFC 5050 pag 37.
The flag I would like to read is the one that indicates that the
record is relative to a fragmented bundle.

I'm working with DTN2.9.0 on debian sid x86_64

With very kind regards
Michele

---

From: "Scott, Keith L." <[email-masked]>
Date: Mon, 17 Sep 2012 12:19:49 +0000

Are you saying that the APPLICATION got a bundle with frag_offset and orig_length fields set?  Applications should never receive bundle fragments, only complete bundles.
	
	--keith

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michele Rodolfi
Sent: Friday, September 14, 2012 12:07 AM
To: [email-masked]
Subject: [dtn-users] Bundle status report fragment offset and payload length

Hi all,

With very kind regards
Michele
_______________________________________________
dtn-users mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/dtn-users

---

From: <[email-masked]>
Date: Mon, 17 Sep 2012 14:00:01 +0100

If a bundle implementation only gets a single fragment, how does it prompt redelivery?

Lloyd Wood
http://sat-net.com/L.Wood/

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Scott, Keith L. [[email-masked]]
Sent: 17 September 2012 13:19
To: Michele Rodolfi; [email-masked]
Subject: Re: [dtn-users] Bundle status report fragment offset and payload length

        --keith

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michele Rodolfi
Sent: Friday, September 14, 2012 12:07 AM
To: [email-masked]
Subject: [dtn-users] Bundle status report fragment offset and payload length

Hi all,

With very kind regards
Michele

---

From: Michele Rodolfi <[email-masked]>
Date: Mon, 17 Sep 2012 15:14:49 +0200

> Are you saying that the APPLICATION got a bundle with frag_offset and orig_length fields set?  Applications should never receive bundle fragments, only complete bundles.

I'm saying that the application got a bundle STATUS REPORT which
payload refers to a bundle id (source, timestamp, frag_offset and
orig_length).
I noticed that the fields frag_offset and orig_length of the referred
bundle id are wrong only on 64bit architecture nodes.
On 32bit nodes, these fields are correctly set to 0.

Michele

---

From: "Burleigh, Scott C (313B)" <[email-masked]>
Date: Mon, 17 Sep 2012 15:03:50 +0000

In BP, a "fragment" (or "fragmentary bundle") is not a portion of a bundle but is rather a bundle whose payload is a portion of the payload of some antecedent bundle.  Since a fragment is a bundle, all the procedures that apply to bundles can be applied to it, including custodial retransmission.

The main difference between a fragment and a non-fragmentary bundle is that the payloads of fragmentary bundles are never delivered.  Fragments are accumulated at their destination endpoint until the union of their payloads equals the originally transmitted application data unit, at which point a single bundle with the fully reconstituted payload replaces the accumulated fragments and is delivered to the application.

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, September 17, 2012 6:00 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [dtn-users] Bundle status report fragment offset and payload length

Lloyd Wood

        --keith

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michele Rodolfi
Sent: Friday, September 14, 2012 12:07 AM
To: [email-masked]
Subject: [dtn-users] Bundle status report fragment offset and payload length

Hi all,
I'm trying to get infos from the bundle status reports, and I noticed that in the fields "frag_offset" and " orig_length" in the structure bundle_id referred by the status report I get values that do not make sense.
I send bundles with a 50kB payload and receive all the status delivered reports.
In the frag_offset there is always the value 1348824164 and in the orig_length the value is variable but anyway too big.
I can't understand why i get this behaviour Here there is a csv log of what i get:
https://www.dropbox.com/s/jr0x1zc4gkhw2om/400908171_portatile-debian.dtn.csv

Also I'm wondering if there is a way to read the Administrative Record Flags of an administrative record defined in the RFC 5050 pag 37.
The flag I would like to read is the one that indicates that the record is relative to a fragmented bundle.

With very kind regards
Michele

---

From: "Scott, Keith L." <[email-masked]>
Date: Mon, 17 Sep 2012 16:52:16 +0000

Ah, OK.  I think I've got a 64-bit machine I can use; I'll see if I get the same behavior.

		--keith

-----Original Message-----
From: Michele Rodolfi [mailto:[email-masked]] 
Sent: Monday, September 17, 2012 9:15 AM
To: Scott, Keith L.
Cc: [email-masked]
Subject: Re: [dtn-users] Bundle status report fragment offset and payload length

Michele

---

From: <[email-masked]>
Date: Mon, 17 Sep 2012 23:35:21 +0100

I see a problem with the assumption that fragments will simply accumulate until the tunnelled bundle can be assembled.

There's no way to say 'I've got two thirds of this bundle, but just need the other third to complete it'. Custody transfer isn't relevant here.

Lloyd Wood

________________________________________
From: Burleigh, Scott C (313B) [[email-masked]]
Sent: 17 September 2012 16:03
To: Wood L  Dr (Electronic Eng); [email-masked]; [email-masked]; [email-masked]
Subject: RE: [dtn-users] Bundle status report fragment offset and payload length

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, September 17, 2012 6:00 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [dtn-users] Bundle status report fragment offset and payload length

Lloyd Wood

        --keith

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michele Rodolfi
Sent: Friday, September 14, 2012 12:07 AM
To: [email-masked]
Subject: [dtn-users] Bundle status report fragment offset and payload length

Hi all,

With very kind regards
Michele

---

From: "Burleigh, Scott C (313B)" <[email-masked]>
Date: Mon, 17 Sep 2012 23:04:43 +0000

True, custody transfer doesn't prompt for retransmission.  A more direct answer to your original question would have been "it doesn't prompt redelivery; it waits until all the other fragments arrive, then delivers the reassembled payload.  If the rest of the fragments don't arrive prior to bundle expiration, the fragments that have arrived are destroyed.  Responsibility for ensuring the arrival of the missing fragments rests with the convergence-layer protocols, possibly backed up by custodial retransmission of the fragmentary bundles, individually, upon timeout prior to receipt of custody acceptance signal."

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, September 17, 2012 3:35 PM
To: Burleigh, Scott C (313B); [email-masked]; [email-masked]; [email-masked]
Subject: RE: [dtn-users] Bundle status report fragment offset and payload length

Lloyd Wood

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, September 17, 2012 6:00 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [dtn-users] Bundle status report fragment offset and payload length

Lloyd Wood

        --keith

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michele Rodolfi
Sent: Friday, September 14, 2012 12:07 AM
To: [email-masked]
Subject: [dtn-users] Bundle status report fragment offset and payload length

Hi all,

With very kind regards
Michele