Subject: [dtn-users] Help: How i can get local eid in ION's implementation ?

From: Anna d'Amico <[email-masked]>
Date: Thu, 11 Oct 2012 11:33:38 +0200

Hi all,
I'm using the ION's api to implement a part of dtnperf (a tool to 
evaluate perfromance on DTN continously connected networks); while I'm 
using bp_open(char * eid, BpSAP *ionsapPtr) I need the local eid; Is 
there an api or another method to get the local eid without insert it as 
a parameter of invocation, as in the bprecvfile or bpsendfile commands ?
Thank you for your attention and I apologize for my bad English.

-- 
/Anna d'Amico/

---

From: "Burleigh, Scott C (313B)" <[email-masked]>
Date: Thu, 11 Oct 2012 14:04:51 +0000

Hi, Anna.  You can use the ID of any of the endpoints that your node is registered in as the first argument to bp_open, so long as no other application has already got that endpoint open.  You could just make up whatever endpoint you want to use for dtnperf, and then be sure to use bpadmin to register your node in that endpoint.  Alternatively, you can get a list of all of the node's current singleton endpoints by using the "l endpoint" command to bpadmin.  But there's no single "local eid" in ION.

Scott

From: [email-masked] [mailto:[email-masked]] On Behalf Of Anna d'Amico
Sent: Thursday, October 11, 2012 2:34 AM
To: [email-masked]; [email-masked]
Subject: [dtn-users] Help: How i can get local eid in ION's implementation ?

Hi all,
I'm using the ION's api to implement a part of dtnperf (a tool to evaluate perfromance on DTN continously connected networks); while I'm using bp_open(char * eid, BpSAP *ionsapPtr) I need the local eid; Is there an api or another method to get the local eid without insert it as a parameter of invocation, as in the bprecvfile or bpsendfile commands ?
Thank you for your attention and I apologize for my bad English.
--
Anna d'Amico