Subject: Re: [dtn-users] DTN2 NORM convergence layer

From: Elwyn Davies <[email-masked]>
Date: Thu, 28 Mar 2013 16:49:30 +0000

Hi, Brian.

Did you make any progress with this?

In the meantime would it be OK to upload my snapshot of the NORM 1.4b4
code to the DTN2 Sourceforge site so that people can continue working
with NORM if they wish to?

Regards,
Elwyn

On Sat, 2013-01-12 at 18:40 -0500, Brian Adamson wrote:
> I'll talk to the guys who did the DTN binding.  There are some
> important fixes to pick up from the current code and I suspect the
> NORM API calls may need some minor tweaking
> 
> Sent from my iPhone
> 
> On Jan 12, 2013, at 5:38 PM, Elwyn Davies <[email-masked]> wrote:
> 
> > Hi, Brian.
> > 
> > Sergey Reskin and I have been trying to get the NORM convergence layer
> > working in DTN2.
> > 
> > I get the impression that the NORM code has moved along a bit since
> > there was much activity with NORM and DTN2 with the result that it
> > appears the latest daily snapshot compiles and links OK with DTN2 but
> > doesn't run.  Crashes when trying to send a bundle for transmission.
> > 
> > I took a snapshot of the version 1.4b4 code about 2 years ago - the
> > README.TXT is dated March 13 2009 and the TODO.TXT April 12 2010.  This
> > version appears to be nearly compabible with DTN2 - it runs after I
> > added case statements for NORM_TX_RATE_CHANGED to NORMReceiver.cc and
> > NORMSessionManager.cc event case statements.
> > 
> > Would it be possible to:
> > 1. Put a snapshot of the code that will work on the navy.mil downlaod
> > site.
> > 2. Let us know what has been changed and/or provide some patches that
> > will allow the most recent code to be used with DTN2.
> > 
> > Regards,
> > Elwyn Davies
> > Folly Consulting/ Trinity College Dublin
> > 
> >

---

From: Brian Adamson <[email-masked]>
Date: Thu, 28 Mar 2013 16:08:01 -0400

Hi Elwyn,

Can you send me that snapshot?  I could probably troll through the SVN history and possibly get to your "golden" version myself, but this would guarantee I had a good reference to look at the delta from the current code and see what the issue might be.  I suspect there were some NORM API changes I made where I didn't realize it would create a backwards compatibility issue (likely where a pointer is now passed instead of an "int" or something that slips through the compiler but causes a runtime issue).  Looking at the delta in "normApi.h" would let me quickly see where the DTN code may be passing NORM what is now a problematic parameter value.  

I had spoken briefly to Keith Scott about your issue but my follow through with his guys slipped by the wayside (my fault).  I am re-enaging them, too in parallel with this. Sorry for the slow response!

cheers,

Brian Adamson
[email-masked]