Subject: Re: [dtn-users] DTN2 and oasys tests

From: Jim Wright <[email-masked]>
Date: Mon, 4 Mar 2013 11:04:57 -0700

Thanks Elwyn. With that I was able to run the tests.

Jim

On Feb 27, 2013, at 4:18 PM, Elwyn Davies wrote:

> Hi, Jim.
> 
> Have you grabbed the test_utils component from the Sourceforge site?
> That has scripts for running multiple tests.
> 
> Alex McMahon (TCD) is the expert on the tests.  We run nightly
> compilation and test runs on the most up to date code on one of the
> machines at TCD.  I'll let him give you the low down on what does and
> does not work.
> 
> A small warning: The ODBC/SQLite persistent storage mechanism in 2.8.0
> is only marginally stable and it is conceivable that you may encounter
> problems with forwarding logs and opportunistic or manually configured
> (i.e. not setup by the config file) links after restarts because the
> link names may change after restarts leading to inconsistent forwarding
> logs. This was not handled correctly by changeset 3518. 
> 
> Also considerable work has been done on the LTP implementation since
> 2.8.0 to ensure that it interoperates with ION - Stephen Farrell can
> give you chapter and verse on this one.
> 
> Regards,
> Elwyn Davies 
> 
> On Wed, 2013-02-27 at 15:00 -0700, Jim Wright wrote:
>> I'm beginning to use DTN2. I am setting up a single DTN2 node to
>> emulate a configuration which will be in use with our experiments
>> onboard ISS. Our ground equipment and payloads run ION and will be
>> communicating through a NASA DTN2 node. Because of my focus on
>> interoperability testing, I am using DTN2 2.8.0 hg
>> revision 14ffb2a3aa16 and oasys 1.5.0 hg revision 2a143c1f5eea. I
>> realize this is not the most recent code, but it is what our partners
>> at NASA recommend using. We will be following their update schedule.
>> 
>> I need to run this with as few local modifications as possible. I have
>> created RPM spec files for DTN2 and oasys and that is working fine. I
>> have everything building and packaging well. I'd like to run the tests
>> included with both the oasys and DTN2 code to verify that all is
>> working. My concern is that while there are a number of tests present,
>> there appears to be no way to systematically run them. Is anyone
>> actually using these tests?
>> 
>> 
>> Here are some specifics:
>> 
>> 
>> * In oasys, running the tests by hand in the test directory, I find
>> that 4 of the tests
>> fail: berkeley-db-test, filesys-db-test, memory-store-test, stack-trace-test. Is this expected behavior, or should I be concerned that my setup has problems?
>> 
>> 
>> * In dtn2, running the tests by hand in the test/unit-test directory,
>> I find that 1 of the tests fails: prophet-bundle-core-test. Actually,
>> two tests failed using just the code from the mercurial pull, but one
>> of my patches appears to have fixed one of them.
>> 
>> 
>> * In dtn2, there are a great many tcl scripts intended to run tests. I
>> still can't figure out how to get any of them to execute. Help!?!
>> 
>> 
>> Thanks for any assistance. I've been following the DTN2 mailing lists
>> for nearly a year, and I haven't seen these tests discussed.
>> 
>> 
>> Jim Wright
>> BioServe Space Technologies
>> [email-masked]
>> 303-492-1579
>> 
>> 
>> _______________________________________________
>> dtn-users mailing list
>> [email-masked]
>> https://www.irtf.org/mailman/listinfo/dtn-users
>

---

From: Elwyn Davies <[email-masked]>
Date: Mon, 04 Mar 2013 18:55:41 +0000

Excellent news!

Any issues?

Regards,
Elwyn

---

From: Jim Wright <[email-masked]>
Date: Mon, 4 Mar 2013 14:09:10 -0700

As best I can tell, the source directories of DTN2, oasys and test_utils are intimately intertwined. They seem to compile and run tests only if they can poke into each other via paths similar to ../oasys/*. I'm close to the conclusion that the work of separating this out, or re-architecting our buildbot infrastructure to accommodate it, is more than we want to take on. Part of that is the knowledge that we are using an older version, so that any changes may be less likely to be accepted back into the source. Another part is that we just want a DTN2 node as a "black box" for testing, and our development work for our payload and ground equipment is on ION which will interoperate with this. And finally, the time set aside to get this up and working is relatively small.

Jim