Subject: [dtn-users] e-ink devices on DTN

From: Tom Sparks <[email-masked]>
Date: Fri, 1 Mar 2013 08:42:24 -0800 (PST)

I am wondering if anybody has looked at these e-ink devices (like the kindle) for use in/on a DTN?

---
tom_a_sparks "It's a nerdy thing I like to do"
Child of the Internet born 1983
Please use ISO approved file formats excluding Office Open XML - http://www.gnu.org/philosophy/no-word-attachments.html
Ubuntu wiki page https://wiki.ubuntu.com/tomsparks

---

From: "Pitts, Robert L. (MSFC-EO60)[HOSC SERVICES CONTRACT]" <[email-masked]>
Date: Fri, 1 Mar 2013 11:08:10 -0600

I don't think anyone at MSFC has but it is a good idea since they are extremely low power devices.

Lee

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tom Sparks
Sent: Friday, March 01, 2013 10:42 AM
To: [email-masked]
Subject: [dtn-users] e-ink devices on DTN

 
---
tom_a_sparks "It's a nerdy thing I like to do"
Child of the Internet born 1983
Please use ISO approved file formats excluding Office Open XML - http://www.gnu.org/philosophy/no-word-attachments.html
Ubuntu wiki page https://wiki.ubuntu.com/tomsparks _______________________________________________
dtn-users mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/dtn-users

---

From: Lana Black <[email-masked]>
Date: Sat, 2 Mar 2013 00:49:38 +0000

> I am wondering if anybody has looked at these e-ink devices (like the kindle) for use in/on a DTN?

Just like any other mobile node, it could be used as a data mule. Of
course, it imposes certain requirements on the device in question, but I
think any device capable of running linux should be able to serve as a
dtn node.

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Fri, 1 Mar 2013 22:11:42 -0600

My wife works at a library and deals with numerous e-ink devices.  I believe
the applications are pretty interactive for security reasons - security here
being data-rights management.  It is not just file transfers.

The application has to be written to handle disconnection unless you are
fully connected in which case you don't need DTN.

Will

> From: Lana Black <[email-masked]>
> Date: Fri, 1 Mar 2013 18:49:38 -0600
> To: Tom Sparks <[email-masked]>
> Cc: dtn-users maillist <[email-masked]>
> Subject: Re: [dtn-users] e-ink devices on DTN
> 
> _______________________________________________
> dtn-users mailing list
> [email-masked]

---

From: Tom Sparks <[email-masked]>
Date: Sat, 2 Mar 2013 08:03:41 -0800 (PST)

----- Original Message -----
> From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
> To: Lana Black <[email-masked]>; Tom Sparks <[email-masked]>
> Sent: Saturday, 2 March 2013 3:11 PM
for email:
mutt[1] could be used with maildir[2]
see Configuring Mutt from [3]

For Web access:
a lot of the current system like TEK[4], freenet[5] use proxy servers witch are too memory hungry for e-ink devices

the offline browsing[6] method makes sense,
but when a url has not been mirrored the browser trys to connect to the internet and fails
I have not seen a TEK, Freenet interface that is not proxy server based

[1] http://en.wikipedia.org/wiki/Mutt_%28e-mail_client%29
[2] http://en.wikipedia.org/wiki/Maildir
[3] http://dannf.org/docs/offlinemail.html
[4] http://tek.sourceforge.net/index.shtml
[5] http://en.wikipedia.org/wiki/Freenet

[6] http://en.wikipedia.org/wiki/Offline_reader