Subject: [dtn-users] ion-3.2.1 compile error on FreeBSD 10.0

From: "Yang, Yueli" <[email-masked]>
Date: Sun, 27 Jul 2014 06:09:38 +0000

Hi, I am having trouble to compile ion-3.2.1 on FreeBSD 10.

After fixing a few errors of "unsigned enum/int <0 is always false" and "use of undeclared identifier O_LARGEFILE",  make command still fails with:

Make[2]: don't know how to make ./ici/doc/ionadmin.1. Stop
Make[2]: stopped in /root/ion-open-source
*** Error code 1

Running make in ./ici/doc/ failed with:

Make: exec(./man/man1/ionadmin.1) failed (No such file or directory)
*** Error code 1

I revised the ./ici/doc/Makefile to generate " ./html/man*/*html" and "./man/man*/*.x" files, make still failed with

Cannot find "lyst_insert" in podpath: cannot find suitable replacement path, cannot resolve link
Make: exec(./man/man1/ionadmin.1) failed (Permission denied)
*** Error code 1

Any help or tip on compile/build/install ion-3.2.1 on FreeBSD 10.0 will be greatly appreciated.
Regards,
Yueli Yang
Boeing Research & Technology
Seattle DC 9-08.4, 4D13-1.2, MC: 4C-78
Phone: 425-373-7132, FAX: 206-544-6757

---

From: "Burleigh, Scott C (312G)" <[email-masked]>
Date: Sun, 27 Jul 2014 18:01:01 +0000

Hi, Yueli.  I'm really sorry, we never had a lot of takers for the FreeBSD port of ION so we got out of the habit of regression-testing it on every release; by now the low-level Makefiles are all way out of date, and at the moment we've got no FreeBSD machine to debug on.

I unfortunately am going to be away from my development machines for almost three weeks starting tomorrow, so I can't be much help until mid-August.  In the meantime, if anybody else can help Yueli with updating the FreeBSD port, please feel free - and , if possible, please keep track of the changes you made so we can fold them back into the next release.

Scott

From: dtn-users [mailto:[email-masked]] On Behalf Of Yang, Yueli
Sent: Saturday, July 26, 2014 11:10 PM
To: [email-masked]
Cc: [email-masked]
Subject: [dtn-users] ion-3.2.1 compile error on FreeBSD 10.0

---

From: "Burleigh, Scott C (312G)" <[email-masked]>
Date: Mon, 28 Jul 2014 14:56:56 +0000

Sending this again, as it seems to have gotten stuck in JPL's mail system yesterday.

Scott

From: dtn-users [mailto:[email-masked]] On Behalf Of Burleigh, Scott C (312G)
Sent: Sunday, July 27, 2014 11:01 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [dtn-users] ion-3.2.1 compile error on FreeBSD 10.0

Scott

From: dtn-users [mailto:[email-masked]] On Behalf Of Yang, Yueli
Sent: Saturday, July 26, 2014 11:10 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [dtn-users] ion-3.2.1 compile error on FreeBSD 10.0

---

From: "Yang, Yueli" <[email-masked]>
Date: Wed, 30 Jul 2014 09:19:14 +0000

Thank you very much, Scott.

By switching to gmake, I am able to get ion-3.2.1 build on FreeBSD 10.0 after fixing the following errors.

*         unsigned enum in file in file bp/cgr/libcgr.c  by removing "traceType  <  0  ||"  in line 1817 and "reason  <  0  ||"  in line 1856

*         undeclared identifier errors in file bss/library/libbssP.c line 1129:43 and 1228:36 by adding "#define O_LARGEFILE 0" to line 20

*         unsigned int in file nm/shared/adm/adm.c:970:10 error by adding (int) in front of len

*         unsigned int in file nm/shared/utils/utils.c:692:23 error by adding (int) in front of (size-result_len)

Regards,
    Yueli
From: dtn-users [mailto:[email-masked]] On Behalf Of Burleigh, Scott C (312G)
Sent: Monday, July 28, 2014 7:57 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [dtn-users] ion-3.2.1 compile error on FreeBSD 10.0

Scott

Scott

---

From: "Burleigh, Scott C (312G)" <[email-masked]>
Date: Wed, 30 Jul 2014 13:17:00 +0000

Great!  Thanks, Yueli.  As it happens, I have just located a machine I can configure for FreeBSD debugging.  I may have time to do that tomorrow morning, confirm your fixes, and post them as a feature branch for the ION 3.2.2 release, targeted for the end of September; with any luck, we won't have to go through this again.

Scott
________________________________
From: Yang, Yueli [[email-masked]]
Sent: Wednesday, July 30, 2014 2:19 AM
To: Burleigh, Scott C (312G); [email-masked]
Subject: RE: ion-3.2.1 compile error on FreeBSD 10.0

·         unsigned enum in file in file bp/cgr/libcgr.c  by removing “traceType  <  0  ||”  in line 1817 and “reason  <  0  ||”  in line 1856

·         undeclared identifier errors in file bss/library/libbssP.c line 1129:43 and 1228:36 by adding “#define O_LARGEFILE 0” to line 20

·         unsigned int in file nm/shared/adm/adm.c:970:10 error by adding (int) in front of len

·         unsigned int in file nm/shared/utils/utils.c:692:23 error by adding (int) in front of (size-result_len)

Regards,
    Yueli

Sending this again, as it seems to have gotten stuck in JPL’s mail system yesterday.

Scott

Hi, Yueli.  I’m really sorry, we never had a lot of takers for the FreeBSD port of ION so we got out of the habit of regression-testing it on every release; by now the low-level Makefiles are all way out of date, and at the moment we’ve got no FreeBSD machine to debug on.

I unfortunately am going to be away from my development machines for almost three weeks starting tomorrow, so I can’t be much help until mid-August.  In the meantime, if anybody else can help Yueli with updating the FreeBSD port, please feel free – and , if possible, please keep track of the changes you made so we can fold them back into the next release.

Scott

After fixing a few errors of “unsigned enum/int <0 is always false” and “use of undeclared identifier O_LARGEFILE”,  make command still fails with:

Make[2]: don’t know how to make ./ici/doc/ionadmin.1. Stop
Make[2]: stopped in /root/ion-open-source
*** Error code 1

I revised the ./ici/doc/Makefile to generate “ ./html/man*/*html” and “./man/man*/*.x” files, make still failed with

Cannot find “lyst_insert” in podpath: cannot find suitable replacement path, cannot resolve link
Make: exec(./man/man1/ionadmin.1) failed (Permission denied)
*** Error code 1