Subject: [dtn-users] Fail to send from ION 3.2.1 on FBSD 10.0 to DTN2 2.9.1 on Ubuntu 14.04

From: "Yang, Yueli" <[email-masked]>
Date: Fri, 8 Aug 2014 21:38:07 +0000

Hi,

I failed to send DTN bundles using "bpsource". Here are the error messages from ion.log. Wireshark capture from the source node network interface is also included.

...
[2014/08/08-00:15:39] at line 552 of bp/tcp/libtcpcla.c, TCPCL read() error on socket: Connection reset by peer
[2014/08/08-00:15:39] at line 712 of bp/tcp/libtcpcla.c, Couldn't receive segment header.
[2014/08/08-00:15:39] at line 203 of bp/tcp/tcpclo.c, Can't acquire bundle.
...

FYI,

ION 3.2.1 was built and running on FreeBSD 10.0 DTN node 10.0.3.2
DTN2 2.9 was build and running on Ubuntu 14.04 DTN node 10.0.0.10

Can anyone help to explain the cause of the errors? Thank you!

Yueli Yang
Boeing Research & Technology
Seattle DC 9-08.4, 4D13-1.2, MC: 4C-78
Phone - 425-373-7132, FAX: 206-544-6757

---

From: "Burleigh, Scott C (312G)" <[email-masked]>
Date: Sat, 9 Aug 2014 08:50:01 +0000

Yueli, have you run any of the ION regression tests to make sure TCPCLA is working properly in FreeBSD?  If you have, and it is, then I'd say there's something wrong with the TCP connectivity between the FreeBSD and Ubuntu nodes: tcpcli terminated because it got a TCP error on its attempt to read from a socket.  Make sure iptables is configured on both machines to let traffic pass, but I don't think that's the problem.

Scott
________________________________
From: dtn-users [[email-masked]] on behalf of Yang, Yueli [[email-masked]]
Sent: Friday, August 08, 2014 2:38 PM
To: [email-masked]
Subject: [dtn-users] Fail to send from ION 3.2.1 on FBSD 10.0 to DTN2 2.9.1 on Ubuntu 14.04

Hi,

I failed to send DTN bundles using “bpsource”. Here are the error messages from ion.log. Wireshark capture from the source node network interface is also included.

…
…

FYI,

Yueli Yang