Subject: [dtn-users] DTN2 & CFDP

From: Murugadoss <[email-masked]>
Date: Wed, 15 Oct 2014 12:49:07 +0900 (GMT)

Hello,
Does DTN2 have support for CFDP ? 
Similar to ION, do DTN2 also have built-in support for CFDP or is it possible to build as module in DTN2 
Can anyone please give few inputs on it. 
 
Thank you
 
Thanks &amp; Regards 
Murugadoss

Thanks &amp; Regards
Murugadoss

---

From: Elwyn Davies <[email-masked]>
Date: Wed, 15 Oct 2014 11:51:00 +0100

Hi.

I am not an expert on the space protocols such as CFDP, but assuming 
things are not vastly different from what Scott Burleigh wrote back in 
2003 [1], it appears that CFDP is implemented as an overlay on top of 
the BP, and doesn't really need to significantly interact with the 
innards of the BPA.

Accordingly, although there isn't any CFDP support in DTN2, it would 
probably be relatively trivial to
use DTN2 instead of ION to provide the BP underlay.  So you could 
probably use the ION CFDP code with some minor surgery to interface with 
DTN2.

Please let us know if this strategy works -  and we can incorporate the 
mechanism into DTN2.

Regards,
Elwyn

[1] http://sunset.usc.edu/GSAW/gsaw2003/s3/burleigh.pdf

On 15/10/14 04:49, Murugadoss wrote:
> Thanks & Regards
> Thanks & Regards
> _______________________________________________
> dtn-users mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-users

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Wed, 15 Oct 2014 14:27:26 +0000

Thanks, Elwyn, that's exactly right.  The ION implementation of CFDP has got an API for writing "unitdata transmission" ("UT-layer") underlay adapters.  The UT adapter that ships with ION is in the cfdp/bp directory and is named bputa.c; it invokes the ION BP API.  To run ION CFDP over DTN2, all you should need to do is clone bputa.c and adapt it to invoke the DTN2 API.

Scott

From: dtn-users [mailto:[email-masked]] On Behalf Of Elwyn Davies
Sent: Wednesday, October 15, 2014 3:51 AM
To: Murugadoss; [email-masked]
Subject: Re: [dtn-users] DTN2 & CFDP

Hi.

I am not an expert on the space protocols such as CFDP, but assuming things are not vastly different from what Scott Burleigh wrote back in 2003 [1], it appears that CFDP is implemented as an overlay on top of the BP, and doesn't really need to significantly interact with the innards of the BPA.

Accordingly, although there isn't any CFDP support in DTN2, it would probably be relatively trivial to
use DTN2 instead of ION to provide the BP underlay.  So you could probably use the ION CFDP code with some minor surgery to interface with DTN2.

Please let us know if this strategy works -  and we can incorporate the mechanism into DTN2.

Regards,
Elwyn

Hello,

Thank you

Thanks & Regards

Murugadoss

Thanks & Regards
Murugadoss

[http://mail.hanyang.ac.kr:80/historySent.ds?act=confirm&sender=bXVydWdhZG9zc0BoYW55YW5nLmFjLmty&receiver=ZHRuLXVzZXJzQGlydGYub3Jn&subject=RFROMiAmIENGRFA%3d&msgid=NjA3MDI3MDMyOTY2MTQ1NzcwMg%3d%3d]

dtn-users mailing list

[email-masked]<mailto:[email-masked]>