Subject: [dtn-users] regarding DTNSIM2

From: Somreeta Pramanik <[email-masked]>
Date: Tue, 26 May 2015 11:22:10 +0530 (IST)

Hello all,
Can anyone please provide me the DTNSIM2 simulator. I can't download it from the site http://watwire.uwaterloo.ca/DTN/sim/

---

From: Aggelis Aggelis <[email-masked]>
Date: Tue, 26 May 2015 10:35:11 +0300

hello somreeta
This reply is not related to your question but to a previous post that you
asked n this list related to dtn-ion interoperability:

in a post that you send to dtn-users about interoperability isues between
ion and dtn2
you said that you had a problem where

somreeta dtn% [1411747528.640888 /dtn/bundle/protocol error] error parsing
previous hop eid 'dtn://somreetadtn.dtn

[1411747528.640911 /dtn/bundle/protocol error] consume: protocol error
handling block 0x5
[1411747528.640922 /dtn/cl/tcp/conn/0x7f7268000940 error] protocol error
parsing bundle data segment

and at the reply from  Yang, Yueli
it had attached two configuration files where they tested dtn 2.9.0 and ion
3.21
with success.
----------------

Hi Somreeta:

We recently successfully validated ION-DTN interoperability with the
attached configuration files.

We have two hosts, both running ubuntu 14.04:

“tango” running ION-3.2.1 with the attached tangoion.rc file.

“ballet” running DTN-2.9.0 with the attached balletdtn2.conf file.

Hope this helps your debug of sending from ION node to DTN2 node.

Yueli Yang
-----------------

in our tests we had success with ion dtn interoperability with only with
ion version
3.0.1

Did you have success with the conf files that Yeli sent you?
Also since in the mailing list archives i cannot find yelis configuration
files
could you please send me those files ?

Thanks and regards

On Tue, May 26, 2015 at 8:52 AM, Somreeta Pramanik <
[email-masked]> wrote:

> Hello all,
> Can anyone please provide me the DTNSIM2 simulator. I can't download it
> from the site http://watwire.uwaterloo.ca/DTN/sim/
>
> _______________________________________________
> dtn-users mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-users
>

---

From: "Zoller, David A. (MSFC-EO50)[HOSC SERVICES CONTRACT]" <[email-masked]>
Date: Tue, 26 May 2015 17:43:46 +0000

Hi Somreeta and Aggelis,
In  <dtn2>/servlib/bundling/BundleProtocol.cc, you can comment out line 100:
    //BundleProtocl::register_processor(new PreviousHopBlockProcessor());

This will disable processing the Previous Hop Insertion Block so that you will be back in business. Neither of those implementations conform to the specification and they are not 100% compatible with each other – one includes a trailing null character after an EID string and the other does not. The specification says that the EID should be broken into a null-terminated Scheme name and a null-terminated SSP similar to the Primary Header dictionary. I believe ION 3.3 has been updated to the specification format which will be more incompatible with the current DTN2.9 implementation.
Regards,
DZ

From: dtn-users [mailto:[email-masked]] On Behalf Of Aggelis Aggelis
Sent: Tuesday, May 26, 2015 2:35 AM
To: Somreeta Pramanik
Cc: [email-masked]
Subject: Re: [dtn-users] regarding DTNSIM2

hello somreeta
This reply is not related to your question but to a previous post that you asked n this list related to dtn-ion interoperability:

in a post that you send to dtn-users about interoperability isues between ion and dtn2
you said that you had a problem where

somreeta dtn% [1411747528.640888 /dtn/bundle/protocol error] error parsing previous hop eid 'dtn://somreetadtn.dtn

[1411747528.640911 /dtn/bundle/protocol error] consume: protocol error handling block 0x5
[1411747528.640922 /dtn/cl/tcp/conn/0x7f7268000940 error] protocol error parsing bundle data segment
and at the reply from  Yang, Yueli
it had attached two configuration files where they tested dtn 2.9.0 and ion 3.21
with success.
----------------
Hi Somreeta:

We recently successfully validated ION-DTN interoperability with the attached configuration files.

Yueli Yang
-----------------
in our tests we had success with ion dtn interoperability with only with ion version
3.0.1
Did you have success with the conf files that Yeli sent you?
Also since in the mailing list archives i cannot find yelis configuration files
could you please send me those files ?
Thanks and regards

On Tue, May 26, 2015 at 8:52 AM, Somreeta Pramanik <[email-masked]<mailto:[email-masked]>> wrote:
Hello all,
Can anyone please provide me the DTNSIM2 simulator. I can't download it from the site http://watwire.uwaterloo.ca/DTN/sim/

_______________________________________________
dtn-users mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/dtn-users

---

From: Aggelis Aggelis <[email-masked]>
Date: Wed, 27 May 2015 13:33:40 +0300

Thank you very much David
i also found another thread in ion-users list from Somreeta

http://korgano.eecs.ohiou.edu/pipermail/ion-users/2014-October/000398.html

here is a quote from the above thread.

"It looks like the DTN2 node is unable to parse the Previous Hop
extension block inserted by ION, because it can't parse the dtn-scheme
node ID for that node (apparently 'dtn://somreetadtn.dtn'); it then
apparently closes the connection, which causes ION to fail on reading
from the DTN2 node.
ION automatically computes an administrative EID for the dtn scheme
based on the hostname, which in this case seems to be somreetadtn, and
that's the EID that it uses in the Previous Hop block.  If the
structure of that EID is incorrect then we should fix it in ION, but
it looks compliant to me.  Matthew's suggestion to explicitly add that
endpoint in the ION config is a good one.
If worse comes to worst, you can always just disable the Previous Hop
extension block at the ION end; all you do is '#ifdef 0' the phn
member of the extensions[] array in bp/ext/bpextensions.c and rebuild.
Scott"

Regards

   Aggelis Aggelis

On Tue, May 26, 2015 at 8:43 PM, Zoller, David A. (MSFC-EO50)[HOSC SERVICES
CONTRACT] <[email-masked]> wrote:

> This will disable processing the Previous Hop Insertion Block so that you
> will be back in business. Neither of those implementations conform to the
> specification and they are not 100% compatible with each other – one
> includes a trailing null character after an EID string and the other does
> not. The specification says that the EID should be broken into a
> null-terminated Scheme name and a null-terminated SSP similar to the
> Primary Header dictionary. I believe ION 3.3 has been updated to the
> specification format which will be more incompatible with the current
> DTN2.9 implementation.
>
> Regards,
>
> DZ
>
>
>
> *From:* dtn-users [mailto:[email-masked]] *On Behalf Of *Aggelis
> Aggelis
> *Sent:* Tuesday, May 26, 2015 2:35 AM
> *To:* Somreeta Pramanik
> *Cc:* [email-masked]
> *Subject:* Re: [dtn-users] regarding DTNSIM2
>
>
>
> hello somreeta
>

---

From: Aggelis Aggelis <[email-masked]>
Date: Wed, 27 May 2015 13:43:19 +0300

i also forgot to mention that i tried putting the EID in the ion
configuration
eg
# Alert ION which endpoints are on this host
a endpoint dtn://ionbox.dtn q  <------ THIS LINE WAS ADDED
a endpoint dtn://ionbox.dtn/sink q
a endpoint dtn://ionbox.dtn/ping q
a endpoint dtn://ionbox.dtn/a q

but it didnt work so i disabled in
ion-open-source/bp/library/ext/bpextensions.c

the phn member of the extensions[] array

---------------------PART FROM bpextensions.c-------

static ExtensionDef     extensionDefs[] =
                        {
#if 0 <-------------ADDED
                { "phn", EXTENSION_TYPE_PHN,
                                phn_offer,
                                {phn_processOnFwd,
                                phn_processOnAccept,
                                phn_processOnEnqueue,
                                phn_processOnDequeue,
                                0},
                                phn_release,
                                phn_copy,
                                0,
                                0,
                                phn_parse,
                                phn_check,
                                phn_record,
                                phn_clear
                },
#endif <---------------ADDED
#if 0
                { "snid", EXTENSION_TYPE_SNID,
                                snid_offer,
                                {snid_processOnFwd,
                                snid_processOnAccept,
                                snid_processOnEnqueue,

.
.
.
.
----------------------------------------------------------

then recompiled ion and now ion can send bundles to dtn router.
I will also try your solution and post the results.

Regards
   Aggelis Aggelis

On Wed, May 27, 2015 at 1:33 PM, Aggelis Aggelis <[email-masked]> wrote:

> "It looks like the DTN2 node is unable to parse the Previous Hop extension block inserted by ION, because it can't parse the dtn-scheme node ID for that node (apparently 'dtn://somreetadtn.dtn'); it then apparently closes the connection, which causes ION to fail on reading from the DTN2 node.
> ION automatically computes an administrative EID for the dtn scheme based on the hostname, which in this case seems to be somreetadtn, and that's the EID that it uses in the Previous Hop block.  If the structure of that EID is incorrect then we should fix it in ION, but it looks compliant to me.  Matthew's suggestion to explicitly add that endpoint in the ION config is a good one.
> If worse comes to worst, you can always just disable the Previous Hop extension block at the ION end; all you do is '#ifdef 0' the phn member of the extensions[] array in bp/ext/bpextensions.c and rebuild.
> Scott"
>
> Regards
>
>    Aggelis Aggelis
>
>
>
> On Tue, May 26, 2015 at 8:43 PM, Zoller, David A. (MSFC-EO50)[HOSC
> SERVICES CONTRACT] <[email-masked]> wrote:
>
>>  Hi Somreeta and Aggelis,
>>
>> This reply is not related to your question but to a previous post that
>> you asked n this list related to dtn-ion interoperability:
>>
>>
>> somreeta dtn% [1411747528.640888 /dtn/bundle/protocol error] error
>> parsing previous hop eid 'dtn://somreetadtn.dtn
>>