Subject: [dtn-users] Ping Failed when use ad-hoc mode

From: Ahmad Zainudin <[email-masked]>
Date: Wed, 2 Sep 2015 09:21:40 +0700

Dear all,
I am use DTN 2.9.0 and debian jessie operating system, I have install DTN2
and ping with another node (ip 192.168.50.1 and 192.168.50.2) use ad-hoc
mode successful. Ping from 192.168.50.2 to 192.168.50.1
root@dtn-2:/home/dtn-2# ping 192.168.50.1
PING 192.168.50.1 (192.168.50.1) 56(84) bytes of data.
64 bytes from 192.168.50.1: icmp_seq=1 ttl=64 time=3.71 ms
64 bytes from 192.168.50.1: icmp_seq=2 ttl=64 time=3.52 ms
64 bytes from 192.168.50.1: icmp_seq=3 ttl=64 time=20.6 ms
64 bytes from 192.168.50.1: icmp_seq=4 ttl=64 time=2.57 ms
64 bytes from 192.168.50.1: icmp_seq=5 ttl=64 time=1.49 ms
64 bytes from 192.168.50.1: icmp_seq=6 ttl=64 time=18.2 ms

and then I use static routing with configure in dtn.conf

on pc 192.168.50.1
route set type static
route local_eid "dtn://dtn-1.dtn"
interface add tcp0 tcp
interface add udp0 udp
link add link1 192.168.50.2 ONDEMAND tcp
route add dtn://dtn-2.dtn/* link1

on pc 192.168.50.2
route set type static
route local_eid "dtn://dtn-2.dtn"
interface add tcp0 tcp
interface add udp0 udp
link add link1 192.168.50.1 ONDEMAND tcp
route add dtn://dtn-1.dtn/* link1

I use command dtnping
ping localhost success
root@dtn-2:/usr/local/src/dtn-2.9.0/apps/dtnping# dtnping localhost
source_eid [dtn://dtn-2.dtn/ping.2181]
dtn_register succeeded, regid 36
PING [dtn://dtn-2.dtn/ping] (expiration 30)...
20 bytes from [dtn://dtn-2.dtn/ping]: 'dtnping!' seqno=0, time=230 ms
20 bytes from [dtn://dtn-2.dtn/ping]: 'dtnping!' seqno=1, time=285 ms
20 bytes from [dtn://dtn-2.dtn/ping]: 'dtnping!' seqno=2, time=263 ms
20 bytes from [dtn://dtn-2.dtn/ping]: 'dtnping!' seqno=3, time=263 ms
20 bytes from [dtn://dtn-2.dtn/ping]: 'dtnping!' seqno=4, time=275 ms

But use command dtnping to another node failed

root@dtn-2:/usr/local/src/dtn-2.9.0/apps/dtnping# dtnping -c 6
dtn://dtn-1.dtn/ping
source_eid [dtn://dtn-2.dtn/ping.2188]
dtn_register succeeded, regid 37
PING [dtn://dtn-1.dtn/ping] (expiration 30)...

log in daemon
root@dtn-2:/usr/local/src/dtn-2.9.0/daemon# dtnd -c dtn.conf
[1441185215.847809 /dtnd notice] random seed is 847792
[1441185215.848060 /dtnd notice] DTN daemon starting up... (pid 2174)
[1441185215.998328 /S10 notice] Lines marked "S10" are log lines added to
make parsing
[1441185215.998387 /S10 notice] the logs easier after extended tests. These
were added for
[1441185215.998410 /S10 notice] the summer 2010 N4C summer trial and are
mainly new lines
[1441185215.998442 /S10 notice] that allow tracing bundles across multiple
hops.
[1441185215.998459 /S10 notice] To extract these do the following...
[1441185215.998477 /S10 notice]      grep "S10 info" <dtnd-log-files> |
grep -v grep | awk '{print $4,$5}' | sort -n
[1441185215.999192 /dtn/bundle/daemon notice] loading bundles from data
store
dtn-2 dtn% [1441185385.969955 /dtn/contact/manager error]
ContactManager::new_opportunistic_link: failed to add new opportunistic
link link-0
[1441185390.973518 /dtn/contact/manager error]
ContactManager::new_opportunistic_link: failed to add new opportunistic
link link-0
[1441185395.979608 /dtn/contact/manager error]
ContactManager::new_opportunistic_link: failed to add new opportunistic
link link-0
[1441185400.991478 /dtn/contact/manager error]
ContactManager::new_opportunistic_link: failed to add new opportunistic
link link-0
[1441185405.998484 /dtn/contact/manager error]
ContactManager::new_opportunistic_link: failed to add new opportunistic
link link-0
[1441185411.002293 /dtn/contact/manager error]
ContactManager::new_opportunistic_link: failed to add new opportunistic
link link-0

What is the happen? What is the configure to solved this problem?
Thanks,
Zai

---

From: Ahmad Zainudin <[email-masked]>
Date: Wed, 2 Sep 2015 09:52:58 +0700

I use ad-hoc configure as follows ( /etc/network/interfaces)
auto wlan0
iface wlan0 inet static
    address 192.168.50.2
    netmask 255.255.255.0
    wireless-channel 1
    wireless-essid DTN-Network
    wireless-mode ad-hoc

On Wed, Sep 2, 2015 at 9:21 AM, Ahmad Zainudin <
[email-masked]> wrote:

> [1441185215.998387 /S10 notice] the logs easier after extended tests.
> These were added for

---

From: Carlo Caini <[email-masked]>
Date: Wed, 2 Sep 2015 13:36:51 +0000

Dear Ahmad,
        First, please do not flood the same request on all dtn related mailing list. I have received your message in 8 copies!
This said, it seem to me that you have a problem at the convergence layer. After having synchronized the clocks by means of NTP as suggested by Ivancic, substitute your ONDEMAND on node 1 with ALWAYSON (one word) and then temporarily remove (i.e. comment) the instructions "link" and "route" on node 2. Then restart your daemons on both nodes and check the logs before launching dtnping or any othe dtn application. Use the option "-t" in dtnd to clean the database (e.g. dtnd -d -o ./dtn.log -t).
The instruction alwayson tells the TCP CL to open a new TCP connection to the other node. In response a new link (link-0) and a new route to go back (via the brand new link-0) should be automatically added on node 2.
If you still have a message error on the logs this means that dtnping responsible for that.
Do you use DTN2.9 stable or DTN2 "bleeding edge"?
Yours,
   Carlo

________________________________________
Da: dtn-users [[email-masked]] per conto di Ahmad Zainudin [[email-masked]]
Inviato: mercoledì 2 settembre 2015 4.52
A: [email-masked]
Oggetto: Re: [dtn-users] Ping Failed when use ad-hoc mode

On Wed, Sep 2, 2015 at 9:21 AM, Ahmad Zainudin <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,
I am use DTN 2.9.0 and debian jessie operating system, I have install DTN2 and ping with another node (ip 192.168.50.1 and 192.168.50.2) use ad-hoc mode successful. Ping from 192.168.50.2 to 192.168.50.1
root@dtn-2:/home/dtn-2# ping 192.168.50.1
PING 192.168.50.1 (192.168.50.1) 56(84) bytes of data.
64 bytes from 192.168.50.1<http://192.168.50.1>: icmp_seq=1 ttl=64 time=3.71 ms
64 bytes from 192.168.50.1<http://192.168.50.1>: icmp_seq=2 ttl=64 time=3.52 msmatically
64 bytes from 192.168.50.1<http://192.168.50.1>: icmp_seq=3 ttl=64 time=20.6 ms
64 bytes from 192.168.50.1<http://192.168.50.1>: icmp_seq=4 ttl=64 time=2.57 ms
64 bytes from 192.168.50.1<http://192.168.50.1>: icmp_seq=5 ttl=64 time=1.49 ms
64 bytes from 192.168.50.1<http://192.168.50.1>: icmp_seq=6 ttl=64 time=18.2 ms

on pc 192.168.50.1
route set type static

on pc 192.168.50.2
route set type static

I use command dtnping
ping localhost success

root@dtn-2:/usr/local/src/dtn-2.9.0/apps/dtnping# dtnping -c 6 dtn://dtn-1.dtn/ping
source_eid [dtn://dtn-2.dtn/ping.2188]
dtn_register succeeded, regid 37
PING [dtn://dtn-1.dtn/ping] (expiration 30)...

log in daemon
root@dtn-2:/usr/local/src/dtn-2.9.0/daemon# dtnd -c dtn.conf
[1441185215.847809 /dtnd notice] random seed is 847792
[1441185215.848060 /dtnd notice] DTN daemon starting up... (pid 2174)
[1441185215.998328 /S10 notice] Lines marked "S10" are log lines added to make parsing
[1441185215.998387 /S10 notice] the logs easier after extended tests. These were added for
[1441185215.998410 /S10 notice] the summer 2010 N4C summer trial and are mainly new lines
[1441185215.998442 /S10 notice] that allow tracing bundles across multiple hops.
[1441185215.998459 /S10 notice] To extract these do the following...
[1441185215.998477 /S10 notice]      grep "S10 info" <dtnd-log-files> | grep -v grep | awk '{print $4,$5}' | sort -n
[1441185215.999192 /dtn/bundle/daemon notice] loading bundles from data store
dtn-2 dtn% [1441185385.969955 /dtn/contact/manager error] ContactManager::new_opportunistic_link: failed to add new opportunistic link link-0
[1441185390.973518 /dtn/contact/manager error] ContactManager::new_opportunistic_link: failed to add new opportunistic link link-0
[1441185395.979608 /dtn/contact/manager error] ContactManager::new_opportunistic_link: failed to add new opportunistic link link-0
[1441185400.991478 /dtn/contact/manager error] ContactManager::new_opportunistic_link: failed to add new opportunistic link link-0
[1441185405.998484 /dtn/contact/manager error] ContactManager::new_opportunistic_link: failed to add new opportunistic link link-0
[1441185411.002293 /dtn/contact/manager error] ContactManager::new_opportunistic_link: failed to add new opportunistic link link-0