Subject: [dtn] collective bundle sources and custodians

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Wed, 26 Aug 2015 17:50:07 +0000

It sounds like we're moving toward consensus on an approach to dealing with the SDNV/CBOR/JSON question, which maybe we can nail down somewhat at the WG interim meeting on Friday.  So, building on that apparent momentum, can we try to converge on another issue as well?

I think this one is more limited, and I think we got fairly far toward consensus at the end of the IETF93 meeting.  Do we agree that, while the destination and report-to of a bundle are endpoints (i.e., sets of zero or more nodes), the source and current custodian are simply nodes?

If not, we will need to come up with procedures by which a set of N bundle protocol nodes can collectively issue a bundle and/or collectively take custody of a bundle.  My own opinion here is that (a) none of the use cases we need to support require either of these capabilities and (b) the effort required to develop those procedures would be extensive, and I've got limited confidence that it would be successful.  If it were going to be undertaken at all, I would suggest that the work be done in the DTN Research Group rather than in this WG.

Scott

---

From: "Birrane, Edward J." <[email-masked]>
Date: Wed, 26 Aug 2015 18:52:46 +0000

I agree that source and current custodian should be nodes and *not* endpoints.

There might be interesting possibilities where a group accepts custody of a bundle, or the source of a bundle (for reporting and replying purposes) would be a group. However, those are clearly research items and there is nothing in having custodians and sources as nodes that would prevent someone from mimicking "group" behavior through some other mechanism at some other time. 

-Ed

---
Edward J. Birrane, III, Ph.D.
Embedded Applications Group Supervisor
Space Exploration Sector
Johns Hopkins Applied Physics Laboratory
(W) 443-778-7423 / (F) 443-228-3839

> -----Original Message-----
> From: dtn [mailto:[email-masked]] On Behalf Of Burleigh, Scott C
> (312B)
> Sent: Wednesday, August 26, 2015 1:50 PM
> To: [email-masked]
> Subject: [dtn] collective bundle sources and custodians
> 
> It sounds like we're moving toward consensus on an approach to dealing with
> the SDNV/CBOR/JSON question, which maybe we can nail down somewhat
> at the WG interim meeting on Friday.  So, building on that apparent
> momentum, can we try to converge on another issue as well?
> 
> I think this one is more limited, and I think we got fairly far toward consensus
> at the end of the IETF93 meeting.  Do we agree that, while the destination
> and report-to of a bundle are endpoints (i.e., sets of zero or more nodes),
> the source and current custodian are simply nodes?
> 
> If not, we will need to come up with procedures by which a set of N bundle
> protocol nodes can collectively issue a bundle and/or collectively take
> custody of a bundle.  My own opinion here is that (a) none of the use cases
> we need to support require either of these capabilities and (b) the effort
> required to develop those procedures would be extensive, and I've got
> limited confidence that it would be successful.  If it were going to be
> undertaken at all, I would suggest that the work be done in the DTN
> Research Group rather than in this WG.
> 
> Scott
> 
> _______________________________________________
> dtn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtn