Subject: [dtn] DTN-DNS?

From: "Templin, Fred L" <[email-masked]>
Date: Fri, 14 Aug 2015 18:18:36 +0000

Hi Scott,

Regarding the numeric node ID discussions, what would you think about
having a Delay-Tolerant Domain Name System that maps numeric node
IDs to dtn:// URIs (both forward and reverse mappings)?

Thanks - Fred
[email-masked]

---

From: <[email-masked]>
Date: Fri, 14 Aug 2015 18:56:59 +0000

Hey Fred,

>From my side, I would say that it would be a Good Thing (tm). 

I think that simple forward and reverse mapping is fairly easy, but the challenge is how to deal with one-to-many forward mapping. Any sort of failover/load-balancing via DNS would fall apart over any real distance. However, using a distributed table built on previously cached requests may work.

This may be a problem that should be discussed alongside regions.

Thanks,
Jeremy 
________________________________________
From: dtn [[email-masked]] on behalf of Templin, Fred L [[email-masked]]
Sent: Friday, August 14, 2015 8:18 PM
To: [email-masked]
Cc: Burleigh, Scott C (312B)
Subject: [dtn] DTN-DNS?

Hi Scott,

Thanks - Fred

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Fri, 14 Aug 2015 19:33:35 +0000

I agree, Jeremy; the "registration" infrastructure that I've been proposing as a way to implement a federation of contact-plan-encapsulating "regions" (analogous to autonomous systems) would also be a logical place to stash textual names, descriptions, etc. associated with numeric node IDs.  That could include alternative node IDs expressed in different URI schemes, such as dtn.  I think this can work okay even in a delay-fraught network, because none of this information is likely to be very dynamic: the query round-trip time is likely to be much shorter than the rate of update.

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, August 14, 2015 11:57 AM
To: [email-masked]; [email-masked]
Cc: Burleigh, Scott C (312B) <[email-masked]>
Subject: RE: DTN-DNS?

Hey Fred,

Thanks,
Jeremy

Hi Scott,

Regarding the numeric node ID discussions, what would you think about having a Delay-Tolerant Domain Name System that maps numeric node IDs to dtn:// URIs (both forward and reverse mappings)?

Thanks - Fred