Subject: [dtn] Review of draft-ietf-dtn-tcpclv4-00

From: Audric Schiltknecht <[email-masked]>
Date: Thu, 17 Nov 2016 09:56:08 -0500

Hi,

These are some comments and notes I have regarding draft-ietf-dtn-tcpclv4-00.

I welcome the changes made, especially the removal of SDNV values.

General questions

* Section 5.2.1: Should we specify a reason for when a SHUTDOWN message is sent when closing the
session because no message was received for at least 2x Keepalive Interval?

* What happen if a node ends the connection (SHUTDOWN) while not having ACK all DATA_SEGMENT? Does
the sending node "reset" and send the bundle from start again? Does it need to keep track of what
has ben sent and resume from there?

* Section 6.1 "Shutdown Message (SHUTDOWN)"

I'm not sure to clearly understand the last paragraph:

"
In particular, if the session
is to be closed (for whatever reason) while a node is in the process
of transmitting a bundle data segment, the receiving node is still
expecting segment data and might erroneously interpret the SHUTDOWN
message to be part of the data segment.
"

Unless I'm missing something (very probable, jet lag/tiredness starting to take their tolls), I do
not really see why the receiving node would confuse SHUTDOWN message with DATA_SEGMENT.

Nits and typos:

Section 1: "the revsided Bundle" -> "the revised Bundle"
Section 1: "convergence- layer" -> "convergence-layer"
Section 4.2: "Session Keepalve" -> "Session Keepalive"
Section 5: "including the mechanisms" -> "including the mechanism"
Section 5.2.1: "keepalive_interval" -> "Keepalive Interval" (be consistent with Contact message)
Section 5.2.2: "Message rejection: uknow" -> "Message rejection: unknown"
Section 5.3.1: "TLS handshake: identical fashon" -> "TLS handshake: identical fashion"

Section 5.3.2: Figure 6 does not use "C"/"S" prefixes mentioned in text/

Section 5.4.1: "a similar behaivior" -> "a similar behavior"
Section 5.4.2: "Bundle Length: legnth" -> "Bundle Length: length"
Section 5.4.5: "an optional mechanisms" -> "an optional mechanism"

Figure 11: extra space in Transfer ID line

Section 6.1: useless empty line between "To do so, the node sets the ’D’ bit in" and "the message
header flags"

Appendix A: "negotated" -> "negotiated"

Audric

---

From: Audric Schiltknecht <[email-masked]>
Date: Thu, 17 Nov 2016 21:25:46 -0500

Also, in section 5.4.3. Bundle Data Transmission (DATA_SEGMENT), I would re-introduce some text from
7242 to make it super clear that a segment data only contains data from a unique bundle:

"
Once a transmission of a bundle has commenced, the node MUST only
send segments containing sequential portions of that bundle until it
sends a segment with the ’E’ bit set.
"

to

"
Once a transmission of a bundle has commenced, the node MUST only
send segments containing sequential portions of that bundle until it
sends a segment with the ’E’ bit set. A single segment MUST NOT contain
data of more than a single bundle.
"

Audric

On 2016-11-17 09:56, Audric Schiltknecht wrote:
> _______________________________________________
> dtn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtn
>