Subject: Re: [dtn] ADM/YANG/CBOR

From: Brian Sipos <[email-masked]>
Date: Sun, 4 Dec 2016 15:07:05 +0000

Rick,

I read through these earlier, at your suggestion, and have been meaning to reply. I'm copying the WG mailing list so that others can take issue with my opinions. :)

I would definitely like to keep as much commonality as possible to avoid wheel-re-inventing, but I am just concerned about conflicting goals between CORE WG and DTN WG.

My short checklist for AMP commonality:

  *   Use YANG (the language syntax) for specifying ADMs: yes
  *   Use NETMOD typing and structure for specifying ADMs: no, I think that the AMP spells out why this is a different purpose than the traditional NETCONF uses. We can treat any behavioral overlap with NETCONF/NETMOD as coincidental and ignore it for AMP.
  *   Allow importing of NETCONF modules within ADMs: no, If you want NETMOD-like behavior you must copy-paste to a new AMP ADM module and reconcile the differences between NETMOD and ADM.
  *   Allow use of CORE SIDs with ADMs: no, I really dislike the use of flat numeric namespace in that CORE-SID spec and also the fact that the SIDs are specified outside of the YANG modules (though I understand the reasoning for it, SIDs are used as overlay data to avoid modifying pre-existing NETCONF modules). For AMP, the MID is a core feature and splitting it into non-YANG definition would be a mistake in my opinion.

I really do think that AMA/AMP is behaviorally and conceptually different enough that there would be too may conflicts-of-need with NETCONF/NETMOD users. The only purpose of using YANG for ADMs would be to avoid wheel-reinventing with respect to the parsed language syntax and module-import semantics. There would be zero overlap between NETMOD and AMP use of YANG. Unfortunately, there is liable to be some misunderstanding of this as the phrase "YANG" is often used to mean both the language syntax (which ADM would use) as well as the core types/structure (which ADM would mostly not use).

Do these points sound too disagreeable?

The nice thing of this is that because there is zero overlap in data models, there should be no reason for any other YANG / NETMOD users to complain (other than "why is this ADM YANG module not usable for NETCONF?", to which the response is "because nobody ever said you had to use YANG just for NETCONF").

________________________________
From: Rick Taylor <[email-masked]>
Sent: Wednesday, November 16, 2016 12:13:36 AM
To: [email-masked]; Brian Sipos
Subject: ADM/YANG/CBOR

Gents,

I have been reading through Brian's YANG-ADM draft, just looking at the
mappings etc. and I'm wondering if some of the newer work that is
coming out of the various NETMOD/NETCONF working groups can help here.

One draft that sprang out immediately is: https://tools.ietf.org/html/d
raft-ietf-core-sid-00 which is attempts to solve the ADM OID issue in a
general way.

I suggest a read when you both get a chance.

Cheers,

Rick

---

From: "Birrane, Edward J." <[email-masked]>
Date: Sun, 4 Dec 2016 16:24:36 +0000

Speaking for the moment only about SIDS, I completely agree. Rick and I prototyped a better hierarchical encoding of yang models - I should be getting a draft out in January.

-Ed

Sent with Good Work (www.blackberry.com)

From: Brian Sipos <[email-masked]<mailto:[email-masked]>>
Date: Sunday, Dec 04, 2016, 10:07 AM
To: Rick Taylor <[email-masked]<mailto:[email-masked]>>, Birrane, Edward J. <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked] <[email-masked]<mailto:[email-masked]>>
Subject: Re: ADM/YANG/CBOR

Rick,

Gents,

Cheers,

Rick