Subject: Re: [dtn] BPbis implementation at IETF Hackathon

From: Marco Kaulea <[email-masked]>
Date: Mon, 9 Apr 2018 16:04:45 +0200

Hi,
Sorry to warm up this old thread, but I would also be interested in a
copy of the
Python code. I was planing to build a Rust implementation, so this would
be useful to test against/compare. I might also be able to help with
the cleanup.

- Marco

On Thu, Mar 22, 2018 at 9:55 PM, Martin Pilka <[email-masked]> wrote:
> as Felix said, we are planning to release code, however if you do not feel
> like waiting I can make it available for you immediately, just note that:
>
> 1) About 1/3 of the code was created on Hackaton and needs some cleaning,
> although it is not too bad
> 2) This is partial BP implementation, contains bundle encoding/decoding and
> IPND (which works but was not really used in final Docker setup)
>
> If you are still interested, Felix can give you tomorrow *.tar.gz containing
> all the code.

---

From: Lloyd Wood <[email-masked]>
Date: Thu, 12 Apr 2018 02:24:29 +0000 (UTC)

To put that comparison in context, work on the Bundle Protocol started in 1997.

(I see the DTNRG webpage archive has been disabled by google for violating its terms
of service. Someone tell Vint...
https://sites.google.com/site/dtnresgroup/home/)

Lloyd Wood
http://sat-net.com/L.Wood/dtn/

________________________________
From: Rick Taylor <[email-masked]>
To: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]> 
Sent: Friday, 23 March 2018, 20:20
Subject: Re: [dtn] BPbis implementation at IETF Hackathon

I must admit that I am very proud that, unlike some WGs, we seem to
have rough consensus *and* running code for BPbis.

Well done guys, and thank you.

Rick

On Fri, 2018-03-23 at 08:10 +0000, Burleigh, Scott C (312B) wrote:
> Thanks, Brian -- the BPbis draft has some RFC 7942 material in
> section 8, discussing the uPCN implementation, and I certainly agree
> that notes on the PyDTN work should be added there.
> 
> Scott
> 
> -----Original Message-----
> From: dtn <[email-masked]> On Behalf Of Brian Haberman
> Sent: Friday, March 23, 2018 1:03 AM
> To: [email-masked]
> Subject: Re: [dtn] BPbis implementation at IETF Hackathon
> 
> I would highly recommend adding an RFC 7942 section to the BPbis
> draft given the hard work done here.
> 
> Brian
> 
> On 3/22/18 9:54 PM, Spencer Dawkins at IETF wrote:
> > Speaking as the responsible AD for DTN, I'm more thrilled than
> > Scott 
> > is ;-)
> > 
> > Spencer
> > 
> > On Fri, Mar 23, 2018, 00:49 Burleigh, Scott C (312B) < 
> > [email-masked]> wrote:
> > 
> > > This really is terrific, Martin.  And much as I am in awe of you
> > > guys 
> > > being able to put this code together so fast, I am personally 
> > > gratified that the specification turned out to be implementable!
> > > 
> > > Scott
> > > 
>