Subject: [eap] reviewers for new methods

From: Jari Arkko <[email-masked]>
Date: Mon, 09 May 2005 21:47:45 +0300

Hello folks,

We have received expert review requests for EAP PSK,
EAP IKEv2, and EAP Smartcard Type. We are looking
for volunteers to work on these reviews. Let me or
Bernard know if you are interested. The purpose of
the reviews is to ensure that the said methods do
not "break EAP", i.e., they conform to RFC 3748
requirements for methods. Naturally other reviews
are also solicited, e.g., do the methods make sense
for a particular purpose.

--Jari

_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: Thomas Otto <[email-masked]>
Date: Tue, 10 May 2005 09:57:24 +0200

Am Montag, 9. Mai 2005 20:47 schrieb Jari Arkko:
> for volunteers to work on these reviews. 

I have a problem with the following. There are some
mature EAP methods, which want to proof their abilities
in real world deployments, but can not do this because
no expert is found to review the protocol.

Who is now an expert? I guess of course the authors
of the respective EAP method, which leads to the question:
May the authors volunteer self or must the reviewer be some
unbiased person? 

Assume the authors should abstain from review, then 
*who* is an expert? Which skills, grades are needed?

> Let me or Bernard know if you are interested. 

> The purpose of 
> requirements for methods. 

This kind of review is what we are talking about. 
The Review Template is available here:
http://www.drizzle.com/~aboba/EAP/template.txt

That is, if the EAP method meet all criterias in the 
catalogue, then all obstacles are overcome and an
IANA EAP Type Number can be assigned. (Right? Please
correct me..)

Then, the method can be used in real world deployments
(because supplicant and AAA both recognize the method by 
this Type Number) and authors and users are perfectly
happy.

---

From: Jari Arkko <[email-masked]>
Date: Tue, 10 May 2005 11:22:51 +0300

>May the authors volunteer self or must the reviewer be some
I think the point of the review is that its done by
some person other than the authors of the proposal!
But if you have a proposal, here's how you can help:
review some of the other proposals, then it is easier
for us to find a reviewer for your proposal.

We already have one volunteer reviewer from yesterday's
call. But ideally I'd like to get one reviewer for each
method.

>*who* is an expert? Which skills, grades are needed?
The reviewer should thoroughly understand RFC 3748.
There are no formal requirements. Most members of
this WG should be able to do it. Of course, the rules of
the IETF indicate that ADs have the final word in
the appoitment of expert reviewers.

>IANA EAP Type Number can be assigned. (Right? Please
Yes. All obstacles from the point of view of
EAP number assignment are then overcome.
Note that there may also be general IETF
requirements on actual Individual RFC
submissions, as usual.

>this Type Number) and authors and users are perfectly
The chairs of the EAP WG would be even happier
if people brought their methods to RFC status, so
that a permanent specification of methods would
be available to all. Note that the RFC 3748 rules
for EAP method type allocation actually call for
this (or some other permanent reference) since
Specification Required is indicated. From RFC 2434:

    Specification Required - Values and their meaning must be
           documented in an RFC or other permanent and readily available
           reference, in sufficient detail so that interoperability
           between independent implementations is possible.
 
--Jari