Subject: RE: [eap] channel binding

From: "Salowey, Joe" <[email-masked]>
Date: Wed, 31 Aug 2005 20:21:10 -0700

> I have a doubt about applicability of keyed MAC for a blob in 
> three-party key management system.  If the keyed MAC is 
> generated by peer and authenticator, and the authenticator 
> sends the MAC to the server (via a AAA protocol), which key 
> is used for MAC computation? 

[Joe] OK I think I see the misunderstanding.  The Keyed MAC is
transmitted as part of the Method between the EAP-Peer and the
EAP-Server.  The authenticator is not involved directly. 

> Note that AAA-Key is not used in this case because AAA-Key is 
> not yet available at the authenticator before the 
> authenticator sends the MAC to the server, for all possible 
> solutions we have discussed.
> 
> Yoshihiro Ohba
> 
> 
> > 
> > [ t. charles clancy ]--[ [email-masked] ]--[ 
> www.cs.umd.edu/~clancy ] [ 
> > computer science ]-----[ university of maryland | college park ]
> 
_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 31 Aug 2005 21:52:21 -0400

> EAP-Server.  The authenticator is not involved directly. 

OK, then the authenticator would need to send the blob itself to the
EAP-server for EAP-method based solution.

Yoshihiro Ohba