Subject: RE: [eap] channel binding

From: "Salowey, Joe" <[email-masked]>
Date: Mon, 29 Aug 2005 10:14:31 -0700

I don't think confidentiality is strictly necessary if one is
transmitting a MAC of blob of data (type 1).  In GSS-API channel
bindings explicitly state that the underlying mechanism may not provide
confidentiality so applications must take this into consideration when
providing channel binding data. 

If type 2 channel bindings are in use where data must be available on
the other side confidentiality is more of a consideration. 

Joe 

> -----Original Message-----
> From: Charles Clancy [mailto:[email-masked]] 
> Sent: Monday, August 29, 2005 9:58 AM
> To: [email-masked]
> Subject: [eap] channel binding
> 
> Channel binding transmits channel parameters between the EAP 
> client and EAP server in some protected way.  When done by 
> methods, it seems the general approach is to encrypt it (PSK, 
> TTLS, etc), guaranteeing authenticity.  Is there any reason 
> why it a MAC over the blob would be insufficient?  Is 
> confidentiality required for some reason?
> 
> I'm working on defining a protected channel in EAP-PAX for 
> communicating channel binding info, and I'd like to avoid 
> defining a symmetric-key encryption ciphersuite, as PAX is 
> based on MACs.
> 
> [ t. charles clancy ]--[ [email-masked] ]--[ 
> www.cs.umd.edu/~clancy ] [ computer science ]-----[ 
> university of maryland | college park ]
> 
> _______________________________________________
> eap mailing list
> [email-masked]
> http://mail.frascone.com/mailman/listinfo/eap
> 
_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: Jari Arkko <[email-masked]>
Date: Mon, 29 Aug 2005 20:42:57 +0300

>providing channel binding data. 
Yes.

>the other side confidentiality is more of a consideration.
This would depend on the type of data being communicated.
Type of service, identities of parties would be visible in the EAP
exchange. Whether that's a problem depends on many things,
including what the lower layer (both aaa and l2) does. Lets say
that a future l2 has some kind of a support for hiding some of
the identities involved in a network attachment. Now, if it
also protects the EAP exchange then it doesn't matter if channel
bindings are not encrypted. But if it doesn't protect EAP, then
secure information from l2 may leak out via EAP.

Also, if we develop channel bindings capability for a
parameter set now, we don't know what it will be used later
for.

--Jari