Subject: Re: [eap] Use of EMSK?

From: Jari Arkko <[email-masked]>
Date: Thu, 06 Oct 2005 18:16:59 +0300

Bernard Aboba wrote:

>> From the point of view of the EAP Keying Framework, the AMSK is 
>> calculated 
>
> in the lower layer.
>
> Therefore the issue is not how to calculate the AMSK, but how the NAS 
> communicates that it wants/needs an AMSK, how legacy and upgraded AAA 
> servers respond to that request, and what the structure of the AMSK 
> cache is on the EAP peer, authenticator and AAA server.
>
> As far as I know, there is no document that answers these questions.

Right. Dave's proposal to use EMSK for purpose X would have to
cover these issues.

--Jari

_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: Julien Bournelle <[email-masked]>
Date: Thu, 6 Oct 2005 17:56:33 +0200

Hi all,

 I have a quick comment below:

> >cache is on the EAP peer, authenticator and AAA server.

 basically we had a use of AMSK for mip6 where the NAS(EAP
 authenticator) is not required
 to ask for the AMSK. Only the EAP client (MN) and AAA server (on which
 the EAP server is supposed to be colocated) needs to know that they should
 derive the AMSK. (This mip6-amsk is then provided to the HA.)

 As the i-d has expired, the draft can be found here:
 http://www.watersprings.org/pub/id/draft-giaretta-mip6-amsk-00.txt

 Maybe we're doing something wrong so any comments welcome.

-- 
julien.bournelle at int-evry.fr
_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap