Subject: [eap] EAP WG agenda (updated)

From: Jari Arkko <[email-masked]>
Date: Fri, 04 Nov 2005 21:16:16 +0200

IETF-64 EAP WG Agenda

Time:
 MONDAY, November 7, 2005,
 0900-1130 Morning Session I
 (Opposite to apptsv, dnsext, grow, ccmap, pkix, and ippm.)

Chairs:
 Bernard Aboba <[email-masked]>
 Jari Arkko <[email-masked]>

PRELIMINARIES (10 minutes)

 Bluesheets
 Agenda Bash
 Document Status
 Open Issue Summary:
 http://www.drizzle.com/~aboba/EAP/eapissues.html
 Presentations and agenda online at:
 http://www.drizzle.com/~aboba/IETF64/eap/

EAP Network Discovery and Selection (25 min)

 Problem Definition (Jouni Korhonen)
 http://www.ietf.org/internet-drafts/draft-ietf-eap-netsel-problem-03.txt
 - We would like to complete this document with respect to
   what is known in 2005, and publish it as an Informational RFC.
 - Jouni and Farooq have agreed to edit this draft.
 - Discussion of remaining issues.

Keying Issues, Base (60 min)

 Keying Framework (Bernard Aboba)
 http://www.ietf.org/internet-drafts/draft-ietf-eap-keying-08.txt
 - To appear
 - This document will be in WGLC once it appears
 - Discussion of last call comments

Keying Issues, Extensions (30 min)

 Keying Extensions (Bernard Aboba)
 http://www.drizzle.com/~aboba/EAP/draft-aboba-eap-keying-extns-00.txt
 - Discussion about what, if anything, we need to do
   here. Gauging community interest.

 EAP Support for Handovers (Madjid Nakhjiri)
 http://www.ietf.org/internet-drafts/draft-nakhjiri-eap-ho-00.txt
 - Discussion. Are there requirements for keying
   extensions.

Note that we intend to discuss EAP method related things in the EMU
slot, not in the EAP slot.

_______________________________________________
eap mailing list
[email-masked]
http://lists.frascone.com/mailman/listinfo/eap

---

From: Mayumi Yanagiya <[email-masked]>
Date: Mon, 07 Nov 2005 16:35:02 +0900

Hi,

I can’t attend this meeting. Could I ask a question about “Keying 
Extensions” on this list?

In that draft, it is specified that only EAP entities can use EAP keys 
for authentication.  But, I think that it will be useful to extend EAP 
key framework to non-EAP entities such as HA which may use non-EAP 
authentication method.

Are there any problems if we apply EAP key framework to non-EAP entities?

--Mayumi

---

From: Jari Arkko <[email-masked]>
Date: Mon, 07 Nov 2005 16:12:28 +0200

> Are there any problems if we apply EAP key framework to non-EAP entities?

Its hard to give an answer without talking about the specific keys
in question. I hope the draft is clear that long-term secrets, MKs,
TEKs, MSKs, EMSKs are indeed only for specific EAP entities.
Having said that, I see no reason to prohibit the use of AMSKs
or even TSKs in a wider context, e.g., the delivery of keys delivered
from AMSKs for some fast-handoff entity that did not do EAP.
Of course, such usage would have to be well designed to
avoid problems and make sense from other points of view,
but there should not be any fundamental reason to prevent
this in the EAP keying framework.

One current issue that is preventing this in practise, however,
is that -08 does not define the AMSKs. My suggestion would be
to define it, which would allow usage of AMSKs (with the good
design) without the need for EAP WG to respin the keying
framework document or add new extensions.

--Jari

---

From: Mayumi Yanagiya <[email-masked]>
Date: Tue, 08 Nov 2005 20:13:48 +0900

Thank you for your reply.

 > this in the EAP keying framework.

I intended to discuss about AMSKs and TSKs usage.
I’m very happy to hear that there is no problem to use AMSK for non-EAP 
entity. I’ve submitted a draft about this concept in order to reduce 
pre-setting of authentication information (It has been expired). And, I 
read that mip6 ML have started discussion about usage of AMSK for mipv6 
bootstrapping.

 > framework document or add new extensions.

Originally, AMSK was defined in the key framework draft as appendix, 
wasn’t it? I haven't caught up the reason why the specification of AMSK 
is separated from main key framework draft.

--Mayumi