Subject: RE: [eap] WGLC for eap-keying: EAP server-AAA server

From: "Nakhjiri Madjid-MNAKHJI1" <[email-masked]>
Date: Wed, 2 Nov 2005 18:28:30 -0500

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Bernard Aboba
Sent: Tuesday, November 01, 2005 1:21 PM
To: [email-masked]; [email-masked]
Subject: RE: [eap] WGLC for eap-keying: EAP server-AAA server

>1) EIK | PMK =truncate (MSK, 320)
>2) PMK2= truncate (MSK, 160)

Both of these definitions imply that the PMK is a truncated version of
the 
MSK.   Perhaps we can just point that out, and reference 802.11 and
802.16e. 
   There really is not much need to say anything more than that.

Madjid>> My point exactly, except even that is may be too much. What if
it was not a truncation? PMK creation, is really a lower layer issue.

>[Joe] The choice of AAA-Key term in the EAP RFC was unfortunate, it 
>think it would have been better if we stuck just with the MSK.

Yes.  The term "AAA-Key" has been the source of much confusion.   It
took 
quite a while, but at this point, the term is only used once in the EAP
Keying Framework (in the terminology seciton).

Madjid>> Ok, if you say so. But it is still heavily used in 3748 and in
extension drafts 

"AAA-Key-B = prf(AMSK(0,63),"EAP AAA-Key derivation for
                  multiple attachments", AAA-Key, B-Called-Station-Id,
                  Calling-Station-Id,length)"

>Existing lower layers already use the MSK directly so I don't think 
>defining AMSKs derived from this quantity is appropriate in this 
>document.

Right.

_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap
_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: Jari Arkko <[email-masked]>
Date: Mon, 07 Nov 2005 15:19:49 +0200

>it was not a truncation? PMK creation, is really a lower layer issue.
Suggested text:

Pairwise Master Key (PMK)
Lower layers use MSK in lower-layer dependent manner.
For instance, in [IEEE-802.11i] Octets 0-31 of the MSK
are known as the Pairwise Master Key (PMK). In
[IEEE-802.11i] the TKIP and AES CCMP ciphersuites derive
their Transient Session Keys (TSKs) solely from the PMK, whereas
the WEP ciphersuite as noted in [RFC3580], derives its TSKs from
both halves of the MSK. In [802.16e], the MSK is truncated to
40 octets for PMK and 20 octets for PMK2.

and delete PMK usage from Appendix A.

>                  Calling-Station-Id,length)"
The extension document is not currently on the table,
and there may well be other approaches (e.g. yours).
But I would point out that the "AAA-Key-B" really has
nothing to do with the current AAA-Key; its a completely
different quantity that could be used in handoffs.
We can name it to whatever we want.

--Jari

_______________________________________________
eap mailing list
[email-masked]
http://lists.frascone.com/mailman/listinfo/eap