Subject: RE: [eap] Strawman -10/EMSK deletion requirement?

From: "Avi Lior" <[email-masked]>
Date: Mon, 13 Mar 2006 02:41:23 -0500

HI Jari,

I thought we would be done by now :-)  See inline.... 

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]] 
> Sent: Sunday, March 12, 2006 2:26 PM
> To: Avi Lior
> Cc: [email-masked]
> Subject: Re: [eap] Strawman -10/EMSK deletion requirement?
> 
> Avi Lior wrote:
> 
> >>The role of the
> >>EAP keying framework is to leave some key material in the 
> EAP server 
> >>to enable such functionality, but if we are going to use 
> it, we will 
> >>need, among other things, protocol descriptions on how RADIUS can 
> >>retrieve pieces of this key information and how particular 
> >>applications employ these keys.
> >>    
> >>
> >
> >If RADIUS is colocated with EAP-server do we need to define 
> a protocol 
> >for getting the AMSK(s)?
> >  
> >
> 
> I do not think we need a protocol definition between the AAA 
> and EAP layers; this is mostly an API in any case.

What about the API to fetch the MSK? Or to Push the MSK?
What about the API to send the EAP message from the AAA to the EAP AS?
What about the API to retrieve the EAP message from the EAP-AS?
Etc....why are we forgetting these as well?

> --Jari
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/eap

Arhives: http://lists.frascone.com/pipermail/eap

---

From: Jari Arkko <[email-masked]>
Date: Mon, 13 Mar 2006 10:29:53 +0200

>Etc....why are we forgetting these as well?
I am not saying that they are not needed. The question is
whether the IETF wants to get into the business of standardizing
such APIs. We mostly deal with what happens on the wire, in
protocols.

--Jari