Subject: Channel binding approaches (Was: Re: [eap] Strawman -10)

From: Jari Arkko <[email-masked]>
Date: Sun, 05 Mar 2006 21:40:45 +0200

The channel binding discussion has been interesting. I can
actually see a number of different alternatives even
within Yoshihiro's method. For instance, L2 could negotiate
the use of channel bindings and have AAA inform the server
of the need to use MSK_cb instead of the regular MSK. Or
EAP method could negotiate this. Or the use of channel
bindings would be dictated by the used lower layer,

I'm not sure which approach is the best one; there
are tradeoffs. Generally I like approaches where
we don't need to change EAP methods but YMMV.

In any case, I'm happy with what the -10 says about
channel bindings, and perhaps the results of this
discussion can be incorporated to Yoshihiro's draft.

--Jari

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/eap

Arhives: http://lists.frascone.com/pipermail/eap

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 8 Mar 2006 11:43:33 -0500

I agree that there can be several alternatives within my channel
binding approach.

I'd be happy to discuss such alternatives in my draft.  Then the
question is in which WG can we discuss my draft if EAP WG is
closed?

Best regards,
Yoshihiro Ohba