Subject: [EAT] Preliminary RATS BoF Agenda

From: Henk Birkholz <[email-masked]>
Date: Sat, 20 Oct 2018 12:41:47 +0200

Hi all,

please find below a first agenda draft for the RATS BoF ("may be subject 
to change") create by the BoF proponents. In order to support the 
discussion about intersection of RATS and EAT, we reserved a 
presentation slot for the EAT draft.

> RATS BOF Agenda at IETF 103 in Bangkok, Thailand
> Tuesday, November 6th, 2018, Chitlada 2
> Afternoon Session I 1350-1550 (UTC+7)
> 
> https://datatracker.ietf.org/meeting/103/floor-plan?room=chitlada-2
> 
> 0)  Minute Takers, Jabber Scribe, Bluesheets (chairs)
> 
> 1)  Hello Room & Agenda Bash (chairs)
> 
> 2)  Introduction & Summary of Current IETF Work (Ned & Henk)
> 
> 3)  The Entity Attestation Token (TBD)
> 
> 4)  Compromise Trustworthy Visibility in Working Systems (Eric)
> 
> 5)  Charter Text Discussion (Ned & Henk)
> 
> 6)  Wrap Up (chairs) 

The current plan is to limit presentations to approx. 15 min or shorter 
- item 5 is an exception to this rule as it is intended to be a kick-off 
presentation to start charter discussions in the time remaining until 
wrap up.

Viele Grüße,

Henk

---

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 20 Oct 2018 16:21:07 +0000

Hi Henk,

Could you say something more about agenda item #4 called "Compromise Trustworthy Visibility in Working Systems"?

Agenda item #2 sounds a bit like you would be talking about RATS drafts? Correct?

I am missing a "Here is the problem we are solving and this is why we will make the Internet work better" presentation.

Ciao
Hannes

-----Original Message-----
From: EAT <[email-masked]> On Behalf Of Henk Birkholz
Sent: Saturday, October 20, 2018 3:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [EAT] Preliminary RATS BoF Agenda

Hi all,

please find below a first agenda draft for the RATS BoF ("may be subject to change") create by the BoF proponents. In order to support the discussion about intersection of RATS and EAT, we reserved a presentation slot for the EAT draft.

> RATS BOF Agenda at IETF 103 in Bangkok, Thailand Tuesday, November
> 6th, 2018, Chitlada 2 Afternoon Session I 1350-1550 (UTC+7)
>

The current plan is to limit presentations to approx. 15 min or shorter
- item 5 is an exception to this rule as it is intended to be a kick-off presentation to start charter discussions in the time remaining until wrap up.

Viele Grüße,

Henk

_______________________________________________
EAT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/eat
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Sun, 21 Oct 2018 13:19:35 +0000

> From: Hannes Tschofenig, October 20, 2018 12:21 PM
> 
> Hi Henk,
> 
> Could you say something more about agenda item #4 called "Compromise
> Trustworthy Visibility in Working Systems"?

Hi Hannes,

I will be doing agenda item #4.  Basically this agenda item was added to address a question raised on earlier on the RATS/EAT threads: is there a real business problem here?

To me the answer is yes.  For over a year Cisco has offered a controller based Integrity Verification application.  This application does remote attestation for routers.  See:
https://www.cisco.com/c/dam/en/us/td/docs/cloud-systems-management/application-policy-infrastructure-controller-enterprise-module/1-5-x/integrity_verification/user-guide/Cisco_Integrity_Verification_Application_APIC-EM_User_Guide_1_5_0_x.pdf

Agenda item #4 will give a brief demo of production PCR results flowing up to a monitoring application, talk about some lessons learned, and give an idea of where proposed WG efforts might help future types of router to controller communications.

Eric

> please find below a first agenda draft for the RATS BoF ("may be subject to
> change") create by the BoF proponents. In order to support the discussion
> about intersection of RATS and EAT, we reserved a presentation slot for the
> EAT draft.
> 
> presentation to start charter discussions in the time remaining until wrap up.
> 
> Viele Grüße,
> 
> Henk
> 
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended recipient,
> please notify the sender immediately and do not disclose the contents to any
> other person, use it for any purpose, or store or copy the information in any
> medium. Thank you.

---

From: Laurence Lundblade <[email-masked]>
Date: Sun, 21 Oct 2018 20:02:08 +0530

> On Oct 21, 2018, at 6:49 PM, Eric Voit (evoit) <[email-masked]> wrote:
> 
> https://www.cisco.com/c/dam/en/us/td/docs/cloud-systems-management/application-policy-infrastructure-controller-enterprise-module/1-5-x/integrity_verification/user-guide/Cisco_Integrity_Verification_Application_APIC-EM_User_Guide_1_5_0_x.pdf <https://www.cisco.com/c/dam/en/us/td/docs/cloud-systems-management/application-policy-infrastructure-controller-enterprise-module/1-5-x/integrity_verification/user-guide/Cisco_Integrity_Verification_Application_APIC-EM_User_Guide_1_5_0_x.pdf>

Eric, thanks for sharing that. I read it carefully and that helps me understand quite a lot in a more concrete way. Even looked at the KGV tar ball. In a lot of ways this isn’t too different some EAT uses on mobile phones where the idea is to use TrustZone, virtualization and other HW architectures to measure Android.

I’m guessing a lot of this is implemented with TPMs and TCG ideas.  Is that right? If you can share implementation HW specifics, then I won’t have to guess and have a lower probability of saying dumb things, but understand if that is highly proprietary. 

LL

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Sun, 21 Oct 2018 17:32:32 +0000

From: Laurence Lundblade, October 21, 2018 10:32 AM

On Oct 21, 2018, at 6:49 PM, Eric Voit (evoit) <[email-masked]<mailto:[email-masked]>> wrote:

<Eric>

Hi Lawrence,

Cisco has a variety of off-the-shelf and custom hardware implementations of the TCG ideas across dozens of its products.  I believe this effort has the potential to normalize much of the software between these variations of hardware and the application layer.

Eric

LL

---

From: Michael Richardson <[email-masked]>
Date: Mon, 22 Oct 2018 17:17:16 -0400

Hannes Tschofenig <[email-masked]> wrote:
    > I am missing a "Here is the problem we are solving and this is why we
    > will make the Internet work better" presentation.

+1.

Background material is welcome, but I'm not seeing a charter.
I keep seeing introductory text that belongs in an overview, roadmap or
requirements document (but I don't know which, because the charter hasn't
told me how we are running things)

Also, I don't know how eat@ and rats@ differ, so maybe we can just get rid of
one of these lists?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 22 Oct 2018 23:35:45 +0200

> Background material is welcome, but I’m not seeing a charter.

One problem with writing a charter in an area without accepted terminology is that you need a source of that terminology.
The IESG generally frowns upon a WG defining the terminology used in the charter in an I-D, as this means the WG can change the meaning of the charter unilaterally.  So there is a need for some terminology definitions, more than usually in a charter.

> told me how we are running things)

Now that looks like a problem, indeed.

> Also, I don’t know how eat@ and rats@ differ,

EAT is one technical approach (put claim sets into CWTs), which I like.  
RATS has some additional requirements that are harder to do in a CWT (of course, anything can be packaged in a CWT if you really want — RATS is really more about workflows that involve evidence and tend to be more complicated than just signing a few CWTs and checking those signatures).

> so maybe we can just get rid of
> one of these lists?

Whenever we know the name of the new WG, we can get rid of both.

Grüße, Carsten